]> git.pld-linux.org Git - packages/firefox.git/blame - mozilla-firefox.spec
- merged from DEVEL
[packages/firefox.git] / mozilla-firefox.spec
CommitLineData
0d00fa1b 1# TODO:
2a673919 2# - crashreporter does not seem to be built on ac nor th
0d00fa1b
AM
3# - handle locales differently (runtime, since it's possible to do)
4# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
f37c2ce5
ER
5# for hints how to make locales
6# - make it more pld-like (bookmarks, default page etc..)
2a673919 7# - system nss, xulrunner
2f695f11 8#
ca6a7239 9# Conditional build:
4ab16c9e
JB
10%bcond_with tests # enable tests (whatever they check)
11%bcond_without gnomeui # disable gnomeui support
12%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
2a673919
PZ
14%bcond_without kerberos # disable krb5 support
15
4ab16c9e
JB
16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
2a673919
PZ
20
21%define ver 3.0
22
52dbdf60 23Summary: Firefox Community Edition web browser
948d1385 24Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
ea721d92 25Name: mozilla-firefox
2a673919 26Version: %{ver}
8bc15110 27Release: 2
4ab16c9e 28License: MPL 1.1 or GPL v2+ or LGPL v2.1+
51c0f20a 29Group: X11/Applications/Networking
8359e4e0 30Source0: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
2a673919 31# Source0-md5: 4210ae0801df2eb498408533010d97c1
7c7475d0 32Source1: %{name}.desktop
33Source2: %{name}.sh
2a673919
PZ
34Patch0: %{name}-install.patch
35Patch1: %{name}-agent.patch
36Patch2: %{name}-agent-ac.patch
37Patch3: %{name}-gcc3.patch
5f561b4c 38URL: http://www.mozilla.org/projects/firefox/
4ab16c9e 39%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
e933d2a8 40BuildRequires: automake
2a673919
PZ
41BuildRequires: cairo-devel >= 1.6.0
42BuildRequires: glib2-devel
4ab16c9e 43%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
2a673919
PZ
44BuildRequires: gtk+2-devel >= 2:2.10
45%if "%{pld_release}" == "ac"
46%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
47%else
48%{?with_kerberos:BuildRequires: krb5-devel}
49%endif
8a88dcf7 50BuildRequires: libIDL-devel >= 0.8.0
4ab16c9e
JB
51%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
52%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
ea721d92 53BuildRequires: libjpeg-devel >= 6b
2a673919 54BuildRequires: libpng(APNG)-devel >= 0.10
1dd3785b 55BuildRequires: libpng-devel >= 1.2.7
ea721d92 56BuildRequires: libstdc++-devel
4d687af8 57BuildRequires: myspell-devel
2a673919 58BuildRequires: nspr-devel >= 1:4.7
f37c2ce5 59BuildRequires: nss-devel >= 1:3.11.3-3
56cf7ebf 60BuildRequires: pango-devel >= 1:1.6.0
61BuildRequires: perl-modules >= 5.004
1bb00684 62BuildRequires: pkgconfig
6b1581cf 63BuildRequires: rpm >= 4.4.9-56
2a673919
PZ
64BuildRequires: rpmbuild(macros) >= 1.453
65BuildRequires: startup-notification-devel
446ffaab
JB
66BuildRequires: xorg-lib-libXext-devel
67BuildRequires: xorg-lib-libXft-devel >= 2.1
68BuildRequires: xorg-lib-libXinerama-devel
69BuildRequires: xorg-lib-libXp-devel
de5abc0a 70BuildRequires: xorg-lib-libXt-devel
b0a3aa79 71BuildRequires: zip
1dd3785b 72BuildRequires: zlib-devel >= 1.2.3
f37c2ce5 73Requires(post): mktemp >= 1.5-18
1408fb17 74Requires: browser-plugins >= 2.0
2a673919
PZ
75Requires: cairo >= 1.6.0
76Requires: libpng(APNG) >= 0.10
77Requires: nspr >= 1:4.7
78Requires: nss >= 1:3.11.3-3
0d52cac8 79Provides: wwwbrowser
51c0f20a 80Obsoletes: mozilla-firebird
2620301e 81Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
c2814220 82Obsoletes: mozilla-firefox-libs
ea721d92 83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
34dd92dd
JB
85# firefox/thunderbird/seamonkey provide their own versions
86%define _noautoreqdep libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
6162f349 87%define _noautoprovfiles %{_libdir}/%{name}/components
4c7e703c 88# we don't want these to satisfy xulrunner-devel
626daa28 89%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
4c7e703c 90# and as we don't provide them, don't require either
626daa28 91%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
c14d6140 92
2a673919 93%if "%{cc_version}" >= "3.4"
2de50ddb 94%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
2a673919
PZ
95%else
96%define specflags -fno-strict-aliasing
97%endif
d3b02e37 98
ea721d92 99%description
52dbdf60
ER
100Firefox Community Edition is an open-source web browser, designed for
101standards compliance, performance and portability.
ea721d92 102
eace6cdf 103%description -l pl.UTF-8
c0bec9dd 104Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
e236f127 105zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
106o zgodności ze standardami, wydajnością i przenośnością.
ea721d92 107
108%prep
2a673919 109%setup -qc -n %{name}-%{version}
56143477 110cd mozilla
d541162e 111%patch0 -p1
2a673919 112%if "%{pld_release}" == "ac"
8bc15110 113%patch2 -p1
6b1581cf 114%else
2a673919
PZ
115%patch1 -p1
116%endif
117%if "%{cc_version}" < "3.4"
118%patch3 -p2
6b1581cf 119%endif
a4a42caf 120
ea721d92 121%build
56143477 122cd mozilla
52befddb 123cp -f %{_datadir}/automake/config.* build/autoconf
124cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
52befddb 125
52befddb 126cat << 'EOF' > .mozconfig
127. $topsrcdir/browser/config/mozconfig
128
2620301e 129mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
2620301e 130
f37c2ce5 131# Options for 'configure' (same as command-line options).
52befddb 132ac_add_options --prefix=%{_prefix}
133ac_add_options --exec-prefix=%{_exec_prefix}
134ac_add_options --bindir=%{_bindir}
135ac_add_options --sbindir=%{_sbindir}
136ac_add_options --sysconfdir=%{_sysconfdir}
137ac_add_options --datadir=%{_datadir}
138ac_add_options --includedir=%{_includedir}
139ac_add_options --libdir=%{_libdir}
140ac_add_options --libexecdir=%{_libexecdir}
141ac_add_options --localstatedir=%{_localstatedir}
142ac_add_options --sharedstatedir=%{_sharedstatedir}
143ac_add_options --mandir=%{_mandir}
144ac_add_options --infodir=%{_infodir}
cf471ce5 145%if %{?debug:1}0
f37c2ce5 146ac_add_options --disable-optimize
52befddb 147ac_add_options --enable-debug
148ac_add_options --enable-debug-modules
f37c2ce5
ER
149ac_add_options --enable-debugger-info-modules
150ac_add_options --enable-crash-on-assert
52befddb 151%else
152ac_add_options --disable-debug
2620301e 153ac_add_options --disable-debug-modules
f37c2ce5 154ac_add_options --disable-logging
2a673919 155ac_add_options --enable-optimize="%{rpmcflags} -Os"
52befddb 156%endif
157%if %{with tests}
158ac_add_options --enable-tests
c4f9bb37 159%else
52befddb 160ac_add_options --disable-tests
c4f9bb37 161%endif
6800f9e1 162%if %{with gnomeui}
f37c2ce5
ER
163ac_add_options --enable-gnomeui
164%else
f37c2ce5
ER
165ac_add_options --disable-gnomeui
166%endif
6800f9e1
JB
167%if %{with gnomevfs}
168ac_add_options --enable-gnomevfs
169%else
170ac_add_options --disable-gnomevfs
171%endif
2a673919 172ac_add_options --disable-crashreporter
52befddb 173ac_add_options --disable-installer
f37c2ce5
ER
174ac_add_options --disable-javaxpcom
175ac_add_options --disable-updater
2a673919
PZ
176ac_add_options --disable-strip
177ac_add_options --disable-xprint
178ac_add_options --enable-startup-notification
164d575d 179ac_add_options --enable-svg
52befddb 180ac_add_options --enable-system-cairo
4d687af8 181ac_add_options --enable-system-myspell
2a673919
PZ
182ac_add_options --enable-libxul
183ac_add_options --enable-xinerama
f37c2ce5 184ac_add_options --with-distribution-id=org.pld-linux
2a673919 185ac_add_options --with-pthreads
2620301e 186ac_add_options --with-system-jpeg
52befddb 187ac_add_options --with-system-nspr
f37c2ce5 188ac_add_options --with-system-nss
f37c2ce5 189ac_add_options --with-system-png
2620301e 190ac_add_options --with-system-zlib
6162f349 191ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
52befddb 192EOF
33f81726 193
1698621e 194%{__make} -j1 -f client.mk build \
2a673919 195 STRIP="/bin/true" \
3d445135 196 CC="%{__cc}" \
33f81726 197 CXX="%{__cxx}"
ea721d92 198
199%install
200rm -rf $RPM_BUILD_ROOT
56143477 201cd mozilla
45f27404 202install -d \
f37c2ce5 203 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
45f27404 204 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
93639547 205 $RPM_BUILD_ROOT%{_datadir}/%{name}
75e09104 206
8bc15110
PZ
207%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
208
2a673919 209%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
d541162e 210 DESTDIR=$RPM_BUILD_ROOT \
6162f349 211 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
f37c2ce5 212 PKG_SKIP_STRIP=1
ea721d92 213
f86547d4
ER
214# move arch independant ones to datadir
215mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
216mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
f86547d4
ER
217mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
218mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
219mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
2a673919 220mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
f86547d4
ER
221mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
222mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
223ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
224ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
f86547d4
ER
225ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
226ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
2a673919 227ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
f86547d4 228ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
f86547d4
ER
229ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
230ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
231
ade6d95c 232rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
4d687af8
ER
233ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
234
7c7475d0 235sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
8bc15110 236ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
ea721d92 237
f37c2ce5 238install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
ea721d92 239
7c7475d0 240install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
ea721d92 241
f37c2ce5 242# files created by regxpcom and firefox -register
6162f349
ER
243touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
244touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
f37c2ce5 245
f86547d4
ER
246# what's this? it's content is invalid anyway.
247rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
a42140da 248rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
f86547d4 249
f37c2ce5 250cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
6d77929c 251#!/bin/sh
050f03d2 252umask 022
6162f349 253rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
3eeab518 254
f37c2ce5
ER
255# it attempts to touch files in $HOME/.mozilla
256# beware if you run this with sudo!!!
257export HOME=$(mktemp -d)
258# also TMPDIR could be pointing to sudo user's homedir
259unset TMPDIR TMP || :
3eeab518 260
2a673919 261#LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
6162f349 262%{_libdir}/%{name}/firefox -register
3eeab518 263
56143477 264rm -rf $HOME
6d77929c 265EOF
3eeab518 266
6d77929c
JB
267%clean
268rm -rf $RPM_BUILD_ROOT
3eeab518 269
b1662829 270%pretrans
ade6d95c
ER
271if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
272 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
273fi
2a673919 274for d in chrome defaults extensions greprefs icons res searchplugins; do
f86547d4
ER
275 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
276 install -d %{_datadir}/%{name}
277 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
278 fi
279done
280exit 0
281
6d77929c 282%post
f37c2ce5 283%{_sbindir}/%{name}-chrome+xpcom-generate
4d9eecad
ER
284%update_browser_plugins
285
286%postun
287if [ "$1" = 0 ]; then
288 %update_browser_plugins
289fi
ea0245e6 290
ea721d92 291%files
292%defattr(644,root,root,755)
f37c2ce5 293%attr(755,root,root) %{_bindir}/%{name}
fb0d8197 294%attr(755,root,root) %{_bindir}/firefox
f37c2ce5
ER
295%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
296
4d9eecad
ER
297# browser plugins v2
298%{_browserpluginsconfdir}/browsers.d/%{name}.*
299%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
300
c2814220
ER
301%dir %{_libdir}/%{name}
302%attr(755,root,root) %{_libdir}/%{name}/*.so
2a673919
PZ
303%{_libdir}/%{name}/blocklist.xml
304
305%if %{with crashreporter}
306%{_libdir}/%{name}/crashreporter
307%{_libdir}/%{name}/crashreporter-override.ini
308%{_libdir}/%{name}/crashreporter.ini
309%{_libdir}/%{name}/Throbber-small.gif
310%endif
311
312# config?
313%{_libdir}/%{name}/.autoreg
314%{_libdir}/%{name}/application.ini
315%{_libdir}/%{name}/platform.ini
316# XXX: nss
317%{_libdir}/%{name}/libfreebl3.chk
318%{_libdir}/%{name}/libsoftokn3.chk
c2814220 319
6162f349 320%dir %{_libdir}/%{name}/components
2a673919
PZ
321
322%{_libdir}/%{name}/components/aboutRobots.js
fd4f0696
ER
323%{_libdir}/%{name}/components/FeedConverter.js
324%{_libdir}/%{name}/components/FeedProcessor.js
fd4f0696 325%{_libdir}/%{name}/components/FeedWriter.js
2a673919
PZ
326%{_libdir}/%{name}/components/WebContentConverter.js
327%{_libdir}/%{name}/components/browser.xpt
328%{_libdir}/%{name}/components/fuelApplication.js
fd4f0696 329%{_libdir}/%{name}/components/jsconsole-clhandler.js
2a673919
PZ
330%{_libdir}/%{name}/components/nsAddonRepository.js
331%{_libdir}/%{name}/components/nsBlocklistService.js
fd4f0696 332%{_libdir}/%{name}/components/nsBrowserGlue.js
2a673919
PZ
333%{_libdir}/%{name}/components/nsContentDispatchChooser.js
334%{_libdir}/%{name}/components/nsContentPrefService.js
fd4f0696 335%{_libdir}/%{name}/components/nsDefaultCLH.js
2a673919 336%{_libdir}/%{name}/components/nsDownloadManagerUI.js
fd4f0696
ER
337%{_libdir}/%{name}/components/nsExtensionManager.js
338%{_libdir}/%{name}/components/nsFilePicker.js
2a673919 339%{_libdir}/%{name}/components/nsHandlerService.js
fd4f0696 340%{_libdir}/%{name}/components/nsHelperAppDlg.js
2a673919
PZ
341%{_libdir}/%{name}/components/nsLivemarkService.js
342%{_libdir}/%{name}/components/nsLoginInfo.js
343%{_libdir}/%{name}/components/nsLoginManager.js
344%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
fd4f0696 345%{_libdir}/%{name}/components/nsMicrosummaryService.js
2a673919 346%{_libdir}/%{name}/components/nsPlacesTransactionsService.js
fd4f0696 347%{_libdir}/%{name}/components/nsProxyAutoConfig.js
fd4f0696
ER
348%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
349%{_libdir}/%{name}/components/nsSearchService.js
350%{_libdir}/%{name}/components/nsSearchSuggestions.js
351%{_libdir}/%{name}/components/nsSessionStartup.js
352%{_libdir}/%{name}/components/nsSessionStore.js
353%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
354%{_libdir}/%{name}/components/nsSidebar.js
2a673919
PZ
355%{_libdir}/%{name}/components/nsTaggingService.js
356%{_libdir}/%{name}/components/nsTryToClose.js
357%{_libdir}/%{name}/components/nsURLFormatter.js
fd4f0696
ER
358%{_libdir}/%{name}/components/nsUpdateService.js
359%{_libdir}/%{name}/components/nsUrlClassifierLib.js
360%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
2a673919
PZ
361%{_libdir}/%{name}/components/nsWebHandlerApp.js
362%{_libdir}/%{name}/components/pluginGlue.js
363%{_libdir}/%{name}/components/storage-Legacy.js
364%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
365%{_libdir}/%{name}/components/nsBrowserContentHandler.js
366
367%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
368%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
369%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
370%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
371
372%if %{with gnomevfs}
373%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
374%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
375%endif
376
6162f349
ER
377%dir %{_libdir}/%{name}/plugins
378%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
6162f349 379%attr(755,root,root) %{_libdir}/%{name}/*.sh
2a673919
PZ
380%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
381%attr(755,root,root) %{_libdir}/%{name}/firefox
382%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
93639547
ER
383%{_pixmapsdir}/mozilla-firefox.png
384%{_desktopdir}/mozilla-firefox.desktop
cdbdbff1 385
f86547d4
ER
386# symlinks
387%{_libdir}/%{name}/chrome
388%{_libdir}/%{name}/defaults
389%{_libdir}/%{name}/dictionaries
390%{_libdir}/%{name}/extensions
391%{_libdir}/%{name}/greprefs
392%{_libdir}/%{name}/icons
2a673919 393%{_libdir}/%{name}/modules
f86547d4
ER
394%{_libdir}/%{name}/res
395%{_libdir}/%{name}/searchplugins
f37c2ce5
ER
396
397# browserconfig
6162f349 398%{_libdir}/%{name}/browserconfig.properties
f37c2ce5 399
6162f349 400%{_libdir}/%{name}/README.txt
f86547d4
ER
401
402%dir %{_datadir}/%{name}
403%{_datadir}/%{name}/chrome
404%{_datadir}/%{name}/defaults
f86547d4
ER
405%{_datadir}/%{name}/greprefs
406%{_datadir}/%{name}/icons
2a673919 407%{_datadir}/%{name}/modules
f86547d4
ER
408%{_datadir}/%{name}/res
409%{_datadir}/%{name}/searchplugins
410
411%dir %{_datadir}/%{name}/extensions
412# -dom-inspector subpackage?
2a673919 413#%{_datadir}/%{name}/extensions/inspector@mozilla.org
f86547d4
ER
414# the signature of the default theme
415%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
f37c2ce5
ER
416
417# files created by regxpcom and firefox -register
6162f349
ER
418%ghost %{_libdir}/%{name}/components/compreg.dat
419%ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.105762 seconds and 4 git commands to generate.