]> git.pld-linux.org Git - packages/findutils.git/commitdiff
- one more fix from fc auto/th/findutils-4.6.0-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Jun 2016 22:07:27 +0000 (00:07 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Jun 2016 22:07:27 +0000 (00:07 +0200)
findutils-4.6.0-mbrtowc-tests.patch [new file with mode: 0644]
findutils.spec

diff --git a/findutils-4.6.0-mbrtowc-tests.patch b/findutils-4.6.0-mbrtowc-tests.patch
new file mode 100644 (file)
index 0000000..a140654
--- /dev/null
@@ -0,0 +1,35 @@
+From 06a46ba755195810f2aeda01b12d1ccfe7c2dcfd Mon Sep 17 00:00:00 2001
+From: Daiki Ueno <ueno@gnu.org>
+Date: Mon, 28 Dec 2015 06:27:42 +0900
+Subject: [PATCH] maint: fix operator precedence in mbrtowc test
+
+This is a fix for test breakage introduced by commit 45228d96; the
+equality expression must be parenthesized when negated with '!',
+otherwise we always get:
+
+  test-mbrtowc.c:49: assertion 'ret == (size_t)(-2)' failed
+
+* m4/mbrtowc.m4 (gl_MBRTOWC_EMPTY_INPUT): Negate the entire expression.
+
+Upstream-commit: 1f63650823cebf52044df840c81062ccb52163a2
+Signed-off-by: Kamil Dudka <kdudka@redhat.com>
+---
+ gl/m4/mbrtowc.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gl/m4/mbrtowc.m4 b/gl/m4/mbrtowc.m4
+index deb9f06..be2e9d6 100644
+--- a/gl/m4/mbrtowc.m4
++++ b/gl/m4/mbrtowc.m4
+@@ -569,7 +569,7 @@ changequote([,])dnl
+            int
+            main (void)
+            {
+-             return ! mbrtowc (&wc, "", 0, &mbs) == (size_t) -2;
++             return mbrtowc (&wc, "", 0, &mbs) != (size_t) -2;
+            }]])],
+         [gl_cv_func_mbrtowc_empty_input=yes],
+         [gl_cv_func_mbrtowc_empty_input=no],
+-- 
+2.5.0
+
index de2c1f0306e7dafb8a1216192b9cae5c1bd4562c..8578df2ccbb3d2ecba9e808447e8973f5a8673f3 100644 (file)
@@ -26,6 +26,7 @@ Patch1:               %{name}-man-selinux.patch
 Patch2:                %{name}-info.patch
 # http://translationproject.org/latest/findutils/pl.po
 Patch3:                %{name}-pl.po-update.patch
+Patch4:                findutils-4.6.0-mbrtowc-tests.patch
 URL:           http://www.gnu.org/software/findutils/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -89,6 +90,7 @@ arayabilirsiniz.
 # patch1 is applied in install stage
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.033151 seconds and 4 git commands to generate.