]> git.pld-linux.org Git - packages/filtergen.git/blob - filtergen.spec
- renamed filter.spec to filtergen.spec (follow package name change)
[packages/filtergen.git] / filtergen.spec
1 Summary:        Simple packet filter generator
2 Summary(pl):    Prosty generator filtrów pakietów
3 Name:           filtergen
4 Version:        0.11
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
9 # Source0-md5:  de33c1dce928fe240b036498e56e545f
10 Source1:        filter.conf
11 Source2:        filter.sysconfig
12 Source3:        filter.init
13 URL:            http://hairy.beasts.org/filter/
14 BuildRequires:  flex
15 PreReq:         rc-scripts
16 Requires(post,preun):   /sbin/chkconfig
17 Provides:       firewall
18 Obsoletes:      filter
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This tool is for generating packet filtering rules from a fairly high-
23 level description language. It doesn't support all of the whizz-bang
24 features of the latest and greatest packet filters, but supports a
25 decent subset which is sufficient for typical workstation.
26
27 It currently supports only Linux iptables and ipchains. Cisco IOS has
28 been begun, but is incomplete. Darren Reed's ipfilter may be supported
29 at some stage. It doesn't generate optimal rulesets, and has a few
30 limitations which need to be removed, but is still a useful tool.
31
32 Please read HONESTY file!
33
34 %description -l pl
35 To jest narzêdzie do generowania regu³ filtrowania pakietów z
36 wzglêdnie wysokopoziomowego jêzyka opisu. Nie obs³uguje wszystkich
37 zaawansowanych mo¿liwo¶ci najnowszych filtrów pakietów, ale wspiera
38 przyzwoity podzbiór, wystarczaj±cy dla typowych stacji roboczych.
39
40 Aktualnie obs³uguje tylko linuksowe iptables i ipchains. Obs³uga Cisco
41 IOS jest zaczêta, ale nie kompletna. ipfilter Darrena Reeda jest
42 obs³ugiwany czê¶ciowo. Nie generuje optymalnych regu³ek i ma parê
43 ograniczeñ, które powinny byæ usuniête, ale mimo to jest u¿ytecznym
44 narzêdziem.
45
46 Przeczytaj plik HONESTY!
47
48 %prep
49 %setup -q
50
51 %build
52 %{__make} \
53         CC="%{__cc}" \
54         CFLAGS="%{rpmcflags} -Wall -Werror -Wno-unused"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/filter} \
59         $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
60         $RPM_BUILD_ROOT%{_mandir}/man{5,7,8}
61
62 install filtergen $RPM_BUILD_ROOT%{_sbindir}
63 install filter_syntax.5 $RPM_BUILD_ROOT%{_mandir}/man5
64 install filter_backends.7 $RPM_BUILD_ROOT%{_mandir}/man7
65 install filtergen.8 $RPM_BUILD_ROOT%{_mandir}/man8
66 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/filter/simple.conf
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
68 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
69 touch $RPM_BUILD_ROOT%{_sysconfdir}/filter/generated_rules
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/chkconfig --add filtergen
76 if [ -f /var/lock/subsys/filtergen ]; then
77         /etc/rc.d/init.d/filtergen restart >&2
78 else
79         echo "Run \"/etc/rc.d/init.d/filtergen start\" to start filtergen"
80 fi
81
82 %preun
83 if [ "$1" = "0" ]; then
84         if [ -f /var/lock/subsys/filtergen ]; then
85                 /etc/rc.d/init.d/filtergen stop >&2
86         fi
87         /sbin/chkconfig --del filtergen
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README HONESTY HISTORY TODO tests
93 %attr(755,root,root) %{_sbindir}/filtergen
94 %dir %{_sysconfdir}/filter
95 %attr(600,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/filter/simple.conf
96 %attr(600,root,root) %{_sysconfdir}/filter/generated_rules
97 %attr(600,root,root) /etc/sysconfig/%{name}
98 %attr(754,root,root) /etc/rc.d/init.d/%{name}
99 %{_mandir}/man5/*
100 %{_mandir}/man7/*
101 %{_mandir}/man8/*
This page took 0.080016 seconds and 4 git commands to generate.