]> git.pld-linux.org Git - packages/filtergen.git/blob - filtergen.spec
- more specific Requires
[packages/filtergen.git] / filtergen.spec
1 Summary:        Simple packet filter generator
2 Summary(pl):    Prosty generator filtrów pakietów
3 Name:           filter
4 Version:        0.9
5 Release:        3
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
9 # Source0-md5:  dda501b978046a1ea4bf764677e4d5cf
10 Source1:        %{name}.conf
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.init
13 Patch0:         %{name}-types.patch
14 URL:            http://hairy.beasts.org/filter/
15 BuildRequires:  flex
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 Provides:       firewall
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This tool is for generating packet filtering rules from a fairly high-
23 level description language. It doesn't support all of the whizz-bang
24 features of the latest and greatest packet filters, but supports a
25 decent subset which is sufficient for typical workstation.
26
27 It currently supports only Linux iptables and ipchains. Cisco IOS has
28 been begun, but is incomplete. Darren Reed's ipfilter may be supported
29 at some stage. It doesn't generate optimal rulesets, and has a few
30 limitations which need to be removed, but is still a useful tool.
31
32 Please read HONESTY file!
33
34 %description -l pl
35 To jest narzêdzie do generowania regu³ filtrowania pakietów z
36 wzglêdnie wysokopoziomowego jêzyka opisu. Nie obs³uguje wszystkich
37 zaawansowanych mo¿liwo¶ci najnowszych filtrów pakietów, ale wspiera
38 przyzwoity podzbiór, wystarczaj±cy dla typowych stacji roboczych.
39
40 Aktualnie obs³uguje tylko linuksowe iptables i ipchains. Obs³uga Cisco
41 IOS jest zaczêta, ale nie kompletna. ipfilter Darrena Reeda jest
42 obs³ugiwany czê¶ciowo. Nie generuje optymalnych regu³ek i ma parê
43 ograniczeñ, które powinny byæ usuniête, ale mimo to jest u¿ytecznym
44 narzêdziem.
45
46 Przeczytaj plik HONESTY!
47
48 %prep
49 %setup -q
50 %patch -p1
51
52 %build
53 %{__make} \
54         CC="%{__cc}" \
55         CFLAGS="%{rpmcflags} -Wall -Werror"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/%{name}} \
60         $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,rc.d/init.d} \
61         $RPM_BUILD_ROOT%{_mandir}/man{5,7,8}
62
63 install filtergen $RPM_BUILD_ROOT%{_sbindir}
64 install filter_syntax.5 $RPM_BUILD_ROOT%{_mandir}/man5
65 install filter_backends.7 $RPM_BUILD_ROOT%{_mandir}/man7
66 install filtergen.8 $RPM_BUILD_ROOT%{_mandir}/man8
67 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/simple.conf
68 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
69 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
70 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/generated_rules
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/chkconfig --add filter
77 if [ -f /var/lock/subsys/filter ]; then
78         /etc/rc.d/init.d/filter restart >&2
79 else
80         echo "Run \"/etc/rc.d/init.d/filter start\" to start filter"
81 fi
82
83 %preun
84 if [ "$1" = "0" ]; then
85         if [ -f /var/lock/subsys/filter ]; then
86                 /etc/rc.d/init.d/filter stop >&2
87         fi
88         /sbin/chkconfig --del filter
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README HONESTY HISTORY TODO tests
94 %attr(755,root,root) %{_sbindir}/filtergen
95 %dir %{_sysconfdir}/%{name}
96 %attr(600,root,root) %{_sysconfdir}/%{name}/simple.conf
97 %attr(600,root,root) %{_sysconfdir}/%{name}/generated_rules
98 %attr(600,root,root) /etc/sysconfig/%{name}
99 %attr(754,root,root) /etc/rc.d/init.d/%{name}
100 %{_mandir}/man5/*
101 %{_mandir}/man7/*
102 %{_mandir}/man8/*
This page took 0.078129 seconds and 4 git commands to generate.