]> git.pld-linux.org Git - packages/filtergen.git/blob - filtergen.spec
- fixed build on alpha (types patch), use proper CC and CFLAGS; release 2
[packages/filtergen.git] / filtergen.spec
1 Summary:        Simple packet filter generator
2 Summary(pl):    Prosty generator filtrów pakietów
3 Name:           filter
4 Version:        0.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
9 Source1:        %{name}.conf
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.init
12 Patch0:         %{name}-types.patch
13 URL:            http://hairy.beasts.org/filter/
14 BuildRequires:  flex
15 Prereq:         rc-scripts
16 Prereq:         /sbin/chkconfig
17 Provides:       firewall
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This tool is for generating packet filtering rules from a fairly high-
22 level description language. It doesn't support all of the whizz-bang
23 features of the latest and greatest packet filters, but supports a
24 decent subset which is sufficient for typical workstation.
25
26 It currently supports only Linux iptables and ipchains. Cisco IOS has
27 been begun, but is incomplete. Darren Reed's ipfilter may be supported
28 at some stage. It doesn't generate optimal rulesets, and has a few
29 limitations which need to be removed, but is still a useful tool.
30
31 Please read HONESTY file!
32
33 %description -l pl
34 To jest narzêdzie do generowania regu³ filtrowania pakietów z
35 wzglêdnie wysokopoziomowego jêzyka opisu. Nie obs³uguje wszystkich
36 zaawansowanych mo¿liwo¶ci najnowszych filtrów pakietów, ale wspiera
37 przyzwoity podzbiór, wystarczaj±cy dla typowych stacji roboczych.
38
39 Aktualnie obs³uguje tylko linuksowe iptables i ipchains. Obs³uga Cisco
40 IOS jest zaczêta, ale nie kompletna. ipfilter Darrena Reeda jest
41 obs³ugiwany czê¶ciowo. Nie generuje optymalnych regu³ek i ma parê
42 ograniczeñ, które powinny byæ usuniête, ale mimo to jest u¿ytecznym
43 narzêdziem.
44
45 Przeczytaj plik HONESTY!
46
47 %prep
48 %setup -q
49 %patch -p1
50
51 %build
52 %{__make} \
53         CC="%{__cc}" \
54         CFLAGS="%{rpmcflags} -Wall -Werror"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/%{name}} \
59         $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,rc.d/init.d}
60
61 install filtergen $RPM_BUILD_ROOT%{_sbindir}
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/simple.conf
63 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
64 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
65 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/generated_rules
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 /sbin/chkconfig --add filter
72 if [ -f /var/lock/subsys/filter ]; then
73         /etc/rc.d/init.d/filter restart >&2
74 else
75         echo "Run \"/etc/rc.d/init.d/filter start\" to start filter"
76 fi
77
78 %preun
79 if [ "$1" = "0" ]; then
80         if [ -f /var/lock/subsys/filter ]; then
81                 /etc/rc.d/init.d/filter stop >&2
82         fi
83         /sbin/chkconfig --del filter
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README HONESTY HISTORY TODO tests
89 %attr(755,root,root) %{_sbindir}/filtergen
90 %dir %{_sysconfdir}/%{name}
91 %attr(600,root,root) %{_sysconfdir}/%{name}/simple.conf
92 %attr(600,root,root) %{_sysconfdir}/%{name}/generated_rules
93 %attr(600,root,root) %{_sysconfdir}/sysconfig/%{name}
94 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
This page took 0.064686 seconds and 4 git commands to generate.