]> git.pld-linux.org Git - packages/filtergen.git/blob - filtergen.spec
- 0.8 - SECURITY update
[packages/filtergen.git] / filtergen.spec
1 Summary:        Simple packet filter generator
2 Summary(pl):    Prosty generator filtrów pakietów
3 Name:           filter
4 Version:        0.8
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
9 Source1:        %{name}.conf
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.init
12 URL:            http://hairy.beasts.org/filter/
13 BuildRequires:  flex
14 Prereq:         rc-scripts
15 Prereq:         /sbin/chkconfig
16 Provides:       firewall
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This tool is for generating packet filtering rules from a fairly high-
21 level description language. It doesn't support all of the whizz-bang
22 features of the latest and greatest packet filters, but supports a
23 decent subset which is sufficient for typical workstation.
24
25 It currently supports only Linux iptables and ipchains. Cisco IOS has
26 been begun, but is incomplete. Darren Reed's ipfilter may be supported
27 at some stage. It doesn't generate optimal rulesets, and has a few
28 limitations which need to be removed, but is still a useful tool.
29
30 Please read HONESTY file!
31
32 %description -l pl
33 To jest narzêdzie do generowania regu³ filtrowania pakietów z
34 wzglêdnie wysokopoziomowego jêzyka opisu. Nie obs³uguje wszystkich
35 zaawansowanych mo¿liwo¶ci najnowszych filtrów pakietów, ale wspiera
36 przyzwoity podzbiór, wystarczaj±cy dla typowych stacji roboczych.
37
38 Aktualnie obs³uguje tylko linuksowe iptables i ipchains. Obs³uga Cisco
39 IOS jest zaczêta, ale nie kompletna. ipfilter Darrena Reeda jest
40 obs³ugiwany czê¶ciowo. Nie generuje optymalnych regu³ek i ma parê
41 ograniczeñ, które powinny byæ usuniête, ale mimo to jest u¿ytecznym
42 narzêdziem.
43
44 Przeczytaj plik HONESTY!
45
46 %prep
47 %setup -q
48
49 %build
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/%{name}} \
55         $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,rc.d/init.d}
56
57 install filtergen $RPM_BUILD_ROOT%{_sbindir}
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/simple.conf
59 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
60 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
61 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/generated_rules
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 /sbin/chkconfig --add filter
68 if [ -f /var/lock/subsys/filter ]; then
69         /etc/rc.d/init.d/filter restart >&2
70 else
71         echo "Run \"/etc/rc.d/init.d/filter start\" to start filter"
72 fi
73
74 %preun
75 if [ "$1" = "0" ]; then
76         if [ -f /var/lock/subsys/filter ]; then
77                 /etc/rc.d/init.d/filter stop >&2
78         fi
79         /sbin/chkconfig --del filter
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README HONESTY HISTORY TODO tests
85 %attr(755,root,root) %{_sbindir}/filtergen
86 %dir %{_sysconfdir}/%{name}
87 %attr(600,root,root) %{_sysconfdir}/%{name}/simple.conf
88 %attr(600,root,root) %{_sysconfdir}/%{name}/generated_rules
89 %attr(600,root,root) %{_sysconfdir}/sysconfig/%{name}
90 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
This page took 0.060526 seconds and 4 git commands to generate.