]> git.pld-linux.org Git - packages/filtergen.git/blame_incremental - filtergen.spec
- tabs in preamble
[packages/filtergen.git] / filtergen.spec
... / ...
CommitLineData
1Summary: Simple packet filter generator
2Summary(pl.UTF-8): Prosty generator filtrów pakietów
3Name: filtergen
4Version: 0.11
5Release: 2
6License: GPL
7Group: Networking/Utilities
8Source0: http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
9# Source0-md5: de33c1dce928fe240b036498e56e545f
10Source1: filter.conf
11Source2: filter.sysconfig
12Source3: filter.init
13URL: http://hairy.beasts.org/filter/
14BuildRequires: flex
15BuildRequires: rpmbuild(macros) >= 1.268
16Requires(post,preun): /sbin/chkconfig
17Requires: rc-scripts
18Provides: firewall
19Obsoletes: filter
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This tool is for generating packet filtering rules from a fairly high-
24level description language. It doesn't support all of the whizz-bang
25features of the latest and greatest packet filters, but supports a
26decent subset which is sufficient for typical workstation.
27
28It currently supports only Linux iptables and ipchains. Cisco IOS has
29been begun, but is incomplete. Darren Reed's ipfilter may be supported
30at some stage. It doesn't generate optimal rulesets, and has a few
31limitations which need to be removed, but is still a useful tool.
32
33Please read HONESTY file!
34
35%description -l pl.UTF-8
36To jest narzędzie do generowania reguł filtrowania pakietów z
37względnie wysokopoziomowego języka opisu. Nie obsługuje wszystkich
38zaawansowanych możliwości najnowszych filtrów pakietów, ale wspiera
39przyzwoity podzbiór, wystarczający dla typowych stacji roboczych.
40
41Aktualnie obsługuje tylko linuksowe iptables i ipchains. Obsługa Cisco
42IOS jest zaczęta, ale nie kompletna. ipfilter Darrena Reeda jest
43obsługiwany częściowo. Nie generuje optymalnych regułek i ma parę
44ograniczeń, które powinny być usunięte, ale mimo to jest użytecznym
45narzędziem.
46
47Przeczytaj plik HONESTY!
48
49%prep
50%setup -q
51
52%build
53%{__make} \
54 CC="%{__cc}" \
55 CFLAGS="%{rpmcflags} -Wall -Werror -Wno-unused"
56
57%install
58rm -rf $RPM_BUILD_ROOT
59install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/filter} \
60 $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
61 $RPM_BUILD_ROOT%{_mandir}/man{5,7,8}
62
63install filtergen $RPM_BUILD_ROOT%{_sbindir}
64install filter_syntax.5 $RPM_BUILD_ROOT%{_mandir}/man5
65install filter_backends.7 $RPM_BUILD_ROOT%{_mandir}/man7
66install filtergen.8 $RPM_BUILD_ROOT%{_mandir}/man8
67install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/filter/simple.conf
68install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
69install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
70touch $RPM_BUILD_ROOT%{_sysconfdir}/filter/generated_rules
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post
76/sbin/chkconfig --add filtergen
77%service filtergen restart "filtergen"
78
79%preun
80if [ "$1" = "0" ]; then
81 %service filtergen stop
82 /sbin/chkconfig --del filtergen
83fi
84
85%files
86%defattr(644,root,root,755)
87%doc README HONESTY HISTORY TODO tests
88%attr(755,root,root) %{_sbindir}/filtergen
89%dir %{_sysconfdir}/filter
90%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/filter/simple.conf
91%attr(600,root,root) %{_sysconfdir}/filter/generated_rules
92%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
93%attr(754,root,root) /etc/rc.d/init.d/%{name}
94%{_mandir}/man5/*
95%{_mandir}/man7/*
96%{_mandir}/man8/*
This page took 0.196617 seconds and 4 git commands to generate.