]> git.pld-linux.org Git - packages/filesystem.git/blobdiff - filesystem.spec
- removed install -d usr/man
[packages/filesystem.git] / filesystem.spec
index fcc2b946b85a70a783ea5333b40706b698929377..26a8cd7345d533d7c1afaab99cf869e1fe6c4f26 100644 (file)
@@ -4,11 +4,11 @@ Summary(fr):  Arborescence de base du syst
 Summary(pl):   Podstawa uk³ad katalogów systemu Linux
 Summary(tr):   Temel dosya sistemi yapýsý
 Name:          filesystem
-Version:       1.4
-Release:       5
+Version:       1.5
+Release:       1
 Copyright:     Public Domain
 Group:         Base
-Group(pl):     Podstawy
+Group(pl):     Bazowe
 Buildroot:     /tmp/%{name}-%{version}-root
 Prereq:                setup
 Buildarch:     noarch
@@ -16,18 +16,18 @@ Buildarch:  noarch
 %description
 This package contains the basic directory layout for a Linux system, 
 including the proper permissions for the directories. This layout conforms
-to the Linux Filesystem Standard (FSSTND) 1.3.
+to the Filesystem Hierarchy Standard (FHS) 2.0.
 
 %description -l de
 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines Linux-Systems,
 einschließlich der entsprechenden Zugriffsrechte. Diese Struktur entspricht
-dem Linux-Dateisystem-Standard (FSSTND) 1.3.
+dem Filesystem Hierarchy Standard (FHS) 2.0.
 
 %description -l fr
 Ce package contient l'arborescence type pour système linux
 y compris les permissions adéquates pour les répertoires. Cette
-arborescence est conforme au standard \"Linux Filesystem Standard\"
-(FSSTND) 1.3.
+arborescence est conforme au standard \"Filesystem Hierarchy Standard\"
+(FHS) 2.0.
 
 %description -l pl
 Pakiet ten zawiera informacje o podstawowej strukturze katalogów systemu i
@@ -42,52 +42,119 @@ metin dosyalar
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/{bin,boot,etc,home/users,lib/modules}
-install -d $RPM_BUILD_ROOT/{mnt/{floppy,cdrom},proc,root,sbin,tmp}
-install -d $RPM_BUILD_ROOT/usr/{bin,dict,doc,etc,games,include,info,sbin,share}
-
-install -d $RPM_BUILD_ROOT/usr/{games,lib/games,man}
-
-install -d $RPM_BUILD_ROOT/usr/local/{bin,etc,doc,games,info,lib,man,sbin,src}
-
-install -d $RPM_BUILD_ROOT/var/{lib,local,lock/subsys,log,run,preserve,spool/mail}
-install -d $RPM_BUILD_ROOT/var/lib/games
-
-ln -sf ../tmp $RPM_BUILD_ROOT/var/tmp
+install -d $RPM_BUILD_ROOT/{bin,boot,home/users,opt} \
+       $RPM_BUILD_ROOT/etc/{X11/wmconfig,profile.d,security,opt} \
+       $RPM_BUILD_ROOT/lib/{modules,security} \
+       $RPM_BUILD_ROOT/{mnt/{floppy,cdrom},proc,root,sbin,tmp} \
+       $RPM_BUILD_ROOT/usr/{bin,etc,games,include,sbin,share} \
+       $RPM_BUILD_ROOT/usr/share/{dict,doc,info,man,misc,games} \
+       $RPM_BUILD_ROOT/usr/{games,lib/games} \
+       $RPM_BUILD_ROOT/usr/local/{bin,games,share/{info,man,doc},lib,sbin,src} \
+       $RPM_BUILD_ROOT/var/{local,lock/subsys,log,run,preserve,mail,spool} \
+       $RPM_BUILD_ROOT/var/{games,state,tmp,db,opt}
+
+ln -sf share/man       $RPM_BUILD_ROOT/usr/man
+ln -sf share/man       $RPM_BUILD_ROOT/usr/local/man
+ln -sf share/info      $RPM_BUILD_ROOT/usr/info
+ln -sf state           $RPM_BUILD_ROOT/var/lib
+ln -sf share/doc       $RPM_BUILD_ROOT/usr/doc
+ln -sf share/doc       $RPM_BUILD_ROOT/usr/local/doc
+ln -sf share/dict      $RPM_BUILD_ROOT/usr/dict
+
+%pre
+if [ -e /usr/man ] && [ ! -L /usr/man ]; then 
+       mkdir -p /usr/share/man
+       cp -a /usr/man/* /usr/share/man || :
+       rm -rf /usr/man
+fi 
+if [ -e /usr/local/man ] && [ ! -L /usr/local/man ]; then 
+       mkdir -p /usr/local/share/man
+       cp -a /usr/local/man/* /usr/local/share/man || :
+       rm -rf /usr/local/man
+fi 
+if [ -e /usr/info ] && [ ! -L /usr/info ]; then 
+       mkdir -p /usr/share/info
+       cp -a /usr/info/* /usr/share/info || :
+       rm -rf /usr/info
+fi 
+if [ -e /usr/doc ] && [ ! -L /usr/doc ]; then 
+       mkdir -p /usr/share/doc
+       cp -a /usr/doc/* /usr/share/doc || :
+       rm -rf /usr/doc
+fi 
+if [ -e /usr/local/doc ] && [ ! -L /usr/local/doc ]; then 
+       mkdir -p /usr/local/share/doc
+       cp -a /usr/local/doc/* /usr/local/share/doc
+       rm -rf /usr/local/doc
+fi 
+if [ -e /usr/dict ] && [ ! -L /usr/dict ]; then 
+       mkdir -p /usr/share/dict
+       cp -a /usr/dict/* /usr/share/dict || :
+       rm -rf /usr/dict
+fi 
+if [ -e /var/lib ] && [ ! -L /var/lib ]; then 
+       mkdir -p /var/state
+       cp -a /var/lib/* /var/state
+       rm -rf /var/lib
+fi 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(755,root,root)
-/bin
-%attr(700,root,root) %dir /boot
-/etc
+%defattr(755,root,root,755)
+%dir /bin
+%attr(700,root,root) /boot
+%dir /etc
+%attr(751,root,root) %dir /etc/security
+%dir /etc/profile.d
+%dir /etc/opt
+%dir /etc/X11
+%dir /etc/X11/wmconfig
 /home
 /lib
 /mnt
-%attr(555,root,root) %dir /proc
-/sbin
+%attr(555,root,root) /proc
+%attr(700,root,root) /root
+%dir /sbin
 %attr(1777,root,root) /tmp
 /usr
 %dir /var
-/var/lib
-/var/local
-/var/lock
-/var/lock/subsys
-%attr(711,root,root) /var/log
-/var/run
-/var/preserve
-/var/spool
-/var/tmp
+%dir /var/db
+%dir /var/lib
+%dir /var/local
+%dir /var/lock
+%attr(751,root,root) /var/log
+%dir /var/run
+%dir /var/preserve
+%dir /var/spool
+%dir /var/state
+%attr(1777,root,root) %dir /var/tmp
 
 %changelog
+* Thu May  6 1999 Artur Frysiak <wiget@pld.org.pl>
+  [1.5-1]
+- modyfications for FHS 2.0.
+
+* Tue Apr 20 1999 Piotr Czerwiñski <pius@pld.org.pl>
+  [1.4-8]
+- recompiled on rpm 3.
+
+* Wed Mar 31 1999 Piotr Czerwiñski <pius@pld.org.pl>
+  [1.4-7]
+- added /etc/X11/wmconfig.
+
+* Thu Feb 23 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
+  [1.4-6]
+- added /etc/X11.
+
 * Sun Feb 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
   [1.4-5]
 - removed /usr/tmp (not neccessary),
 - added /usr/src,
 - removed many directories which must belongs to other packages
   (webserwer, ftpdaemon, smtpdaemon, gopher serwer, petidomo),
+- simplification in %files,
 - changed GUID on man directorirs to root.
 
 * Wed Dec 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
This page took 0.054864 seconds and 4 git commands to generate.