]> git.pld-linux.org Git - packages/fiaif.git/blob - fiaif.spec
- up to 1.22.1
[packages/fiaif.git] / fiaif.spec
1 Summary:        Fiaif is an Intelligent Firewall for iptables based Linux systems
2 Summary(pl.UTF-8):      Fiaif - inteligentny firewall bazujący na iptables
3 Name:           fiaif
4 Version:        1.22.1
5 Release:        0.1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.fiaif.net/dist/%{name}_%{version}.tar.gz
9 # Source0-md5:  14943ad87923c1f9ae492bc6b36c551e
10 URL:            http://www.fiaif.net/
11 BuildRequires:  texlive-fonts-cmsuper
12 BuildRequires:  texlive-fonts-jknappen
13 BuildRequires:  texlive-latex-ams
14 BuildRequires:  texlive-latex-moreverb
15 BuildRequires:  texlive-latex-psnfss
16 BuildRequires:  texlive-makeindex
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       bash >= 2.04
19 Requires:       grep
20 Requires:       iptables >= 1.2.7a
21 Requires:       sh-utils
22 Requires:       textutils
23 Conflicts:      ipmasq, knetfilter, firewall-easy, shorewall, firewall-init
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Goal of FIAIF is to provide a highly customizable script for
29 setting up an iptables based firewall.
30
31 Unlike many other scripts, FIAIF can be truly customized allowing
32 multiple interfaces (or rather zones). There is no limit on the number
33 of zones. All configuration is done through configuration files. No
34 need to understand the script behind it all.
35
36 The script makes heavy use of stateful firewalling, and all RELATED
37 and ESTABLISHED packets are accepted on all chains. If you wish to
38 block something out, do not accept it in the first place.
39
40 The script is written in BASH. Though this is not the optimal program
41 to use, it means that you do not need to install extra interpreters on
42 your firewall. This allows you to have a minimalistic installation on
43 your firewall.
44
45 %description -l pl.UTF-8
46 Celem FIAIF jest udostępnienie wysoce dostosowawczego skryptu
47 ustawiania reguł ściany ogniowej opartej na netfiltrze.
48
49 W przeciwieństwie do innych skryptów, FIAIF umożliwia ustawianie reguł
50 na wielu interfejsach, a raczej strefach. Nie ma limitu stref. Całą
51 konfigurację przeprowadza się za pomocą plików konfiguracyjnych. Nie
52 ma potrzeby rozumienia stojącego za nimi skryptu.
53
54 Skrypt mocno używa zabezpieczeń typu stateful, przepuszczając
55 wszystkie pakiety RELATED i ESTABLISHED na wszystkich łańcuchach.
56 Żeby coś zablokować, wystarczy nie akceptować tego na początku.
57
58 Skrypt napisany jest w bashu, co pozwala na zmniejszenie koniecznej
59 instalacji na ścianie ogniowej.
60
61 %prep
62 %setup -q
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70 %{__make} install-config \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install prog/fiaif $RPM_BUILD_ROOT/etc/rc.d/init.d/fiaif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /sbin/chkconfig --add fiaif
80 if [ -f /var/lib/fiaif/iptables ]; then
81         /etc/rc.d/init.d/fiaif force-reload >&2
82 else
83         echo "Configure fiaif and remove the line 'DONT_START=1'"
84         echo "from /etc/fiaif/fiaif.conf, then execute"
85         echo "'/etc/rc.d/init.d/fiaif start' to start fiaif."
86 fi
87
88 %preun
89 if [ "$1" = "0" ]; then
90         if [ -f /var/lib/fiaif/iptables ]; then
91                 /etc/rc.d/init.d/fiaif stop >&2
92         fi
93         /sbin/chkconfig --del fiaif
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc doc/faq.txt doc/DHCP.txt doc/reporting_bugs.txt doc/upgrade.txt
99
100 %dir %attr(700,root,root) %{_sysconfdir}/fiaif
101 %dir %attr(700,root,root) /var/lib/fiaif
102 %attr(600,root,root) %{_sysconfdir}/cron.daily/fiaif
103 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.dmz
104 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.ext
105 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.int
106 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/fiaif.conf
107 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/reserved_networks
108 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/private_networks
109 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/type_of_services
110 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/aliases
111
112 %attr(754,root,root) /etc/rc.d/init.d/fiaif
113 %attr(755,root,root) %{_sbindir}/fiaif-scan
114 %attr(755,root,root) %{_sbindir}/fiaif-getdev
115 %attr(755,root,root) %{_sbindir}/fiaif-update
116
117 %dir %{_datadir}/fiaif
118 %{_datadir}/fiaif/traffic-shaping.sh
119 %{_datadir}/fiaif/functions.sh
120 %{_datadir}/fiaif/zones.sh
121 %{_datadir}/fiaif/iptables.sh
122 %{_datadir}/fiaif/proc-check.sh
123 %{_datadir}/fiaif/sanity_check.sh
124 %{_datadir}/fiaif/constants.sh
125 %{_datadir}/fiaif/cleanup_rules.sh
126 %{_datadir}/fiaif/aliases.sh
127 %{_datadir}/fiaif/cleanup_rules.awk
128 %{_datadir}/fiaif/fiaif_rules.awk
129 %{_datadir}/fiaif/syntax.awk
130 %{_datadir}/fiaif/zone_rules.awk
131 %{_datadir}/fiaif/VERSION
132
133 %{_mandir}/man8/fiaif.8*
134 %{_mandir}/man5/zone.conf.5*
135 %{_mandir}/man5/fiaif.conf.5*
136 %{_mandir}/man8/fiaif-scan.8*
137 %{_mandir}/man8/fiaif-getdev.8*
138 %{_mandir}/man8/fiaif-update.8*
This page took 0.069965 seconds and 3 git commands to generate.