]> git.pld-linux.org Git - packages/fftw3.git/commitdiff
- no *-long on sparc (long double is equal double)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 18 Feb 2004 20:20:42 +0000 (20:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fftw3.spec -> 1.13

fftw3.spec

index 3d45545624af66952c4d6433ba984b3b8026b860..34016e9d4bdaedd6dd1286e0331df682cba2237c 100644 (file)
@@ -1,3 +1,10 @@
+#
+%bcond_without fftwl   # don't build -long subpackages
+#
+%ifarch sparc
+# sparc has sizeof(double long)==sizeof(double)
+%undefine      with_long
+%endif
 Summary:       Fast Fourier Transform library
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera
 Summary(pt_BR):        biblioteca fast fourier transform
 Summary:       Fast Fourier Transform library
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera
 Summary(pt_BR):        biblioteca fast fourier transform
@@ -222,7 +229,7 @@ cp -a `cat files.list` long-double
 ln -sf . double
 
 # MMX/SSE/etc. seem to be safe because of runtime CPU detection
 ln -sf . double
 
 # MMX/SSE/etc. seem to be safe because of runtime CPU detection
-for ver in single double long-double ; do
+for ver in single double %{with_fftwl:long-double} ; do
        OPTS=""
        # k7,SSE,3dnow,altivec only for single
        if [ "$ver" = "single" ]; then
        OPTS=""
        # k7,SSE,3dnow,altivec only for single
        if [ "$ver" = "single" ]; then
@@ -270,8 +277,10 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install -C single \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} install -C single \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with fftwl}
 %{__make} install -C long-double\
        DESTDIR=$RPM_BUILD_ROOT
 %{__make} install -C long-double\
        DESTDIR=$RPM_BUILD_ROOT
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -325,6 +334,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libfftw3f.a
 %{_libdir}/libfftw3f_threads.a
 
 %{_libdir}/libfftw3f.a
 %{_libdir}/libfftw3f_threads.a
 
+%if %{with fftwl}
 %files long
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/fftwl-wisdom
 %files long
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/fftwl-wisdom
@@ -344,6 +354,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libfftw3l.a
 %{_libdir}/libfftw3l_threads.a
 %defattr(644,root,root,755)
 %{_libdir}/libfftw3l.a
 %{_libdir}/libfftw3l_threads.a
+%endif
 
 %files common
 %defattr(644,root,root,755)
 
 %files common
 %defattr(644,root,root,755)
This page took 0.094929 seconds and 4 git commands to generate.