]> git.pld-linux.org Git - packages/fftw3.git/blobdiff - fftw3.spec
- no *-long on sparc (long double is equal double)
[packages/fftw3.git] / fftw3.spec
index 7b80cf248d9dc1c0a9ef201f9c52fa3637003340..34016e9d4bdaedd6dd1286e0331df682cba2237c 100644 (file)
@@ -1,9 +1,16 @@
+#
+%bcond_without fftwl   # don't build -long subpackages
+#
+%ifarch sparc
+# sparc has sizeof(double long)==sizeof(double)
+%undefine      with_long
+%endif
 Summary:       Fast Fourier Transform library
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera
 Summary(pt_BR):        biblioteca fast fourier transform
 Name:          fftw3
 Version:       3.0.1
-Release:       1
+Release:       2
 License:       GPL
 Group:         Libraries
 Source0:       ftp://ftp.fftw.org/pub/fftw/fftw-%{version}.tar.gz
@@ -16,7 +23,7 @@ BuildRequires:        autoconf
 BuildRequires: automake
 BuildRequires: gcc-g77
 BuildRequires: libtool
-Requires:      %{name}-common = %{version}
+Requires:      %{name}-common = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -47,8 +54,8 @@ Summary:      Development files for fftw
 Summary(pl):   Pliki programistyczne do fftw
 Summary(pt_BR):        Headers e documentação do pacote FFTW
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
-Requires:      %{name}-common-devel = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-common-devel = %{version}-%{release}
 
 %description devel
 This package contains the files you need to develop programs using the
@@ -67,7 +74,7 @@ Summary:      Static fftw libraries
 Summary(pl):   Statyczne biblioteki fftw
 Summary(pt_BR):        Bibliotecas estáticas do pacote FFTW
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static fftw libraries.
@@ -82,7 +89,7 @@ Este pacote cont
 Summary:       Fast Fourier Transform library - single precision
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera - pojedynczej precyzji
 Group:         Libraries
-Requires:      %{name}-common = %{version}
+Requires:      %{name}-common = %{version}-%{release}
 
 %description single
 FFTW is a collection of fast C routines for computing the Discrete
@@ -103,8 +110,8 @@ jednoprocesorowych oraz z obs
 Summary:       Development files for single precision fftw
 Summary(pl):   Pliki programistyczne do fftw pojedynczej precyzji
 Group:         Development/Libraries
-Requires:      %{name}-common-devel = %{version}
-Requires:      %{name}-single = %{version}
+Requires:      %{name}-common-devel = %{version}-%{release}
+Requires:      %{name}-single = %{version}-%{release}
 
 %description single-devel
 This package contains the files you need to develop programs using the
@@ -119,7 +126,7 @@ Fouriera).
 Summary:       Static fftw single precision libraries
 Summary(pl):   Statyczne biblioteki fftw pojedynczej precyzji
 Group:         Development/Libraries
-Requires:      %{name}-single-devel = %{version}
+Requires:      %{name}-single-devel = %{version}-%{release}
 
 %description single-static
 Static fftw single precision libraries.
@@ -131,7 +138,7 @@ Statyczne biblioteki fftw pojedynczej precyzji.
 Summary:       Fast Fourier Transform library - long double precision
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera - rozszerzonej precyzji
 Group:         Libraries
-Requires:      %{name}-common = %{version}
+Requires:      %{name}-common = %{version}-%{release}
 
 %description long
 FFTW is a collection of fast C routines for computing the Discrete
@@ -152,8 +159,8 @@ jednoprocesorowych oraz z obs
 Summary:       Development files for long double precision fftw
 Summary(pl):   Pliki programistyczne do fftw rozszerzonej precyzji
 Group:         Development/Libraries
-Requires:      %{name}-common-devel = %{version}
-Requires:      %{name}-long = %{version}
+Requires:      %{name}-common-devel = %{version}-%{release}
+Requires:      %{name}-long = %{version}-%{release}
 
 %description long-devel
 This package contains the files you need to develop programs using the
@@ -168,7 +175,7 @@ Fouriera).
 Summary:       Static fftw long double precision libraries
 Summary(pl):   Statyczne biblioteki fftw rozszerzonej precyzji
 Group:         Development/Libraries
-Requires:      %{name}-long-devel = %{version}
+Requires:      %{name}-long-devel = %{version}-%{release}
 
 %description long-static
 Static fftw long double precision libraries.
@@ -193,7 +200,7 @@ dokumentacja, narz
 Summary:       Development files common for all versions of fftw libraries
 Summary(pl):   Pliki programistyczne wspólne dla wszystkich wersji bibliotek fftw
 Group:         Development/Libraries
-Requires:      %{name}-common
+Requires:      %{name}-common = %{version}-%{release}
 
 %description common-devel
 Development files common for all versions of fftw libraries (header
@@ -222,7 +229,7 @@ cp -a `cat files.list` long-double
 ln -sf . double
 
 # MMX/SSE/etc. seem to be safe because of runtime CPU detection
-for ver in single double long-double ; do
+for ver in single double %{with_fftwl:long-double} ; do
        OPTS=""
        # k7,SSE,3dnow,altivec only for single
        if [ "$ver" = "single" ]; then
@@ -237,6 +244,9 @@ for ver in single double long-double ; do
 %endif
 %ifarch ppc
                OPTS="--enable-altivec"
+%endif
+%ifnarch i586 i686 k6 athlon ppc
+               :       # keep sh happy about syntax
 %endif
        fi
 %ifarch i686
@@ -267,8 +277,10 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install -C single \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with fftwl}
 %{__make} install -C long-double\
        DESTDIR=$RPM_BUILD_ROOT
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -322,6 +334,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libfftw3f.a
 %{_libdir}/libfftw3f_threads.a
 
+%if %{with fftwl}
 %files long
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/fftwl-wisdom
@@ -341,6 +354,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libfftw3l.a
 %{_libdir}/libfftw3l_threads.a
+%endif
 
 %files common
 %defattr(644,root,root,755)
This page took 0.159781 seconds and 4 git commands to generate.