]> git.pld-linux.org Git - packages/fftw3.git/blobdiff - fftw3.spec
- keep fftwl bcond
[packages/fftw3.git] / fftw3.spec
index ec0bac0d6489a1444b6e0866231c82325ddebad6..1f50da5e7679664350fe2d6bad4c96cd4ec04206 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_without fftwl   # don't build "long" subpackages
+#
 Summary:       Fast Fourier Transform library
 Summary(pl):   Biblioteka z funkcjami szybkiej transformaty Fouriera
 Summary(pt_BR):        biblioteca fast fourier transform
@@ -14,10 +18,13 @@ Patch2:             %{name}-ac_simd.patch
 URL:           http://www.fftw.org/
 BuildRequires: autoconf
 BuildRequires: automake
+%ifarch alpha ppc s390 s390x sparc sparcv9
+%if %{with fftwl}
 # for 128-bit long double support
 BuildRequires: gcc-fortran >= 5:4.1.0-1
 BuildRequires: glibc >= 6:2.4-1
-#
+%endif
+%endif
 BuildRequires: libtool
 BuildRequires: texinfo
 Requires:      %{name}-common = %{version}-%{release}
@@ -228,7 +235,7 @@ cp -a `cat files.list` long-double
 ln -sf . double
 
 # MMX/SSE/etc. seem to be safe because of runtime CPU detection
-for ver in single double long-double; do
+for ver in single double %{?with_fftwl:long-double}; do
        OPTS=""
        # k7,SSE,3dnow,altivec only for single
        if [ "$ver" = "single" ]; then
@@ -273,8 +280,10 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install -C single \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__make} install -C long-double\
+%if %{with fftwl}
+%{__make} install -C long-double \
        DESTDIR=$RPM_BUILD_ROOT
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -328,6 +337,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libfftw3f.a
 %{_libdir}/libfftw3f_threads.a
 
+%if %{with fftwl}
 %files long
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/fftwl-wisdom
@@ -347,6 +357,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libfftw3l.a
 %{_libdir}/libfftw3l_threads.a
+%endif
 
 %files common
 %defattr(644,root,root,755)
This page took 0.091802 seconds and 4 git commands to generate.