]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
- cosmetics
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single            # without single precision library
4
5 Summary:        Fast Fourier transform library
6 Summary(pl):    Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR): Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        2
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 Icon:           fftw-logo-thumb.gif
17 URL:            http://www.fftw.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  lam
21 BuildRequires:  libtool
22 BuildRequires:  texinfo
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 FFTW is a collection of fast C routines for computing the Discrete
27 Fourier Transform in one or more dimensions. It includes complex,
28 real, and parallel transforms, and can handle arbitrary array sizes
29 efficiently. This RPM package includes the double precision FFTW
30 uniprocessor and threads libraries.
31
32 %description -l pl
33 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
34 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
35 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
36 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
37 zawiera wersje FFTW o podwójnej precyzji dla architektur
38 jednoprocesorowych oraz z obs³ug± w±tków.
39
40 %description -l pt_BR
41 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
42 Fourier Transform em uma ou mais dimensões. Incluindo transformações
43 complexas, reais e paralelas, também pode manipular vetores de tamanho
44 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
45 suporte a threads, normal e dupla precisão (Os arquivos de precisão
46 normal tem um prefixo "s").
47
48 %package devel
49 Summary:        Headers, libraries & docs for fftw
50 Summary(pl):    Nag³ówki, biblioteki oraz dokumentacja do fftw
51 Summary(pt_BR): headers, bibliotecas e documentação do pacote FFTW
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}
54
55 %description devel
56 This package contains the additional header files, documentation and
57 Libraries you need to develop programs using the FFTW (fast Fourier
58 transform library).
59
60 %description devel -l pl
61 Ten pakiet zawiera dodatkowe pliki nag³ówkowe, dokumentacjê oraz
62 biblioteki niezbêdne do tworzenia programów u¿ywaj±cych biblioteki
63 FFTW (fast Fourier transform library).
64
65 %description devel -l pt_BR
66 Este pacote contém documentação, headers e bibliotecas adicionais para
67 desenvolver programas usando a FFTW.
68
69 %package static
70 Summary:        Static fftw libraries
71 Summary(pl):    Statyczne biblioteki fftw
72 Summary(pt_BR): bibliotecas estáticas do pacote FFTW
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}
75
76 %description static
77 Static fftw libraries.
78
79 %description static -l pl
80 Statyczne biblioteki fftw.
81
82 %description static -l pt_BR
83 Este pacote contém as bibliotecas estáticas do pacote FFTW.
84
85 %prep
86 %setup -q
87 %patch -p1
88
89 %build
90 # This is important to do sfftw (Single precision library)
91 %if %{with single}
92 cp -r ../%{name}-%{version} ../single
93 cd ../single
94
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__automake}
99 %configure \
100 %ifarch %{ix86}
101         --enable-i386-hacks \
102 %endif
103         --enable-shared \
104         --enable-threads \
105         --enable-float \
106         --enable-type-prefix \
107         --%{!?debug:dis}%{?debug:en}able-debug
108
109 %{__make}
110
111 cd -
112 %endif
113
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__automake}
118 %configure \
119 %ifarch %{ix86}
120         --enable-i386-hacks \
121 %endif
122         --enable-shared \
123         --enable-threads \
124         --%{!?debug:dis}%{?debug:en}able-debug
125 #        --enable-type-prefix \
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %if %{with single}
133 cd ../single
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136 cd -
137 %endif
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %post devel
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
147
148 %postun devel
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.la
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_includedir}/*
163 %{_infodir}/fftw.info*
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/lib*.a
This page took 0.048321 seconds and 4 git commands to generate.