]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
- fix: added missing $RPM_BUILD_ROOT in %install,
[packages/fftw.git] / fftw.spec
1 Summary:        fast fourier transform library
2 Name:           fftw
3 Version:        2.1.2
4 Release:        3
5 Copyright:      GPL
6 Icon:           fftw-logo-thumb.gif
7 Group:          Libraries
8 Source:         ftp://theory.lcs.mit.edu/pub/fftw/%{name}-%{version}.tar.gz
9 Patch:          fftw-info.patch
10 Prereq:         /sbin/install-info
11 URL:            http://theory.lcs.mit.edu/~fftw/
12 BuildRoot:      /tmp/%{name}-%{version}-root
13
14 %description
15 FFTW is a collection of fast C routines for computing the Discrete Fourier
16 Transform in one or more dimensions. It includes complex, real, and
17 parallel transforms, and can handle arbitrary array sizes efficiently. This
18 RPM package includes both the double- and single-precision FFTW uniprocessor
19 and threads libraries.
20
21 %package devel
22 Summary:        headers, libraries, & docs for fftw
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}
25
26 %description devel
27 This package contains the additional header files, documentation, and
28 libraries you need to develop programs using the FFTW fast fourier transform
29 library.
30
31 %package static
32 Summary:        Static fftw libraries
33 Group:          Development/Libraries
34 Requires:       %{name}-devel = %{version}
35
36 %description static
37 Static fftw libraries.
38
39 %prep
40 %setup -q
41 %patch -p1
42
43 %build
44 LDFLAGS="-s"; export LDFLAGS
45 %configure \
46 %ifarch i386 i486 i586 i686
47         --enable-i386-hacks \
48 %endif
49         --enable-shared \
50         --enable-type-prefix \
51         --enable-threads
52
53 make
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 make install DESTDIR=$RPM_BUILD_ROOT
59
60 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
61
62 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/fftw.info*
63
64 %post
65 /sbin/install-info %{_infodir}/%{name}.info.gz /etc/info-dir >&2
66
67 %preun
68 if [ "$1" = "0" ]; then
69         /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
70                 /etc/info-dir >&2
71 fi
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %attr(755,root,root) %{_libdir}/lib*.so.*.*
78
79 %files devel
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_libdir}/lib*.la
82 %attr(755,root,root) %{_libdir}/lib*.so
83 %{_includedir}/*
84 %{_infodir}/fftw.info*
85
86 %files static
87 %defattr(644,root,root,755)
88 %{_libdir}/lib*.a
This page took 0.051117 seconds and 4 git commands to generate.