]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
f5484736d17c9b9b3bbb52941395ba15ce72e970
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single            # without single precision library
4
5 Summary:        Fast Fourier transform library
6 Summary(pl):    Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR): Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        3
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 Icon:           fftw-logo-thumb.gif
17 URL:            http://www.fftw.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRequires:  texinfo
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 FFTW is a collection of fast C routines for computing the Discrete
26 Fourier Transform in one or more dimensions. It includes complex,
27 real, and parallel transforms, and can handle arbitrary array sizes
28 efficiently. This RPM package includes the single and double precision
29 FFTW uniprocessor and threads libraries.
30
31 %description -l pl
32 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
33 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
34 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
35 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
36 zawiera wersje FFTW o pojedyñczej i podwójnej precyzji dla architektur
37 jednoprocesorowych oraz z obs³ug± w±tków.
38
39 %description -l pt_BR
40 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
41 Fourier Transform em uma ou mais dimensões. Incluindo transformações
42 complexas, reais e paralelas, também pode manipular vetores de tamanho
43 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
44 suporte a threads, normal e dupla precisão (Os arquivos de precisão
45 normal tem um prefixo "s").
46
47 %package devel
48 Summary:        Headers, libraries & docs for fftw
49 Summary(pl):    Nag³ówki, biblioteki oraz dokumentacja do fftw
50 Summary(pt_BR): headers, bibliotecas e documentação do pacote FFTW
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}
53
54 %description devel
55 This package contains the additional header files, documentation and
56 Libraries you need to develop programs using the FFTW (fast Fourier
57 transform library).
58
59 %description devel -l pl
60 Ten pakiet zawiera dodatkowe pliki nag³ówkowe, dokumentacjê oraz
61 biblioteki niezbêdne do tworzenia programów u¿ywaj±cych biblioteki
62 FFTW (fast Fourier transform library).
63
64 %description devel -l pt_BR
65 Este pacote contém documentação, headers e bibliotecas adicionais para
66 desenvolver programas usando a FFTW.
67
68 %package static
69 Summary:        Static fftw libraries
70 Summary(pl):    Statyczne biblioteki fftw
71 Summary(pt_BR): bibliotecas estáticas do pacote FFTW
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 Static fftw libraries.
77
78 %description static -l pl
79 Statyczne biblioteki fftw.
80
81 %description static -l pt_BR
82 Este pacote contém as bibliotecas estáticas do pacote FFTW.
83
84 %prep
85 %setup -q
86 %patch -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93
94 %if %{with single}
95 %configure \
96 %ifarch %{ix86}
97         --enable-i386-hacks \
98 %endif
99         --enable-shared \
100         --enable-threads \
101         --enable-float \
102         --enable-type-prefix \
103         --%{!?debug:dis}%{?debug:en}able-debug
104
105 %{__make}
106 %{__make} install \
107         DESTDIR=$(pwd)/single
108 %endif
109
110 %configure \
111 %ifarch %{ix86}
112         --enable-i386-hacks \
113 %endif
114         --enable-shared \
115         --enable-threads \
116         --%{!?debug:dis}%{?debug:en}able-debug
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{?with_single:cp -ar single $RPM_BUILD_ROOT}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %post devel
132 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
133
134 %postun devel
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %{_libdir}/lib*.la
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_includedir}/*
149 %{_infodir}/fftw.info*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
This page took 0.060147 seconds and 2 git commands to generate.