]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
- only cvs changelog
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single          # without single precision library
4 #
5 Summary:        Fast Fourier Transform library
6 Summary(pl):    Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR): Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        4
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-link.patch
17 URL:            http://www.fftw.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 # to detect proper F77 name mangling for fortran binding functions
21 BuildRequires:  gcc-g77
22 BuildRequires:  libtool
23 BuildRequires:  texinfo
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 FFTW is a collection of fast C routines for computing the Discrete
28 Fourier Transform in one or more dimensions. It includes complex,
29 real, and parallel transforms, and can handle arbitrary array sizes
30 efficiently. This RPM package includes the single and double precision
31 FFTW uniprocessor and threads libraries.
32
33 %description -l pl
34 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
35 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
36 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
37 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
38 zawiera wersje FFTW o pojedyñczej i podwójnej precyzji dla architektur
39 jednoprocesorowych oraz z obs³ug± w±tków.
40
41 %description -l pt_BR
42 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
43 Fourier Transform em uma ou mais dimensões. Incluindo transformações
44 complexas, reais e paralelas, também pode manipular vetores de tamanho
45 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
46 suporte a threads, normal e dupla precisão (Os arquivos de precisão
47 normal tem um prefixo "s").
48
49 %package devel
50 Summary:        Header files and development documentation for FFTW library
51 Summary(pl):    Pliki nag³ówkowe i dokumentacja programisty do biblioteki FFTW
52 Summary(pt_BR): Headers e documentação do pacote FFTW
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 This package contains the additional header files and documentation
58 you need to develop programs using the FFTW (fast Fourier transform
59 library).
60
61 %description devel -l pl
62 Ten pakiet zawiera dodatkowe pliki nag³ówkowe oraz dokumentacjê do
63 tworzenia programów u¿ywaj±cych biblioteki FFTW (fast Fourier
64 transform library).
65
66 %description devel -l pt_BR
67 Este pacote contém documentação e headers adicionais para desenvolver
68 programas usando a FFTW.
69
70 %package static
71 Summary:        Static FFTW libraries
72 Summary(pl):    Statyczne biblioteki FFTW
73 Summary(pt_BR): bibliotecas estáticas do pacote FFTW
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static FFTW libraries.
79
80 %description static -l pl
81 Statyczne biblioteki FFTW.
82
83 %description static -l pt_BR
84 Este pacote contém as bibliotecas estáticas do pacote FFTW.
85
86 %package single
87 Summary:        Single-precision Fast Fourier Transform libraries
88 Summary(pl):    Biblioteki szybkiej transformaty Fouriera pojedynczej precyzji
89 Group:          Libraries
90 Conflicts:      fftw < 2.1.5-4
91
92 %description single
93 Single-precision Fast Fourier Transform libraries.
94
95 %description single -l pl
96 Biblioteki szybkiej transformaty Fouriera pojedynczej precyzji.
97
98 %package single-devel
99 Summary:        Header files for single-precision FFTW libraries
100 Summary(pl):    Pliki nag³ówkowe bibliotek FFTW pojedynczej precyzji
101 Group:          Development/Libraries
102 Requires:       %{name}-single = %{version}-%{release}
103
104 %description single-devel
105 Header files for single-precision FFTW libraries.
106
107 %description single-devel -l pl
108 Pliki nag³ówkowe bibliotek FFTW pojedynczej precyzji.
109
110 %package single-static
111 Summary:        Static single-precision FFTW libraries
112 Summary(pl):    Statyczne biblioteki FFTW pojedynczej precyzji
113 Group:          Development/Libraries
114 Requires:       %{name}-single-devel = %{version}-%{release}
115
116 %description single-static
117 Static single-precision FFTW libraries.
118
119 %description single-static -l pl
120 Statyczne biblioteki FFTW pojedynczej precyzji.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch1 -p1
126
127 # don't use pregenerated file
128 rm -f fftw/config.h
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135
136 %if %{with single}
137 install -d build-single
138 cd build-single
139 ../%configure \
140 %ifarch %{ix86}
141         --enable-i386-hacks \
142 %endif
143         --enable-shared \
144         --enable-threads \
145         --enable-float \
146         --enable-type-prefix \
147         --%{!?debug:dis}%{?debug:en}able-debug
148
149 %{__make}
150 cd ..
151 %endif
152
153 install -d build-double
154 cd build-double
155 ../%configure \
156 %ifarch %{ix86}
157         --enable-i386-hacks \
158 %endif
159         --enable-shared \
160         --enable-threads \
161         --%{!?debug:dis}%{?debug:en}able-debug
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} -C build-single install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 %{__make} -C build-double install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %post devel
181 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
182
183 %postun devel
184 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
185
186 %post   single -p /sbin/ldconfig
187 %postun single -p /sbin/ldconfig
188
189 %files
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libfftw.so.*.*.*
192 %attr(755,root,root) %{_libdir}/libfftw_threads.so.*.*.*
193 %attr(755,root,root) %{_libdir}/librfftw.so.*.*.*
194 %attr(755,root,root) %{_libdir}/librfftw_threads.so.*.*.*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libfftw.so
199 %attr(755,root,root) %{_libdir}/libfftw_threads.so
200 %attr(755,root,root) %{_libdir}/librfftw.so
201 %attr(755,root,root) %{_libdir}/librfftw_threads.so
202 %{_libdir}/libfftw.la
203 %{_libdir}/libfftw_threads.la
204 %{_libdir}/librfftw.la
205 %{_libdir}/librfftw_threads.la
206 %{_includedir}/fftw*.h
207 %{_includedir}/rfftw*.h
208 %{_infodir}/fftw.info*
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libfftw.a
213 %{_libdir}/libfftw_threads.a
214 %{_libdir}/librfftw.a
215 %{_libdir}/librfftw_threads.a
216
217 %files single
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libsfftw.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libsfftw_threads.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libsrfftw.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libsrfftw_threads.so.*.*.*
223
224 %files single-devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libsfftw.so
227 %attr(755,root,root) %{_libdir}/libsfftw_threads.so
228 %attr(755,root,root) %{_libdir}/libsrfftw.so
229 %attr(755,root,root) %{_libdir}/libsrfftw_threads.so
230 %{_libdir}/libsfftw.la
231 %{_libdir}/libsfftw_threads.la
232 %{_libdir}/libsrfftw.la
233 %{_libdir}/libsrfftw_threads.la
234 %{_includedir}/sfftw*.h
235 %{_includedir}/srfftw*.h
236
237 %files single-static
238 %defattr(644,root,root,755)
239 %{_libdir}/libsfftw.a
240 %{_libdir}/libsfftw_threads.a
241 %{_libdir}/libsrfftw.a
242 %{_libdir}/libsrfftw_threads.a
This page took 0.066189 seconds and 3 git commands to generate.