]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
- build fix
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single            # without single precision library
4
5 Summary:        Fast Fourier transform library
6 Summary(pl):    Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR): Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        2
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 Icon:           fftw-logo-thumb.gif
17 URL:            http://www.fftw.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRequires:  texinfo
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 FFTW is a collection of fast C routines for computing the Discrete
26 Fourier Transform in one or more dimensions. It includes complex,
27 real, and parallel transforms, and can handle arbitrary array sizes
28 efficiently. This RPM package includes the single and double precision
29 FFTW uniprocessor and threads libraries.
30
31 %description -l pl
32 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
33 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
34 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
35 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
36 zawiera wersje FFTW o pojedyñczej i podwójnej precyzji dla architektur
37 jednoprocesorowych oraz z obs³ug± w±tków.
38
39 %description -l pt_BR
40 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
41 Fourier Transform em uma ou mais dimensões. Incluindo transformações
42 complexas, reais e paralelas, também pode manipular vetores de tamanho
43 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
44 suporte a threads, normal e dupla precisão (Os arquivos de precisão
45 normal tem um prefixo "s").
46
47 %package devel
48 Summary:        Headers, libraries & docs for fftw
49 Summary(pl):    Nag³ówki, biblioteki oraz dokumentacja do fftw
50 Summary(pt_BR): headers, bibliotecas e documentação do pacote FFTW
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}
53
54 %description devel
55 This package contains the additional header files, documentation and
56 Libraries you need to develop programs using the FFTW (fast Fourier
57 transform library).
58
59 %description devel -l pl
60 Ten pakiet zawiera dodatkowe pliki nag³ówkowe, dokumentacjê oraz
61 biblioteki niezbêdne do tworzenia programów u¿ywaj±cych biblioteki
62 FFTW (fast Fourier transform library).
63
64 %description devel -l pt_BR
65 Este pacote contém documentação, headers e bibliotecas adicionais para
66 desenvolver programas usando a FFTW.
67
68 %package static
69 Summary:        Static fftw libraries
70 Summary(pl):    Statyczne biblioteki fftw
71 Summary(pt_BR): bibliotecas estáticas do pacote FFTW
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 Static fftw libraries.
77
78 %description static -l pl
79 Statyczne biblioteki fftw.
80
81 %description static -l pt_BR
82 Este pacote contém as bibliotecas estáticas do pacote FFTW.
83
84 %prep
85 %setup -q
86 %patch -p1
87
88 %build
89 # This is important to do sfftw (Single precision library)
90 %if %{with single}
91
92 tar xzf %{SOURCE0}
93 mv %{name}-%{version}/ single/
94 cd single
95
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101 %ifarch %{ix86}
102         --enable-i386-hacks \
103 %endif
104         --enable-shared \
105         --enable-threads \
106         --enable-float \
107         --enable-type-prefix \
108         --%{!?debug:dis}%{?debug:en}able-debug
109
110 %{__make}
111
112 cd -
113 %endif
114
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120 %ifarch %{ix86}
121         --enable-i386-hacks \
122 %endif
123         --enable-shared \
124         --enable-threads \
125         --%{!?debug:dis}%{?debug:en}able-debug
126 #        --enable-type-prefix \
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %if %{with single}
134 cd single
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137 cd -
138 %endif
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %post devel
147 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
148
149 %postun devel
150 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/lib*.so.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.la
162 %attr(755,root,root) %{_libdir}/lib*.so
163 %{_includedir}/*
164 %{_infodir}/fftw.info*
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/lib*.a
This page took 0.058778 seconds and 3 git commands to generate.