]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
0401e2b8f688460494e5e76cc6b71969ea316c48
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single            # without single precision library
4 #
5 Summary:        Fast Fourier transform library
6 Summary(pl):    Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR): Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        3
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 URL:            http://www.fftw.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  texinfo
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 FFTW is a collection of fast C routines for computing the Discrete
25 Fourier Transform in one or more dimensions. It includes complex,
26 real, and parallel transforms, and can handle arbitrary array sizes
27 efficiently. This RPM package includes the single and double precision
28 FFTW uniprocessor and threads libraries.
29
30 %description -l pl
31 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
32 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
33 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
34 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
35 zawiera wersje FFTW o pojedyñczej i podwójnej precyzji dla architektur
36 jednoprocesorowych oraz z obs³ug± w±tków.
37
38 %description -l pt_BR
39 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
40 Fourier Transform em uma ou mais dimensões. Incluindo transformações
41 complexas, reais e paralelas, também pode manipular vetores de tamanho
42 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
43 suporte a threads, normal e dupla precisão (Os arquivos de precisão
44 normal tem um prefixo "s").
45
46 %package devel
47 Summary:        Header files and development documentation for FFTW library
48 Summary(pl):    Pliki nag³ówkowe i dokumentacja programisty do biblioteki FFTW
49 Summary(pt_BR): Headers e documentação do pacote FFTW
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 This package contains the additional header files and documentation
55 you need to develop programs using the FFTW (fast Fourier transform
56 library).
57
58 %description devel -l pl
59 Ten pakiet zawiera dodatkowe pliki nag³ówkowe oraz dokumentacjê do
60 tworzenia programów u¿ywaj±cych biblioteki FFTW (fast Fourier
61 transform library).
62
63 %description devel -l pt_BR
64 Este pacote contém documentação e headers adicionais para desenvolver
65 programas usando a FFTW.
66
67 %package static
68 Summary:        Static fftw libraries
69 Summary(pl):    Statyczne biblioteki fftw
70 Summary(pt_BR): bibliotecas estáticas do pacote FFTW
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static fftw libraries.
76
77 %description static -l pl
78 Statyczne biblioteki fftw.
79
80 %description static -l pt_BR
81 Este pacote contém as bibliotecas estáticas do pacote FFTW.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92
93 %if %{with single}
94 %configure \
95 %ifarch %{ix86}
96         --enable-i386-hacks \
97 %endif
98         --enable-shared \
99         --enable-threads \
100         --enable-float \
101         --enable-type-prefix \
102         --%{!?debug:dis}%{?debug:en}able-debug
103
104 %{__make}
105 %{__make} install \
106         DESTDIR=$(pwd)/single
107 %endif
108
109 %configure \
110 %ifarch %{ix86}
111         --enable-i386-hacks \
112 %endif
113         --enable-shared \
114         --enable-threads \
115         --%{!?debug:dis}%{?debug:en}able-debug
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{?with_single:cp -ar single $RPM_BUILD_ROOT}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post devel
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun devel
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/lib*.so.*.*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %{_libdir}/lib*.la
147 %{_includedir}/*
148 %{_infodir}/fftw.info*
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/lib*.a
This page took 0.061301 seconds and 2 git commands to generate.