]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
01926c7d1235e84264cfa96f391ed3e9808b6ca5
[packages/fftw.git] / fftw.spec
1 #
2 # Conditional build
3 %bcond_without  single          # without single precision library
4 #
5 Summary:        Fast Fourier Transform library
6 Summary(pl.UTF-8):      Biblioteka z funkcjami szybkiej transformaty Fouriera
7 Summary(pt_BR.UTF-8):   Biblioteca fast Fourier transform
8 Name:           fftw
9 Version:        2.1.5
10 Release:        6
11 License:        GPL
12 Group:          Libraries
13 Source0:        ftp://ftp.fftw.org/pub/fftw/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d16a84f3ca02a785ef9eb36249ba433
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-link.patch
17 Patch2:         doctex.patch
18 URL:            http://www.fftw.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 # to detect proper F77 name mangling for fortran binding functions
22 BuildRequires:  gcc-g77
23 BuildRequires:  libtool
24 BuildRequires:  texinfo
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 FFTW is a collection of fast C routines for computing the Discrete
29 Fourier Transform in one or more dimensions. It includes complex,
30 real, and parallel transforms, and can handle arbitrary array sizes
31 efficiently. This RPM package includes the single and double precision
32 FFTW uniprocessor and threads libraries.
33
34 %description -l pl.UTF-8
35 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
36 transformat Fouriera w jednym lub więcej wymiarach. Zawiera również
37 zespolone, rzeczywiste oraz równoległe transformaty i potrafi wydajnie
38 radzić sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
39 zawiera wersje FFTW o pojedyńczej i podwójnej precyzji dla architektur
40 jednoprocesorowych oraz z obsługą wątków.
41
42 %description -l pt_BR.UTF-8
43 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
44 Fourier Transform em uma ou mais dimensões. Incluindo transformações
45 complexas, reais e paralelas, também pode manipular vetores de tamanho
46 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
47 suporte a threads, normal e dupla precisão (Os arquivos de precisão
48 normal tem um prefixo "s").
49
50 %package devel
51 Summary:        Header files and development documentation for FFTW library
52 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do biblioteki FFTW
53 Summary(pt_BR.UTF-8):   Headers e documentação do pacote FFTW
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 This package contains the additional header files and documentation
59 you need to develop programs using the FFTW (fast Fourier transform
60 library).
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera dodatkowe pliki nagłówkowe oraz dokumentację do
64 tworzenia programów używających biblioteki FFTW (fast Fourier
65 transform library).
66
67 %description devel -l pt_BR.UTF-8
68 Este pacote contém documentação e headers adicionais para desenvolver
69 programas usando a FFTW.
70
71 %package static
72 Summary:        Static FFTW libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki FFTW
74 Summary(pt_BR.UTF-8):   bibliotecas estáticas do pacote FFTW
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static FFTW libraries.
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki FFTW.
83
84 %description static -l pt_BR.UTF-8
85 Este pacote contém as bibliotecas estáticas do pacote FFTW.
86
87 %package single
88 Summary:        Single-precision Fast Fourier Transform libraries
89 Summary(pl.UTF-8):      Biblioteki szybkiej transformaty Fouriera pojedynczej precyzji
90 Group:          Libraries
91 Conflicts:      fftw < 2.1.5-4
92
93 %description single
94 Single-precision Fast Fourier Transform libraries.
95
96 %description single -l pl.UTF-8
97 Biblioteki szybkiej transformaty Fouriera pojedynczej precyzji.
98
99 %package single-devel
100 Summary:        Header files for single-precision FFTW libraries
101 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek FFTW pojedynczej precyzji
102 Group:          Development/Libraries
103 Requires:       %{name}-single = %{version}-%{release}
104
105 %description single-devel
106 Header files for single-precision FFTW libraries.
107
108 %description single-devel -l pl.UTF-8
109 Pliki nagłówkowe bibliotek FFTW pojedynczej precyzji.
110
111 %package single-static
112 Summary:        Static single-precision FFTW libraries
113 Summary(pl.UTF-8):      Statyczne biblioteki FFTW pojedynczej precyzji
114 Group:          Development/Libraries
115 Requires:       %{name}-single-devel = %{version}-%{release}
116
117 %description single-static
118 Static single-precision FFTW libraries.
119
120 %description single-static -l pl.UTF-8
121 Statyczne biblioteki FFTW pojedynczej precyzji.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128
129 # don't use pregenerated file
130 rm -f fftw/config.h
131
132 %build
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__automake}
137
138 %if %{with single}
139 install -d build-single
140 cd build-single
141 ../%configure \
142 %ifarch %{ix86}
143         --enable-i386-hacks \
144 %endif
145         --enable-shared \
146         --enable-threads \
147         --enable-float \
148         --enable-type-prefix \
149         --%{!?debug:dis}%{?debug:en}able-debug
150
151 %{__make}
152 cd ..
153 %endif
154
155 install -d build-double
156 cd build-double
157 ../%configure \
158 %ifarch %{ix86}
159         --enable-i386-hacks \
160 %endif
161         --enable-shared \
162         --enable-threads \
163         --%{!?debug:dis}%{?debug:en}able-debug
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} -C build-single install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 %{__make} -C build-double install \
174         DESTDIR=$RPM_BUILD_ROOT
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %post devel     -p      /sbin/postshell
183 -/usr/sbin/fix-info-dir -c %{_infodir}
184
185 %postun devel   -p      /sbin/postshell
186 -/usr/sbin/fix-info-dir -c %{_infodir}
187
188 %post   single -p /sbin/ldconfig
189 %postun single -p /sbin/ldconfig
190
191 %files
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libfftw.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libfftw.so.2
195 %attr(755,root,root) %{_libdir}/libfftw_threads.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libfftw_threads.so.2
197 %attr(755,root,root) %{_libdir}/librfftw.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/librfftw.so.2
199 %attr(755,root,root) %{_libdir}/librfftw_threads.so.*.*.*
200 %attr(755,root,root) %ghost %{_libdir}/librfftw_threads.so.2
201
202 %files devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libfftw.so
205 %attr(755,root,root) %{_libdir}/libfftw_threads.so
206 %attr(755,root,root) %{_libdir}/librfftw.so
207 %attr(755,root,root) %{_libdir}/librfftw_threads.so
208 %{_libdir}/libfftw.la
209 %{_libdir}/libfftw_threads.la
210 %{_libdir}/librfftw.la
211 %{_libdir}/librfftw_threads.la
212 %{_includedir}/fftw*.h
213 %{_includedir}/rfftw*.h
214 %{_infodir}/fftw.info*
215
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/libfftw.a
219 %{_libdir}/libfftw_threads.a
220 %{_libdir}/librfftw.a
221 %{_libdir}/librfftw_threads.a
222
223 %files single
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/libsfftw.so.*.*.*
226 %attr(755,root,root) %ghost %{_libdir}/libsfftw.so.2
227 %attr(755,root,root) %{_libdir}/libsfftw_threads.so.*.*.*
228 %attr(755,root,root) %ghost %{_libdir}/libsfftw_threads.so.2
229 %attr(755,root,root) %{_libdir}/libsrfftw.so.*.*.*
230 %attr(755,root,root) %ghost %{_libdir}/libsrfftw.so.2
231 %attr(755,root,root) %{_libdir}/libsrfftw_threads.so.*.*.*
232 %attr(755,root,root) %ghost %{_libdir}/libsrfftw_threads.so.2
233
234 %files single-devel
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/libsfftw.so
237 %attr(755,root,root) %{_libdir}/libsfftw_threads.so
238 %attr(755,root,root) %{_libdir}/libsrfftw.so
239 %attr(755,root,root) %{_libdir}/libsrfftw_threads.so
240 %{_libdir}/libsfftw.la
241 %{_libdir}/libsfftw_threads.la
242 %{_libdir}/libsrfftw.la
243 %{_libdir}/libsrfftw_threads.la
244 %{_includedir}/sfftw*.h
245 %{_includedir}/srfftw*.h
246
247 %files single-static
248 %defattr(644,root,root,755)
249 %{_libdir}/libsfftw.a
250 %{_libdir}/libsfftw_threads.a
251 %{_libdir}/libsrfftw.a
252 %{_libdir}/libsrfftw_threads.a
This page took 0.087477 seconds and 2 git commands to generate.