]> git.pld-linux.org Git - packages/ffmpegthumbnailer.git/blob - ffmpegthumbnailer.spec
- add updates from upstream repository, rel 2
[packages/ffmpegthumbnailer.git] / ffmpegthumbnailer.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Lightweight video thumbnailer
6 Summary(pl.UTF-8):      Lekki program do wykonywania miniaturek dla filmów
7 Name:           ffmpegthumbnailer
8 Version:        2.2.0
9 Release:        2
10 License:        GPL v2
11 Group:          Applications/Graphics
12 #Source0Download: https://github.com/dirkvdb/ffmpegthumbnailer/releases
13 Source0:        https://github.com/dirkvdb/ffmpegthumbnailer/releases/download/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ed3754b3b8b9af93a93c490e17def0d0
15 Patch0:         %{name}-pc.patch
16 URL:            https://github.com/dirkvdb/ffmpegthumbnailer
17 BuildRequires:  cmake >= 2.8
18 # libavcodec >= 52.26.0 libavformat libavutil libswscale
19 BuildRequires:  ffmpeg-devel >= 0.6
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  sed >= 4.0
25 # dlopens libglib-2.0.so.0 libgobject-2.0.so.0 libgio-2.0.so.0
26 Requires:       glib2 >= 2.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 ffmpegthumbnailer can be used by file managers to create thumbnails
31 for your video files. It uses ffmpeg to decode frames from the video
32 files.
33
34 %description -l pl.UTF-8
35 ffmpegthumbnailer może być używany przez zarządców plików do tworzenia
36 miniaturek dla plików filmów. Wykorzystuje ffmpeg do dekodowania
37 klatek.
38
39 %package devel
40 Summary:        Header files for libffmpegthumbnailer library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libffmpegthumbnailer
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       ffmpeg-devel
45 Requires:       libjpeg-devel
46 Requires:       libpng-devel
47
48 %description devel
49 Header files for libffmpegthumbnailer library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki libffmpegthumbnailer.
53
54 %package static
55 Summary:        Static libffmpegthumbnailer library
56 Summary(pl.UTF-8):      Statyczna biblioteka libffmpegthumbnailer
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static libffmpegthumbnailer library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libffmpegthumbnailer.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 mkdir build
72 cd build
73 %cmake .. \
74         -DENABLE_GIO=ON \
75         -DENABLE_TESTS=ON \
76         %{?with_static_libs:-DENABLE_STATIC=ON} \
77         -DENABLE_THUMBNAILER=ON
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 cd build
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog README TODO
97 %attr(755,root,root) %{_bindir}/ffmpegthumbnailer
98 %attr(755,root,root) %{_libdir}/libffmpegthumbnailer.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libffmpegthumbnailer.so.4
100 %{_datadir}/thumbnailers/ffmpegthumbnailer.thumbnailer
101 %{_mandir}/man1/ffmpegthumbnailer.1*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libffmpegthumbnailer.so
106 %{_includedir}/libffmpegthumbnailer
107 %{_pkgconfigdir}/libffmpegthumbnailer.pc
108
109 %if %{with static_libs}
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libffmpegthumbnailer.a
113 %endif
This page took 0.060858 seconds and 3 git commands to generate.