]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
add patch to fix build with libvpx 1.5.0
authorElan Ruusamäe <glen@delfi.ee>
Tue, 17 Nov 2015 14:17:50 +0000 (16:17 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 17 Nov 2015 14:18:18 +0000 (16:18 +0200)
ffmpeg.spec
libvpx-1.5.patch [new file with mode: 0644]

index 51a853fe02ebc2768414cf09537813a9e74d4539..c2fa385e33502462f2dd63649167feb1af0207be 100644 (file)
@@ -75,6 +75,7 @@ Source1:      ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
 Patch0:                %{name}-kvazaar.patch
+Patch1:                libvpx-1.5.patch
 URL:           http://www.ffmpeg.org/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
@@ -379,6 +380,7 @@ Dokumentacja pakietu FFmpeg w formacie HTML.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
diff --git a/libvpx-1.5.patch b/libvpx-1.5.patch
new file mode 100644 (file)
index 0000000..34659c7
--- /dev/null
@@ -0,0 +1,41 @@
+https://github.com/jb-alvarado/media-autobuild_suite/issues/185
+http://git.videolan.org/?p=ffmpeg.git;a=commit;h=6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab
+
+From: James Zern <jzern@google.com>
+Date: Tue, 20 Oct 2015 05:44:11 +0000 (-0700)
+Subject: libvpxenc: remove some unused ctrl id mappings
+X-Git-Url: http://git.videolan.org/?p=ffmpeg.git;a=commitdiff_plain;h=6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab;hp=6b41b4414934cc930468ccd5db598dd6ef643987
+
+libvpxenc: remove some unused ctrl id mappings
+
+VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
+from libvpx and the remaining values were never used here
+
+Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
+Signed-off-by: James Zern <jzern@google.com>
+---
+
+diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
+index 5f39783..992122c 100644
+--- a/libavcodec/libvpxenc.c
++++ b/libavcodec/libvpxenc.c
+@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
+ /** String mappings for enum vp8e_enc_control_id */
+ static const char *const ctlidstr[] = {
+-    [VP8E_UPD_ENTROPY]           = "VP8E_UPD_ENTROPY",
+-    [VP8E_UPD_REFERENCE]         = "VP8E_UPD_REFERENCE",
+-    [VP8E_USE_REFERENCE]         = "VP8E_USE_REFERENCE",
+-    [VP8E_SET_ROI_MAP]           = "VP8E_SET_ROI_MAP",
+-    [VP8E_SET_ACTIVEMAP]         = "VP8E_SET_ACTIVEMAP",
+-    [VP8E_SET_SCALEMODE]         = "VP8E_SET_SCALEMODE",
+     [VP8E_SET_CPUUSED]           = "VP8E_SET_CPUUSED",
+     [VP8E_SET_ENABLEAUTOALTREF]  = "VP8E_SET_ENABLEAUTOALTREF",
+     [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
+-    [VP8E_SET_SHARPNESS]         = "VP8E_SET_SHARPNESS",
+     [VP8E_SET_STATIC_THRESHOLD]  = "VP8E_SET_STATIC_THRESHOLD",
+     [VP8E_SET_TOKEN_PARTITIONS]  = "VP8E_SET_TOKEN_PARTITIONS",
+-    [VP8E_GET_LAST_QUANTIZER]    = "VP8E_GET_LAST_QUANTIZER",
+     [VP8E_SET_ARNR_MAXFRAMES]    = "VP8E_SET_ARNR_MAXFRAMES",
+     [VP8E_SET_ARNR_STRENGTH]     = "VP8E_SET_ARNR_STRENGTH",
+     [VP8E_SET_ARNR_TYPE]         = "VP8E_SET_ARNR_TYPE",
This page took 0.319592 seconds and 4 git commands to generate.