]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- updated macros BR (1.470 for rpmcppflags)
[packages/ffmpeg.git] / ffmpeg.spec
index 2eab543fb99b13310b8c186c33ee45ba06f33fd0..f6e082b4d2ff69e34898db635fddb987bab8527b 100644 (file)
@@ -2,38 +2,36 @@
 # - libnut enabled   no (http://www.nut-container.org/)
 #
 # Conditional build:
-%bcond_with    amr             # build 3GPP Adaptive Multi Rate (AMR) speech codec
+%bcond_with    amr             # 3GPP Adaptive Multi Rate (AMR) codec support; makes package non-distributable
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
 %bcond_without imlib2          # don't build imlib2 vhook module
 #
-%define                _snap   2007-10-09
+%define                _snap   2008-08-22
 %define                snap    %(echo %{_snap} | tr -d -)
-%define                _rel 0.1
+%define                rel 4
 Summary:       Realtime audio/video encoder and streaming server
 Summary(pl.UTF-8):     Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
 Name:          ffmpeg
 Version:       0.4.9
-Release:       3.%{snap}.%{_rel}
+Release:       4.%{snap}.%{rel}
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
-# (postprocessing, a52, xvid, x264, faad)
-License:       GPL with LGPL parts
+# (postprocessing, ac3, xvid, x264, faad)
+License:       GPL v2+ with LGPL v2.1+ parts
 Group:         Applications/Multimedia
 #Source0:      http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
 Source0:       http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
-# Source0-md5: fcf10b6a1bf7d0ff1aa41e7d57c69e22
+# Source0-md5: 573ff56bb619391fbc13ecde23389b45
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
-Patch0:                %{name}-gcc4.patch
-Patch1:                %{name}-img_convert_symbol.patch
-Patch2:                %{name}-a52bin.patch
+Patch0:                %{name}-img_convert_symbol.patch
 URL:           http://ffmpeg.mplayerhq.hu/
 BuildRequires: SDL-devel
-BuildRequires: a52dec-libs-devel
 %if %{with amr}
 BuildRequires: amrnb-devel >= 6.1.0.4
 BuildRequires: amrwb-devel >= 7.0.0.1
 %endif
+BuildRequires: dirac-devel
 BuildRequires: faac-devel
 BuildRequires: faad2-devel
 BuildRequires: freetype-devel
@@ -41,22 +39,23 @@ BuildRequires:      freetype-devel
 # require version with altivec support fixed
 BuildRequires: gcc >= 5:3.3.2-3
 %endif
+BuildRequires: a52dec-libs-devel
 %{?with_imlib2:BuildRequires:  imlib2-devel >= 1.3.0}
 BuildRequires: lame-libs-devel
+BuildRequires: libdc1394-devel
 BuildRequires: libgsm-devel
-BuildRequires: libogg-devel
 BuildRequires: libraw1394-devel
 BuildRequires: libtheora-devel >= 1.0-0.alpha7
 BuildRequires: libtool >= 2:1.4d-3
 BuildRequires: libvorbis-devel
-BuildRequires: libx264-devel >= 0.1.2-1.20061024_2245.1
+BuildRequires: libx264-devel >= 0.1.2-1.20080801
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
 %endif
 %endif
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: tetex
 BuildRequires: texinfo
 %{?with_amr:BuildRequires:     unzip}
@@ -201,34 +200,86 @@ dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
 %prep
 %setup -q -n %{name}-export-%{_snap}
 %patch0 -p1
-%patch1 -p1
-#%patch2 -p1
+
+# package the grep result for mplayer, the result formatted as mplayer/configure
+cat <<EOF > ffmpeg-config
+#! /bin/sh
+_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
+_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
+_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
+_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
+_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
+_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
+_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
+EOF
+cat <<'EOF' >> ffmpeg-config
+
+case "$1" in
+--decoders)
+       echo $_libavdecoders_all
+       ;;
+--encoders)
+       echo $_libavencoders_all
+       ;;
+--parsers)
+       echo $_libavparsers_all
+       ;;
+--bsfs)
+       echo $_libavbsfs_all
+       ;;
+--demuxers)
+       echo $_libavdemuxers_all
+       ;;
+--muxers)
+       echo $_libavmuxers_all
+       ;;
+--protocols)
+       echo $_libavprotocols_all
+       ;;
+*)
+       cat <<USAGE
+Usage: $0 [OPTION]
+Options:
+  --decoders
+  --encoders
+  --parsers
+  --bsfs
+  --demuxers
+  --muxers
+  --protocols
+USAGE
+       exit 1;;
+esac
+
+exit 0
+EOF
 
 %build
 # notes:
 # - it's not autoconf configure
-# - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
+# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
 ./configure \
        --arch=%{_target_base_arch} \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --shlibdir=%{_libdir} \
        --mandir=%{_mandir} \
-       --disable-strip \
+       --disable-stripping \
        --enable-liba52 \
        --enable-liba52bin \
        --enable-libfaac \
        --enable-libfaad \
        --enable-libfaadbin \
+       --enable-libdc1394 \
+       --enable-libdirac \
        --enable-gpl \
        --enable-libgsm \
-       --enable-libogg \
        --enable-libtheora \
        --enable-libmp3lame \
-       --enable-pp \
+       --enable-postproc \
        --enable-pthreads \
        --enable-shared \
-       --enable-swscaler \
+       --enable-swscale \
        --enable-libvorbis \
        --enable-libx264 \
        --enable-libxvid \
@@ -239,32 +290,39 @@ dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
        --disable-mmx \
 %endif
 %if %{with amr}
+       --enable-nonfree \
        --enable-libamr-nb \
        --enable-libamr-wb \
 %endif
        --cc="%{__cc}" \
-       --extra-cflags="%{rpmcflags}" \
+       --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
        --extra-ldflags="%{rpmldflags}" \
        --disable-debug \
-       --disable-opts \
+       --disable-optimizations \
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
+       $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
        $RPM_BUILD_ROOT/var/{cache,log}/ffserver
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
-install libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
+install libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
 
+# install as ffmpeg-avconfig to avoid with possible programs looking for
+# ffmpeg-config and expecting --libs output from it which is not implemented
+# simple to do (by querying pkgconfig), but why?
+install ffmpeg-config $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -300,10 +358,17 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
+%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.51
+%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.52
+%attr(755,root,root) %ghost %{_libdir}/libavformat.so.52
+%attr(755,root,root) %ghost %{_libdir}/libavutil.so.49
+%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
+%attr(755,root,root) %ghost %{_libdir}/libswscale.so.0
 %dir %{_libdir}/vhook
 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
 %attr(755,root,root) %{_libdir}/vhook/fish.so
@@ -315,12 +380,19 @@ fi
 %defattr(644,root,root,755)
 %doc doc/optimization.txt
 %attr(755,root,root) %{_libdir}/libavcodec.so
+%attr(755,root,root) %{_libdir}/libavdevice.so
 %attr(755,root,root) %{_libdir}/libavformat.so
 %attr(755,root,root) %{_libdir}/libavutil.so
 %attr(755,root,root) %{_libdir}/libpostproc.so
 %attr(755,root,root) %{_libdir}/libswscale.so
+%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
 %{_includedir}/ffmpeg
-%{_includedir}/postproc
+%{_includedir}/libavcodec
+%{_includedir}/libavdevice
+%{_includedir}/libavformat
+%{_includedir}/libavutil
+%{_includedir}/libpostproc
+%{_includedir}/libswscale
 %{_pkgconfigdir}/*.pc
 
 %files static
This page took 0.040231 seconds and 4 git commands to generate.