]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- opencv bcond, added comment about ffmpeg/opencv build dependency loop
[packages/ffmpeg.git] / ffmpeg.spec
index bb742cbf15731782faac4dc6dadd2e6b63f2dbb0..dbc35211ac22d8cee8f003cd8c2b70b7b321bcb4 100644 (file)
@@ -1,10 +1,20 @@
 # TODO
 # - is bug803 patch still needed? the code changed somehow
-# - libnut enabled   no (http://www.nut-container.org/)
+#
+# Workaround ffmpeg.spec & opencv.spec updating:
+#
+#      1. make-request -r --without opencv ffmpeg.spec
+#      2. make-request -r opencv.spec
+#      3. bump release of ffmpeg.spec
+#      4. make-request -r ffmpeg.spec
 #
 # Conditional build:
 %bcond_with    nonfree         # non free options of package (currently: faac)
+%bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
+%bcond_without frei0r          # build without frei0r video filtering
+%bcond_without opencv          # build without opencv video filtering
+%bcond_without x264            # build without x264 encoder
 %bcond_without va              # VAAPI (Video Acceleration API)
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without doc             # don't build docs
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       0.8
-Release:       1
+Version:       0.9
+Release:       2
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 7e9b8c8a6952de0c477027e48249f3ed
+# Source0-md5: 795058de6fc432aa11271408273a0535
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -30,20 +40,22 @@ URL:                http://www.ffmpeg.org/
 BuildRequires: SDL-devel
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
-BuildRequires: celt-devel
+BuildRequires: celt-devel >= 0.11.0
 BuildRequires: dirac-devel >= 1.0.0
 %{?with_nonfree:BuildRequires: faac-devel}
 BuildRequires: freetype-devel
-BuildRequires: frei0r-devel
+%{?with_frei0r:BuildRequires:  frei0r-devel}
 %ifarch ppc
 # require version with altivec support fixed
 BuildRequires: gcc >= 5:3.3.2-3
 %endif
 BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: lame-libs-devel >= 3.98.3
+%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
 BuildRequires: libdc1394-devel
 BuildRequires: libgsm-devel
-BuildRequires: libraw1394-devel
+BuildRequires: libnut-devel
+BuildRequires: libraw1394-devel >= 2
 BuildRequires: librtmp-devel
 BuildRequires: libtheora-devel >= 1.0-0.beta3
 BuildRequires: libtool >= 2:1.4d-3
@@ -51,9 +63,10 @@ BuildRequires:       libtool >= 2:1.4d-3
 BuildRequires: libvdpau-devel
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.6}
-# X264_BUILD >= 83
-BuildRequires: libx264-devel >= 0.1.3-1.20110625_2245
+# X264_BUILD >= 118
+%{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
 BuildRequires: opencore-amr-devel
+%{?with_opencv:BuildRequires:  opencv-devel}
 BuildRequires: openjpeg-devel >= 1.3-2
 BuildRequires: speex-devel >= 1:1.2-rc1
 %ifarch %{ix86}
@@ -143,13 +156,14 @@ Requires: jack-audio-connection-kit-devel
 Requires:      lame-libs-devel >= 3.98.3
 Requires:      libdc1394-devel
 Requires:      libgsm-devel
-Requires:      libraw1394-devel
+Requires:      libnut-devel
+Requires:      libraw1394-devel >= 2
 Requires:      librtmp-devel
 Requires:      libtheora-devel >= 1.0-0.beta3
 %{?with_va:Requires:   libva-devel >= 1.0.3}
 Requires:      libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 0.9.6}
-Requires:      libx264-devel >= 0.1.3-1.20110625_2245
+%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
 Requires:      opencore-amr-devel
 Requires:      openjpeg-devel >= 1.3-2
 Requires:      schroedinger-devel
@@ -295,14 +309,17 @@ EOF
        --enable-avfilter \
        --enable-gpl \
        --enable-version3 \
-       --enable-frei0r \
+       %{?with_frei0r:--enable-frei0r} \
+       %{?with_aacplus:--enable-libaacplus} \
        --enable-libdc1394 \
        --enable-libcelt \
        --enable-libdirac \
        --enable-libgsm \
        --enable-libmp3lame \
+       --enable-libnut \
        --enable-libopencore-amrnb \
        --enable-libopencore-amrwb \
+       %{?with_opencv:--enable-libopencv} \
        --enable-libopenjpeg \
        --enable-librtmp \
        --enable-libschroedinger \
@@ -312,7 +329,7 @@ EOF
        --enable-libvo-amrwbenc \
        --enable-libvorbis \
        %{?with_vpx:--enable-libvpx} \
-       --enable-libx264 \
+       %{?with_x264:--enable-libx264} \
        --enable-libxavs \
        --enable-libxvid \
        --enable-postproc \
@@ -333,8 +350,6 @@ EOF
 %endif
        --enable-runtime-cpudetect
 
-#      --enable-libopencv would cause dependency loop
-
 # force oldscaler build
 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
 
@@ -364,6 +379,8 @@ for a in libavutil/*/bswap.h; do
 done
 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
 cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
+# for lim-omx ffmpeg components
+cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
@@ -404,12 +421,14 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES,TODO} %{?with_doc:doc/*.html}
+%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
+%attr(755,root,root) %{_bindir}/avconv
 %attr(755,root,root) %{_bindir}/ffmpeg
 %attr(755,root,root) %{_bindir}/ffprobe
 %attr(755,root,root) %{_bindir}/qt-faststart
 %dir %{_datadir}/ffmpeg
 %{_datadir}/ffmpeg/*.ffpreset
+%{?with_doc:%{_mandir}/man1/avconv.1*}
 %{?with_doc:%{_mandir}/man1/ffmpeg.1*}
 %{?with_doc:%{_mandir}/man1/ffprobe.1*}
 
@@ -427,6 +446,8 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
+%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
 
@@ -440,6 +461,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavformat.so
 %attr(755,root,root) %{_libdir}/libavutil.so
 %attr(755,root,root) %{_libdir}/libpostproc.so
+%attr(755,root,root) %{_libdir}/libswresample.so
 %attr(755,root,root) %{_libdir}/libswscale.so
 %{_includedir}/ffmpeg
 %{_includedir}/libavcodec
@@ -448,6 +470,7 @@ fi
 %{_includedir}/libavformat
 %{_includedir}/libavutil
 %{_includedir}/libpostproc
+%{_includedir}/libswresample
 %{_includedir}/libswscale
 %{_pkgconfigdir}/libavcodec.pc
 %{_pkgconfigdir}/libavdevice.pc
@@ -455,6 +478,7 @@ fi
 %{_pkgconfigdir}/libavformat.pc
 %{_pkgconfigdir}/libavutil.pc
 %{_pkgconfigdir}/libpostproc.pc
+%{_pkgconfigdir}/libswresample.pc
 %{_pkgconfigdir}/libswscale.pc
 
 %files static
@@ -465,6 +489,7 @@ fi
 %{_libdir}/libavformat.a
 %{_libdir}/libavutil.a
 %{_libdir}/libpostproc.a
+%{_libdir}/libswresample.a
 %{_libdir}/libswscale.a
 
 %files ffplay
This page took 0.526826 seconds and 4 git commands to generate.