]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- -ffserver subpackage
[packages/ffmpeg.git] / ffmpeg.spec
index f7c60446c5d16e9ceb2b02b58cb8b3bdcd8a42a6..b5cbd22606375ebc4e4f822dd3adebd888550b9a 100644 (file)
@@ -1,21 +1,23 @@
-#
 # Conditional build:
-%bcond_without imlib2          # we can safely play without it :-)
+%bcond_without imlib2          # we can safely play without it:-)
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
 #
+%define        snap    20060129
+%define        _rel 8.3
 Summary:       Realtime audio/video encoder and streaming server
 Summary(pl):   Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
 Name:          ffmpeg
 Version:       0.4.9
-%define        snap    20060129
-Release:       3.%{snap}.4
+Release:       3.%{snap}.%{_rel}
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 License:       GPL
-Group:         Daemons
+Group:         Applications/Multimedia
 #Source0:      http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
 #Source0:      ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
 Source0:       %{name}-%{snap}.tar.bz2
 # Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
+Source1:       ffserver.init
+Source2:       ffserver.sysconfig
 Patch0:                %{name}-libtool.patch
 Patch1:                %{name}-libdir.patch
 Patch2:                %{name}-gcc4.patch
@@ -31,9 +33,12 @@ BuildRequires:       gcc >= 5:3.3.2-3
 %{?with_imlib2:BuildRequires:  imlib2-devel >= 1.1.0-2}
 BuildRequires: lame-libs-devel
 BuildRequires: libdts-devel
+BuildRequires: libgsm-devel
 BuildRequires: libtheora-devel
 BuildRequires: libtool >= 2:1.4d-3
 BuildRequires: libvorbis-devel
+#BuildRequires:        libx264-devel
+BuildRequires: lzo-devel
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
@@ -45,6 +50,7 @@ BuildRequires:        texinfo
 BuildRequires: xvid-devel >= 1:1.1.0
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      xvid >= 1:1.1.0
 Obsoletes:     libpostproc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -66,9 +72,6 @@ convert it into several file formats based on DCT/motion compensation
 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
 compatible stream.
 
-This package contains also ffmpeg shared libraries (libavcodec and
-libavformat).
-
 %description -l pl
 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
@@ -77,19 +80,28 @@ format
 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
 strumienia kompatybilnego z AC3.
 
-Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
-libavformat).
+%package libs
+Summary:       ffmpeg libraries
+Summary(pl):   Biblioteki ffmpeg
+Group:         Libraries
+
+%description libs
+This package contains ffmpeg shared libraries.
+
+%description libs -l pl
+Ten pakiet zawiera biblioteki wspó³dzielone ffmpeg.
 
 %package devel
 Summary:       ffmpeg header files
 Summary(pl):   Pliki nag³ówkowe ffmpeg
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     libpostproc-devel
 # for libavcodec:
 Requires:      faac-devel
 Requires:      lame-libs-devel
 Requires:      libdts-devel
+Requires:      libgsm-devel
 Requires:      libtheora-devel
 Requires:      libvorbis-devel
 Requires:      xvid-devel >= 1:1.1.0
@@ -117,7 +129,7 @@ Statyczne biblioteki ffmpeg (libavcodec i libavformat).
 Summary:       FFplay - SDL-based media player
 Summary(pl):   FFplay - odtwarzacz mediów oparty na SDL
 Group:         Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description ffplay
 FFplay is a very simple and portable media player using the FFmpeg
@@ -133,7 +145,7 @@ testowania r
 Summary:       imlib2 based hook
 Summary(pl):   Modu³ przej¶ciowy oparty o imlib2
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description vhook-imlib2
 This module implements a text overlay for a video image. Currently it
@@ -147,8 +159,18 @@ obs
 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
 obrazie.
 
+%package ffserver
+Summary:       FFserver video server
+Group:         Daemons
+
+%description ffserver
+FFserver is a streaming server for both audio and video. It supports
+several live feeds, streaming from files and time shifting on live
+feeds (you can seek to positions in the past on each live feed,
+provided you specify a big enough feed storage in ffserver.conf).
+
 %prep
-%setup -q -n ffmpeg
+%setup -q -n %{name}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -156,8 +178,6 @@ obrazie.
 %build
 # notes:
 # - it's not autoconf configure
-# - -fomit-frame-pointer is always needed on x86 due to lack of registers
-#   (-fPIC takes one)
 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
 ./configure \
        --prefix=%{_prefix} \
@@ -165,11 +185,13 @@ obrazie.
        --mandir=%{_mandir} \
        --disable-strip \
        --enable-a52 \
+       --enable-a52bin \
        --enable-dts \
        --enable-faac \
        --enable-faad \
        --enable-faadbin \
        --enable-gpl \
+       --enable-libgsm \
        --enable-libogg \
        --enable-mp3lame \
        --enable-pp \
@@ -196,12 +218,14 @@ obrazie.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
 
 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
@@ -214,9 +238,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changelog README doc/*.html
+%doc Changelog README doc/*.html doc/TODO
 %attr(755,root,root) %{_bindir}/ffmpeg
-%attr(755,root,root) %{_sbindir}/ffserver
+%{_mandir}/man1/ffmpeg.1*
+
+%files libs
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
@@ -227,12 +254,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vhook/null.so
 %attr(755,root,root) %{_libdir}/vhook/ppm.so
 %attr(755,root,root) %{_libdir}/vhook/watermark.so
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
-%{_mandir}/man1/ffmpeg.1*
-%{_mandir}/man1/ffserver.1*
 
 %files devel
 %defattr(644,root,root,755)
+%doc doc/optimization.txt
 %attr(755,root,root) %{_libdir}/libavcodec.so
 %attr(755,root,root) %{_libdir}/libavformat.so
 %attr(755,root,root) %{_libdir}/libavutil.so
@@ -256,3 +281,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
 %endif
+
+%files ffserver
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
+%attr(755,root,root) %{_sbindir}/ffserver
+%attr(754,root,root) /etc/rc.d/init.d/ffserver
+%{_mandir}/man1/ffserver.1*
This page took 0.121017 seconds and 4 git commands to generate.