]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- release 3 (by relup.sh)
[packages/ffmpeg.git] / ffmpeg.spec
index a5e44af39a0a169de20762e3f2198496fba74067..a25415dbf9e57718d3913c43157cb5049d08f6e8 100644 (file)
@@ -7,9 +7,10 @@
 #
 # Conditional build:
 %bcond_with    bootstrap       # disable features to able to build without installed ffmpeg
-%bcond_with    nonfree         # non free options of package (currently: faac)
+%bcond_with    nonfree         # non free options of package (currently: aacplus, faac, fdk_aac, nvenc)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
+%bcond_with    faac            # faac (requires nonfree)
 %bcond_without bs2b            # BS2B audio filter support
 %bcond_without caca            # textual display using libcaca
 %bcond_without dcadec          # DCA decoding via libdcadec
@@ -19,6 +20,7 @@
 %bcond_without fribidi         # fribidi support
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without kvazaar         # Kvazaar HEVC encoder support
 %bcond_without ladspa          # LADSPA audio filtering
 %bcond_with    mfx             # MFX hardware acceleration support
 %bcond_with    nvenc           # NVIDIA NVENC support (requires nonfree)
@@ -30,6 +32,7 @@
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
+%bcond_without snappy          # Snappy compression support (needed for hap encoding)
 %bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.7.1
-Release:       1
+Version:       2.8.4
+Release:       3
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
-Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: f159c6d7eed8546b23e1a17325cbf1f8
+Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
+# Source0-md5: ac1e3d6934f9efd8b67713677c7fd99f
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
+Patch0:                %{name}-kvazaar.patch
+Patch1:                %{name}-utvideo.patch
 URL:           http://www.ffmpeg.org/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
@@ -81,7 +86,7 @@ BuildRequires:        alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
 %{?with_dcadec:BuildRequires:  dcadec-devel}
-%{?with_nonfree:BuildRequires: faac-devel}
+%{?with_faac:BuildRequires:    faac-devel}
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 %{?with_flite:BuildRequires:   flite-devel >= 1.4}
 BuildRequires: fontconfig-devel
@@ -96,6 +101,7 @@ BuildRequires:       gcc >= 5:3.3.2-3
 BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
+%{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.7}
 %{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
@@ -110,7 +116,7 @@ BuildRequires:      libgsm-devel
 BuildRequires: libiec61883-devel
 BuildRequires: libmodplug-devel
 BuildRequires: libnut-devel
-%{?with_quvi:BuildRequires:    libquvi-devel}
+%{?with_quvi:BuildRequires:    libquvi-0.4-devel}
 BuildRequires: libraw1394-devel >= 2
 BuildRequires: librtmp-devel
 %{?with_ssh:BuildRequires:     libssh-devel}
@@ -149,13 +155,14 @@ BuildRequires:    pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
 %{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
+%{?with_snappy:BuildRequires:  snappy-devel}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
 %{?with_doc:BuildRequires:     texi2html}
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
-%{?with_utvideo:BuildRequires: utvideo-devel >= 12}
+%{?with_utvideo:BuildRequires: utvideo-devel >= 15.3}
 %{?with_vidstab:BuildRequires: vid.stab-devel >= 0.98}
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
@@ -174,7 +181,7 @@ BuildRequires:      zlib-devel
 # overflows maximum hash table size
 BuildConflicts:        pdksh < 5.2.14-57
 Requires:      %{name}-libs = %{version}-%{release}
-%{?with_utvideo:Requires:      utvideo >= 12}
+%{?with_utvideo:Requires:      utvideo >= 15.3}
 %{?with_ilbc:Requires: webrtc-libilbc}
 Requires:      xvid >= 1:1.1.0
 Obsoletes:     libpostproc
@@ -243,7 +250,7 @@ Requires:   alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
 %{?with_dcadec:Requires:       dcadec-devel}
-%{?with_nonfree:Requires:      faac-devel}
+%{?with_faac:Requires: faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
 %{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      fontconfig-devel
@@ -251,6 +258,7 @@ Requires:   freetype-devel
 %{?with_fribidi:Requires:      fribidi-devel}
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
+%{?with_kvazaar:Requires:      kvazaar-devel >= 0.7}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -264,7 +272,7 @@ Requires:   libgsm-devel
 Requires:      libiec61883-devel
 Requires:      libmodplug-devel
 Requires:      libnut-devel
-%{?with_quvi:Requires: libquvi-devel}
+%{?with_quvi:Requires: libquvi-0.4-devel}
 Requires:      libraw1394-devel >= 2
 Requires:      librtmp-devel
 %{?with_smb:Requires:  libsmbclient-devel}
@@ -282,10 +290,11 @@ Requires: opencore-amr-devel
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
+%{?with_snappy:Requires:       snappy-devel}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
-%{?with_utvideo:Requires:      utvideo-devel >= 12}
+%{?with_utvideo:Requires:      utvideo-devel >= 15.3}
 %{?with_vidstab:Requires:      vid.stab-devel >= 0.98}
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
@@ -370,6 +379,8 @@ Dokumentacja pakietu FFmpeg w formacie HTML.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
@@ -450,6 +461,7 @@ EOF
        --disable-debug \
        --disable-optimizations \
        --disable-stripping \
+       %{!?with_doc:--disable-doc} \
        --enable-avfilter \
        --enable-avresample \
        %{?with_decklink:--enable-decklink} \
@@ -459,7 +471,6 @@ EOF
        --enable-fontconfig \
        %{?with_frei0r:--enable-frei0r} \
        %{?with_ladspa:--enable-ladspa} \
-       %{?with_aacplus:--enable-libaacplus} \
        --enable-libass \
        --enable-libbluray \
        %{?with_bs2b:--enable-libbs2b} \
@@ -468,7 +479,6 @@ EOF
        --enable-libcdio \
        --enable-libdc1394 \
        %{?with_dcadec:--enable-libdcadec} \
-       %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
        %{?with_fribidi:--enable-libfribidi} \
@@ -476,6 +486,7 @@ EOF
        --enable-libgsm \
        --enable-libiec61883 \
        %{?with_ilbc:--enable-libilbc} \
+       %{?with_kvazaar:--enable-libkvazaar} \
        %{?with_mfx:--enable-libmfx} \
        --enable-libmodplug \
        --enable-libmp3lame \
@@ -492,6 +503,7 @@ EOF
        --enable-libschroedinger \
        %{?with_shine:--enable-libshine} \
        %{?with_smb:--enable-libsmbclient} \
+       %{?with_snappy:--enable-libsnappy} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        %{?with_ssh:--enable-libssh} \
@@ -512,7 +524,6 @@ EOF
        --enable-libxvid \
        %{?with_zmq:--enable-libzmq} \
        %{?with_zvbi:--enable-libzvbi} \
-       %{?with_nvenc:--enable-nvenc} \
        %{?with_openal:--enable-openal} \
        %{?with_opencl:--enable-opencl} \
        %{?with_opengl:--enable-opengl} \
@@ -533,7 +544,10 @@ EOF
 %endif
 %if %{with nonfree}
        --enable-nonfree \
-       --enable-libfaac \
+       %{?with_aacplus:--enable-libaacplus} \
+       %{?with_faac:--enable-libfaac} \
+       %{?with_fdk_aac:--enable-libfdk-aac} \
+       %{?with_nvenc:--enable-nvenc} \
 %endif
        --enable-runtime-cpudetect
 
@@ -576,7 +590,9 @@ install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
 
 # packaged as %doc in -doc
+%if %{with doc}
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
+%endif
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.305155 seconds and 4 git commands to generate.