]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- release 2 (by relup.sh)
[packages/ffmpeg.git] / ffmpeg.spec
index 642a5302ae17981aaaf2a451903527fa141df320..90a84e6e6c697cac7e483a7ad66ecfb6cc63616b 100644 (file)
@@ -7,12 +7,12 @@
 #
 # Conditional build:
 %bcond_with    bootstrap       # disable features to able to build without installed ffmpeg
-%bcond_with    nonfree         # non free options of package (currently: aacplus, faac, fdk_aac, nvenc)
-%bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
+%bcond_with    nonfree         # non free options of package (currently: faac, fdk_aac, nvenc)
 %bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
 %bcond_with    faac            # faac (requires nonfree)
 %bcond_without bs2b            # BS2B audio filter support
 %bcond_without caca            # textual display using libcaca
+%bcond_without chromaprint     # audio fingerprinting with chromaprint
 %bcond_without dcadec          # DCA decoding via libdcadec
 %bcond_without decklink        # Blackmagic DeskLink output support
 %bcond_without flite           # flite voice synthesis support
 %bcond_without opengl          # OpenGL rendering support
 %bcond_with    openh264        # OpenH264 H.264 encoder
 %bcond_without pulseaudio      # PulseAudio input support
+%bcond_without rubberband      # rubberband filter
 %bcond_without shine           # shine fixed-point MP3 encoder
 %bcond_without snappy          # Snappy compression support (needed for hap encoding)
 %bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
+%bcond_with    tesseract       # OCR filter based on Tesseract
 %bcond_without x264            # H.264 x264 encoder
 %bcond_without x265            # H.265/HEVC x265 encoder
 %bcond_without utvideo         # Ut Video decoder
@@ -43,6 +45,7 @@
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without wavpack         # wavpack encoding support
 %bcond_without webp            # WebP encoding support
+%bcond_without zimg            # zscale filter based on z.lib
 %bcond_without zmq             # 0MQ message passing
 %bcond_without zvbi            # teletext via libzvbi
 %bcond_without doc             # don't build docs
@@ -62,7 +65,7 @@ Summary:      FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
 Version:       3.0
-Release:       1
+Release:       2
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
@@ -102,13 +105,13 @@ BuildRequires:    jack-audio-connection-kit-devel
 %{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.8.1}
 %{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
-%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
 BuildRequires: libass-devel
 BuildRequires: libavc1394-devel
 %{?with_bs2b:BuildRequires:    libbs2b-devel}
 BuildRequires: libbluray-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
 BuildRequires: libcdio-paranoia-devel >= 0.90-2
+%{?with_chromaprint:BuildRequires:     libchromaprint-devel}
 BuildRequires: libdc1394-devel >= 2
 BuildRequires: libgsm-devel
 BuildRequires: libiec61883-devel
@@ -150,11 +153,13 @@ BuildRequires:    perl-tools-pod
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.470
+%{?with_rubberband:BuildRequires:      rubberband-devel >= 1.8.1}
 BuildRequires: schroedinger-devel
 %{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
 %{?with_snappy:BuildRequires:  snappy-devel}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
+%{?with_tesseract:BuildRequires:       tesseract-devel}
 %{?with_doc:BuildRequires:     tetex}
 %{?with_doc:BuildRequires:     texi2html}
 %{?with_doc:BuildRequires:     texinfo}
@@ -171,8 +176,9 @@ BuildRequires:      xorg-lib-libXfixes-devel
 BuildRequires: xvid-devel >= 1:1.1.0
 BuildRequires: yasm
 %{?with_zmq:BuildRequires:     zeromq-devel}
-%{?with_zvbi:BuildRequires:    zvbi-devel}
+%{?with_zimg:BuildRequires:    zimg-devel}
 BuildRequires: zlib-devel
+%{?with_zvbi:BuildRequires:    zvbi-devel}
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
 # overflows maximum hash table size
 BuildConflicts:        pdksh < 5.2.14-57
@@ -216,6 +222,7 @@ Group:              Libraries
 Requires:      gnutls-libs >= 3.0.20
 %endif
 %{?with_vpx:Requires:  libvpx >= 1.3.0}
+%{?with_rubberband:Requires:   rubberband-libs >= 1.8.1}
 
 %description libs
 This package contains the ffmpeg shared libraries:
@@ -256,13 +263,13 @@ Requires: freetype-devel
 Requires:      jack-audio-connection-kit-devel
 %{?with_kvazaar:Requires:      kvazaar-devel >= 0.7}
 Requires:      lame-libs-devel >= 3.98.3
-%{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
 Requires:      libavc1394-devel
 Requires:      libbluray-devel
 %{?with_bs2b:Requires: libbs2b-devel}
 %{?with_caca:Requires: libcaca-devel}
 Requires:      libcdio-paranoia-devel >= 0.90-2
+%{?with_chromaprint:Requires:  libchromaprint-devel}
 Requires:      libdc1394-devel >= 2
 Requires:      libgsm-devel
 Requires:      libiec61883-devel
@@ -283,11 +290,13 @@ Requires: opencore-amr-devel
 %{?with_opencv:Requires:       opencv-devel}
 %{?with_openh264:Requires:     openh264-devel >= 1.3}
 Requires:      openjpeg-devel >= 1.5
+%{?with_rubberband:Requires:   rubberband-devel >= 1.8.1}
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
 %{?with_snappy:Requires:       snappy-devel}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
+%{?with_tesseract:Requires:    tesseract-devel}
 Requires:      twolame-devel
 %{?with_utvideo:Requires:      utvideo-devel >= 15.4}
 %{?with_vidstab:Requires:      vid.stab-devel >= 0.98}
@@ -299,6 +308,7 @@ Requires:   xorg-lib-libXext-devel
 Requires:      xorg-lib-libXfixes-devel
 Requires:      xvid-devel >= 1:1.1.0
 %{?with_zmq:Requires:  zeromq-devel}
+%{?with_zimg:Requires: zimg-devel}
 Requires:      zlib-devel
 Obsoletes:     libpostproc-devel
 
@@ -457,6 +467,7 @@ EOF
        %{!?with_doc:--disable-doc} \
        --enable-avfilter \
        --enable-avresample \
+       %{?with_chromaprint:--enable-chromaprint} \
        %{?with_decklink:--enable-decklink} \
        --enable-gnutls \
        --enable-gpl \
@@ -492,6 +503,7 @@ EOF
        --enable-libopus \
        %{?with_pulseaudio:--enable-libpulse} \
        --enable-librtmp \
+       %{?with_rubberband:--enable-librubberband} \
        --enable-libschroedinger \
        %{?with_shine:--enable-libshine} \
        %{?with_smb:--enable-libsmbclient} \
@@ -499,6 +511,7 @@ EOF
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        %{?with_ssh:--enable-libssh} \
+       %{?with_tesseract:--enable-libtesseract} \
        --enable-libtheora \
        --enable-libtwolame \
        %{?with_utvideo:--enable-libutvideo} \
@@ -513,6 +526,7 @@ EOF
        %{?with_x265:--enable-libx265} \
        --enable-libxavs \
        --enable-libxvid \
+       %{?with_zimg:--enable-libzimg} \
        %{?with_zmq:--enable-libzmq} \
        %{?with_zvbi:--enable-libzvbi} \
        %{?with_openal:--enable-openal} \
@@ -535,7 +549,6 @@ EOF
 %endif
 %if %{with nonfree}
        --enable-nonfree \
-       %{?with_aacplus:--enable-libaacplus} \
        %{?with_faac:--enable-libfaac} \
        %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_nvenc:--enable-nvenc} \
This page took 0.064447 seconds and 4 git commands to generate.