]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- added cdio-paranoia patch: adjust for separate libcdio-paranoia
[packages/ffmpeg.git] / ffmpeg.spec
index d8581f586e8e35aa00348d38b67631bb20e236d1..4ceee0ea0099cf056dc0136fe7c1abc0813d50c6 100644 (file)
@@ -1,4 +1,3 @@
-# TODO: libilbc (requires webrtc.org version), flite (some additional voices required)
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_with    fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
-%bcond_without autoreqdep      # don't care about package name deps generated by rpm
 %bcond_without caca            # textual display using libcaca
-%bcond_with    flite           # flite voice synthesis support [ffmpeg expects more voices]
-%bcond_without frei0r          # build without frei0r video filtering
-%bcond_with    ilbc            # iLBC de/encoding via libilbc
-%bcond_without openal          # build without OpenAL 1.1 capture support
-%bcond_without opencv          # build without opencv video filtering
-%bcond_without pulseaudio      # build without PulseAudio input support
-%bcond_without x264            # build without x264 encoder
-%bcond_without utvideo         # build without Ut Video decoder
+%bcond_without flite           # flite voice synthesis support
+%bcond_without frei0r          # frei0r video filtering
+%bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without openal          # OpenAL 1.1 capture support
+%bcond_without opencv          # OpenCV video filtering
+%bcond_without pulseaudio      # PulseAudio input support
+%bcond_without x264            # x264 encoder
+%bcond_without utvideo         # Ut Video decoder
 %bcond_without va              # VAAPI (Video Acceleration API)
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without doc             # don't build docs
@@ -27,7 +25,7 @@
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       1.0
+Version:       1.0.1
 Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
@@ -35,13 +33,14 @@ Release:    1
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 3ed526cea20c1bffb5a37f7730f710bd
+# Source0-md5: dbbb88ce5525dea22b24aaa098a9bcc2
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
 Patch0:                %{name}-gsm.patch
 Patch1:                %{name}-opencv24.patch
 Patch2:                %{name}-openjpeg.patch
+Patch3:                %{name}-cdio-paranoia.patch
 URL:           http://www.ffmpeg.org/
 %{?with_openal:BuildRequires:  OpenAL-devel}
 BuildRequires: SDL-devel >= 1.2.1
@@ -50,7 +49,7 @@ BuildRequires:        bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
 %{?with_nonfree:BuildRequires: faac-devel}
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
-%{?with_flite:BuildRequires:   flite-devel}
+%{?with_flite:BuildRequires:   flite-devel >= 1.4}
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel
 %{?with_frei0r:BuildRequires:  frei0r-devel}
@@ -66,11 +65,10 @@ BuildRequires:      libass-devel
 BuildRequires: libavc1394-devel
 BuildRequires: libbluray-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
-BuildRequires: libcdio-devel
+BuildRequires: libcdio-paranoia-devel >= 0.90-2
 BuildRequires: libdc1394-devel >= 2
 BuildRequires: libgsm-devel
 BuildRequires: libiec61883-devel
-%{?with_ilbc:BuildRequires:    libilbc-devel}
 BuildRequires: libmodplug-devel
 BuildRequires: libnut-devel
 BuildRequires: libraw1394-devel >= 2
@@ -105,18 +103,20 @@ BuildRequires:    speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
 %{?with_utvideo:BuildRequires: utvideo-devel}
-BuildRequires: yasm
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
+%{?with_ilbc:BuildRequires:    webrtc-libilbc-devel}
 BuildRequires: xavs-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xvid-devel >= 1:1.1.0
+BuildRequires: yasm
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
 # overflows maximum hash table size
 BuildConflicts:        pdksh < 5.2.14-57
 Requires:      %{name}-libs = %{version}-%{release}
+%{?with_ilbc:Requires: webrtc-libilbc}
 Requires:      xvid >= 1:1.1.0
 Obsoletes:     libpostproc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -181,17 +181,16 @@ Requires: celt-devel >= 0.11.0
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 Requires:      jack-audio-connection-kit-devel
-%{?with_flite:Requires:        flite-devel}
+%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
 Requires:      libavc1394-devel
 Requires:      libbluray-devel
-Requires:      libcdio-devel
+Requires:      libcdio-paranoia-devel >= 0.90-2
 Requires:      libdc1394-devel >= 2
 Requires:      libgsm-devel
 Requires:      libiec61883-devel
-%{?with_ilbc:Requires: libilbc-devel}
 Requires:      libmodplug-devel
 Requires:      libnut-devel
 Requires:      libraw1394-devel >= 2
@@ -202,12 +201,14 @@ Requires: libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 0.9.6}
 %{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
 Requires:      opencore-amr-devel
+%{?with_opencv:Requires:       opencv-devel}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
+%{?with_ilbc:Requires: webrtc-libilbc-devel}
 Requires:      xavs-devel
 Requires:      xorg-lib-libXext-devel
 Requires:      xorg-lib-libXfixes-devel
@@ -275,6 +276,7 @@ dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
 %patch0 -p1
 %patch1 -p0
 %patch2 -p1
+%patch3 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
This page took 0.056174 seconds and 4 git commands to generate.