]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- bootstrap release 0.1
[packages/ffmpeg.git] / ffmpeg.spec
index 4987575309f6ed7d72830592891cd586ce339d62..4a4ebfc073188767552a74874da576510f80be7b 100644 (file)
@@ -1,16 +1,18 @@
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
-#      1. make-request -r --without opencv ffmpeg.spec
+#      1. make-request -r --with bootstrap ffmpeg.spec
 #      2. make-request -r opencv.spec
 #      3. bump release of ffmpeg.spec
 #      4. make-request -r ffmpeg.spec
 #
 # Conditional build:
+%bcond_with    bootstrap       # disable features to able to build without installed ffmpeg
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
 %bcond_without bs2b            # BS2B audio filter support
 %bcond_without caca            # textual display using libcaca
+%bcond_without dcadec          # DCA decoding via libdcadec
 %bcond_without decklink        # Blackmagic DeskLink output support
 %bcond_without flite           # flite voice synthesis support
 %bcond_without frei0r          # frei0r video filtering
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
 %bcond_without ladspa          # LADSPA audio filtering
-%bcond_without ssh             # SFTP protocol support via libssh
+%bcond_with    mfx             # MFX hardware acceleration support
+%bcond_with    nvenc           # NVIDIA NVENC support (requires nonfree)
 %bcond_without openal          # OpenAL 1.1 capture support
 %bcond_without opencl          # OpenCL 1.2 code
-%bcond_without opengl          # OpenGL rendering support
 %bcond_without opencv          # OpenCV video filtering
+%bcond_without opengl          # OpenGL rendering support
+%bcond_with    openh264        # OpenH264 H.264 encoder
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
+%bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
 %bcond_without x264            # H.264 x264 encoder
 %bcond_without doc             # don't build docs
 %bcond_with    tests           # "make check" (some tests fail as of 2.5)
 
+%if %{with bootstrap}
+%undefine      with_opencv
+%endif
+
 %ifnarch %{ix86} %{x8664} arm
 %undefine      with_x265
 %endif
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.5.3
-Release:       3
+Version:       2.7.2
+Release:       0.1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: efba7c5cfbea9ce58ff693cd08f90ffa
+# Source0-md5: 7eb2140bab9f0a8669b65b50c8e4cfb5
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -71,6 +80,7 @@ BuildRequires:        SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
+%{?with_dcadec:BuildRequires:  dcadec-devel}
 %{?with_nonfree:BuildRequires: faac-devel}
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 %{?with_flite:BuildRequires:   flite-devel >= 1.4}
@@ -83,6 +93,7 @@ BuildRequires:        freetype-devel
 # require version with altivec support fixed
 BuildRequires: gcc >= 5:3.3.2-3
 %endif
+BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
 %{?with_ladspa:BuildRequires:  ladspa-devel}
@@ -111,20 +122,24 @@ BuildRequires:    libv4l-devel
 BuildRequires: libvdpau-devel >= 0.2
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 1.3.0}
-%{?with_webp:BuildRequires:    libwebp-devel >= 0.2.0}
+%{?with_webp:BuildRequires:    libwebp-devel >= 0.4.0}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
-# X265_BUILD >= 17
-%{?with_x265:BuildRequires:    libx265-devel >= 1.3}
+# X265_BUILD >= 57
+%{?with_x265:BuildRequires:    libx265-devel >= 1.3-0.20150610.1}
 # libxcb xcb-shm xcb-xfixes xcb-shape
-BuildRequires: libxcb-devel
+BuildRequires: libxcb-devel >= 1.4
+%{?with_mfx:BuildRequires:     mfx_dispatch-devel}
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
 %endif
 %endif
+# which package?
+#%{?with_nvenc:BuildRequires:  NVIDIA-NVENC-API}
 BuildRequires: opencore-amr-devel
 %{?with_opencv:BuildRequires:  opencv-devel}
+%{?with_openh264:BuildRequires:        openh264-devel >= 1.3}
 BuildRequires: openjpeg-devel >= 1.5
 BuildRequires: opus-devel
 BuildRequires: perl-Encode
@@ -227,6 +242,7 @@ Requires:   SDL-devel >= 1.2.1
 Requires:      alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
+%{?with_dcadec:Requires:       dcadec-devel}
 %{?with_nonfree:Requires:      faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
 %{?with_flite:Requires:        flite-devel >= 1.4}
@@ -256,11 +272,13 @@ Requires: libtheora-devel >= 1.0-0.beta3
 %{?with_va:Requires:   libva-devel >= 1.0.3}
 Requires:      libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 1.3.0}
-%{?with_webp:Requires: libwebp-devel >= 0.2.0}
+%{?with_webp:Requires: libwebp-devel >= 0.4.0}
 %{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
-%{?with_x265:Requires: libx265-devel >= 0.7}
+%{?with_x265:Requires: libx265-devel >= 1.3-0.20150610.1}
+%{?with_mfx:Requires:  mfx_dispatch-devel}
 Requires:      opencore-amr-devel
 %{?with_opencv:Requires:       opencv-devel}
+%{?with_openh264:Requires:     openh264-devel >= 1.3}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
@@ -449,6 +467,7 @@ EOF
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
+       %{?with_dcadec:--enable-libdcadec} \
        %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
@@ -457,12 +476,14 @@ EOF
        --enable-libgsm \
        --enable-libiec61883 \
        %{?with_ilbc:--enable-libilbc} \
+       %{?with_mfx:--enable-libmfx} \
        --enable-libmodplug \
        --enable-libmp3lame \
        --enable-libnut \
        --enable-libopencore-amrnb \
        --enable-libopencore-amrwb \
        %{?with_opencv:--enable-libopencv} \
+       %{?with_openh264:--enable-libopenh264} \
        --enable-libopenjpeg \
        --enable-libopus \
        %{?with_pulseaudio:--enable-libpulse} \
@@ -491,6 +512,7 @@ EOF
        --enable-libxvid \
        %{?with_zmq:--enable-libzmq} \
        %{?with_zvbi:--enable-libzvbi} \
+       %{?with_nvenc:--enable-nvenc} \
        %{?with_openal:--enable-openal} \
        %{?with_opencl:--enable-opencl} \
        %{?with_opengl:--enable-opengl} \
@@ -506,6 +528,9 @@ EOF
 %ifarch i386 i486
        --disable-mmx \
 %endif
+%ifarch x32
+       --disable-asm \
+%endif
 %if %{with nonfree}
        --enable-nonfree \
        --enable-libfaac \
This page took 0.137846 seconds and 4 git commands to generate.