]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- ah, merge from DEVEL
[packages/ffmpeg.git] / ffmpeg.spec
index fffd64c2841135ad669bb1ea0976f6797762a249..1dd9f3cc8199578e9e9b438e30e7d6c5ef6d3ea2 100644 (file)
@@ -2,17 +2,18 @@
 # TODO: update for lzo 2.x (currently only lzo 1.x is supported)
 #
 # Conditional build:
-%bcond_without amr             # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
+%bcond_with    amr             # build 3GPP Adaptive Multi Rate (AMR) speech codec
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
 %bcond_without imlib2          # don't build imlib2 vhook module
 %bcond_with    lzo             # build with LZO support
 #
+%define                _snap   2006-12-04
+%define                snap    %(echo %{_snap} | tr -d -)
+%define                _rel 0.3
 Summary:       Realtime audio/video encoder and streaming server
 Summary(pl):   Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
 Name:          ffmpeg
 Version:       0.4.9
-%define                snap    20060129
-%define                _rel 12
 Release:       3.%{snap}.%{_rel}
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, a52, xvid, x264, dts, faad)
@@ -20,8 +21,9 @@ License:      GPL with LGPL parts
 Group:         Applications/Multimedia
 #Source0:      http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
 #Source0:      ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
-Source0:       %{name}-%{snap}.tar.bz2
-# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
+#Source0:      %{name}-%{snap}.tar.bz2
+Source0:       http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
+# Source0-md5: 5be2e4d1e326bb7809205a3401204621
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -29,6 +31,8 @@ Patch0:               %{name}-libtool.patch
 Patch1:                %{name}-libdir.patch
 Patch2:                %{name}-gcc4.patch
 Patch3:                %{name}-system-amr.patch
+Patch4:                %{name}-x264-symbol.patch
+Patch5:                %{name}-as_needed.patch
 URL:           http://ffmpeg.mplayerhq.hu/
 BuildRequires: SDL-devel
 %if %{with amr}
@@ -49,8 +53,8 @@ BuildRequires:        libgsm-devel
 BuildRequires: libtheora-devel
 BuildRequires: libtool >= 2:1.4d-3
 BuildRequires: libvorbis-devel
-BuildRequires: libx264-devel >= 0.1.2-1.20060430_2245.1
-%{?with_lzo:BuildRequires:     lzo-devel < 2.0}
+BuildRequires: libx264-devel >= 0.1.2-1.20061024_2245.1
+#%{?with_lzo:BuildRequires:    lzo-devel < 2.0}
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
@@ -122,8 +126,8 @@ Requires:   libdts-devel
 Requires:      libgsm-devel
 Requires:      libtheora-devel
 Requires:      libvorbis-devel
-%{?with_lzo:Requires:  lzo-devel < 2.0}
-Requires:      libx264-devel >= 0.1.2-1.20060430_2245.1
+Requires:      libx264-devel >= 0.1.2-1.20060828_2245.1
+#%{?with_lzo:Requires: lzo-devel < 2.0}
 Requires:      xvid-devel >= 1:1.1.0
 Requires:      zlib-devel
 Obsoletes:     libpostproc-devel
@@ -185,8 +189,8 @@ Summary:    FFserver video server
 Summary(pl):   FFserver - serwer strumieni obrazu
 Group:         Daemons
 Requires(post,preun):  /sbin/chkconfig
-Requires:      rc-scripts >= 0.4.0.10
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      rc-scripts >= 0.4.0.10
 
 %description ffserver
 FFserver is a streaming server for both audio and video. It supports
@@ -202,11 +206,13 @@ przesz
 du¿ej przestrzeni na dane skonfigurowanej w ffserver.conf).
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name}-export-%{_snap}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1 NEEDS UPDATE
+%patch4 -p1
+#%patch5 -p1 MIGHT BE UNNECCESSARY
 
 %build
 # notes:
@@ -216,7 +222,6 @@ du
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --mandir=%{_mandir} \
-       %{!?with_lzo:--disable-lzo} \
        --disable-strip \
        --enable-a52 \
        --enable-a52bin \
@@ -231,7 +236,6 @@ du
        --enable-pp \
        --enable-pthreads \
        --enable-shared \
-       --enable-theora \
        --enable-vorbis \
        --enable-x264 \
        --enable-xvid \
@@ -250,10 +254,13 @@ du
        --extra-ldflags="%{rpmldflags}" \
        --disable-debug \
        --disable-opts \
-       --tune=generic
 
-%{__make} \
-       BUILD_DOC=yes
+# GONE?
+#      %{!?with_lzo:--disable-lzo} \
+#      --enable-theora \
+#      --tune=generic
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -321,7 +328,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavformat.so
 %attr(755,root,root) %{_libdir}/libavutil.so
 %attr(755,root,root) %{_libdir}/libpostproc.so
-%{_libdir}/lib*.la
+#%{_libdir}/lib*.la
 %{_includedir}/ffmpeg
 %{_includedir}/postproc
 %{_pkgconfigdir}/*.pc
This page took 0.060643 seconds and 4 git commands to generate.