]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- ah, merge from DEVEL
[packages/ffmpeg.git] / ffmpeg.spec
index 901b6b0aadd7f6a927cafa1c4a6806287f1630a2..1dd9f3cc8199578e9e9b438e30e7d6c5ef6d3ea2 100644 (file)
@@ -1,29 +1,44 @@
+#
+# TODO: update for lzo 2.x (currently only lzo 1.x is supported)
+#
 # Conditional build:
-%bcond_without imlib2          # we can safely play without it:-)
+%bcond_with    amr             # build 3GPP Adaptive Multi Rate (AMR) speech codec
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
+%bcond_without imlib2          # don't build imlib2 vhook module
+%bcond_with    lzo             # build with LZO support
 #
-%define        snap    20060129
-%define        _rel 8.6
+%define                _snap   2006-12-04
+%define                snap    %(echo %{_snap} | tr -d -)
+%define                _rel 0.3
 Summary:       Realtime audio/video encoder and streaming server
 Summary(pl):   Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
 Name:          ffmpeg
 Version:       0.4.9
 Release:       3.%{snap}.%{_rel}
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
-License:       GPL
+# (postprocessing, a52, xvid, x264, dts, faad)
+License:       GPL with LGPL parts
 Group:         Applications/Multimedia
 #Source0:      http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
 #Source0:      ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
-Source0:       %{name}-%{snap}.tar.bz2
-# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
+#Source0:      %{name}-%{snap}.tar.bz2
+Source0:       http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
+# Source0-md5: 5be2e4d1e326bb7809205a3401204621
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
 Patch0:                %{name}-libtool.patch
 Patch1:                %{name}-libdir.patch
 Patch2:                %{name}-gcc4.patch
-URL:           http://ffmpeg.sourceforge.net/
+Patch3:                %{name}-system-amr.patch
+Patch4:                %{name}-x264-symbol.patch
+Patch5:                %{name}-as_needed.patch
+URL:           http://ffmpeg.mplayerhq.hu/
 BuildRequires: SDL-devel
+%if %{with amr}
+BuildRequires: amrnb-devel
+BuildRequires: amrwb-devel >= 5.3.0
+%endif
 BuildRequires: faac-devel
 BuildRequires: faad2-devel
 BuildRequires: freetype-devel
@@ -38,8 +53,8 @@ BuildRequires:        libgsm-devel
 BuildRequires: libtheora-devel
 BuildRequires: libtool >= 2:1.4d-3
 BuildRequires: libvorbis-devel
-#BuildRequires:        libx264-devel
-BuildRequires: lzo-devel
+BuildRequires: libx264-devel >= 0.1.2-1.20061024_2245.1
+#%{?with_lzo:BuildRequires:    lzo-devel < 2.0}
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
@@ -49,6 +64,7 @@ BuildRequires:        perl-tools-pod
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: tetex
 BuildRequires: texinfo
+%{?with_amr:BuildRequires:     unzip}
 BuildRequires: xvid-devel >= 1:1.1.0
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
@@ -98,16 +114,23 @@ Summary:   ffmpeg header files
 Summary(pl):   Pliki nag³ówkowe ffmpeg
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     libpostproc-devel
 # for libavcodec:
+%if %{with amr}
+Requires:      amrnb-devel
+Requires:      amrwb-devel >= 5.3.0
+%endif
 Requires:      faac-devel
+Requires:      faad2-devel
 Requires:      lame-libs-devel
 Requires:      libdts-devel
 Requires:      libgsm-devel
 Requires:      libtheora-devel
 Requires:      libvorbis-devel
+Requires:      libx264-devel >= 0.1.2-1.20060828_2245.1
+#%{?with_lzo:Requires: lzo-devel < 2.0}
 Requires:      xvid-devel >= 1:1.1.0
 Requires:      zlib-devel
+Obsoletes:     libpostproc-devel
 
 %description devel
 ffmpeg header files.
@@ -163,9 +186,11 @@ obrazie.
 
 %package ffserver
 Summary:       FFserver video server
+Summary(pl):   FFserver - serwer strumieni obrazu
 Group:         Daemons
 Requires(post,preun):  /sbin/chkconfig
-Requires(post,preun):  rc-scripts >= 0.4.0.10
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      rc-scripts >= 0.4.0.10
 
 %description ffserver
 FFserver is a streaming server for both audio and video. It supports
@@ -173,11 +198,21 @@ several live feeds, streaming from files and time shifting on live
 feeds (you can seek to positions in the past on each live feed,
 provided you specify a big enough feed storage in ffserver.conf).
 
+%description ffserver -l pl
+FFserver to serwer strumieni dla d¼wiêku i obrazu. Obs³uguje kilka
+¼róde³ na ¿ywo, przekazywanie strumieni z plików i przesuwanie w
+czasie dla ¼róde³ na ¿ywo (mo¿na przeskakiwaæ na po³o¿enia w
+przesz³o¶ci dla ka¿dego ¼ród³a na ¿ywo, pod warunkiem odpowiednio
+du¿ej przestrzeni na dane skonfigurowanej w ffserver.conf).
+
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name}-export-%{_snap}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+#%patch3 -p1 NEEDS UPDATE
+%patch4 -p1
+#%patch5 -p1 MIGHT BE UNNECCESSARY
 
 %build
 # notes:
@@ -201,24 +236,31 @@ provided you specify a big enough feed storage in ffserver.conf).
        --enable-pp \
        --enable-pthreads \
        --enable-shared \
-       --enable-theora \
        --enable-vorbis \
+       --enable-x264 \
        --enable-xvid \
 %ifnarch %{ix86} %{x8664}
        --disable-mmx \
 %endif
 %ifarch i386 i486
        --disable-mmx \
+%endif
+%if %{with amr}
+       --enable-amr_nb \
+       --enable-amr_wb \
 %endif
        --cc="%{__cc}" \
        --extra-cflags="%{rpmcflags}" \
        --extra-ldflags="%{rpmldflags}" \
        --disable-debug \
        --disable-opts \
-       --tune=generic
 
-%{__make} \
-       BUILD_DOC=yes
+# GONE?
+#      %{!?with_lzo:--disable-lzo} \
+#      --enable-theora \
+#      --tune=generic
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -237,8 +279,8 @@ mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post libs     -p /sbin/ldconfig
+%postun libs   -p /sbin/ldconfig
 
 %pre ffserver
 %groupadd -g 167 ffserver
@@ -286,7 +328,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavformat.so
 %attr(755,root,root) %{_libdir}/libavutil.so
 %attr(755,root,root) %{_libdir}/libpostproc.so
-%{_libdir}/lib*.la
+#%{_libdir}/lib*.la
 %{_includedir}/ffmpeg
 %{_includedir}/postproc
 %{_pkgconfigdir}/*.pc
This page took 0.052994 seconds and 4 git commands to generate.