]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- added webp and opengl support
[packages/ffmpeg.git] / ffmpeg.spec
index aad39377ca05f1db9d3c35a6496198be855c6e1d..10bf8c71c9695df9b915da4ce6235c2bbd0822a5 100644 (file)
@@ -1,4 +1,3 @@
-# TODO: libzmq ?
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
@@ -9,40 +8,46 @@
 # Conditional build:
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
-%bcond_with    fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
+%bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
 %bcond_without caca            # textual display using libcaca
 %bcond_without flite           # flite voice synthesis support
 %bcond_without frei0r          # frei0r video filtering
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without ladspa          # LADSPA audio filtering
+%bcond_without ssh             # SFTP protocol support via libssh
 %bcond_without openal          # OpenAL 1.1 capture support
-%bcond_with    opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
+%bcond_with    opencl          # OpenCL code [OpenCL 1.2, not available in Mesa yet]
+%bcond_without opengl          # OpenGL rendering support
 %bcond_without opencv          # OpenCV video filtering
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
 %bcond_without soxr            # SoX Resampler support
-%bcond_without x264            # x264 encoder
+%bcond_without x264            # H.264 x264 encoder
+%bcond_with    x265            # HEVC x265 encoder
 %bcond_without utvideo         # Ut Video decoder
 %bcond_without va              # VAAPI (Video Acceleration API)
 %bcond_without vidstab         # vid.stab video stabilization support
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without wavpack         # wavpack encoding support
+%bcond_without webp            # WebP encoding support
 %bcond_without zmq             # 0MQ message passing
+%bcond_without zvbi            # teletext via libzvbi
 %bcond_without doc             # don't build docs
 
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.0
+Version:       2.2
 Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
-# (postprocessing, some filters, x264, xavs, xvid, x11grab)
+# (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 13a0feb74474f89052f6b8ba1bce46be
+# Source0-md5: 744febca199548c9393b1f1ed05ccdd8
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -50,6 +55,7 @@ Patch0:               %{name}-opencv24.patch
 URL:           http://www.ffmpeg.org/
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.2}
+%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
@@ -67,6 +73,7 @@ BuildRequires:        gcc >= 5:3.3.2-3
 %endif
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
+%{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
 BuildRequires: libass-devel
@@ -82,7 +89,7 @@ BuildRequires:        libnut-devel
 %{?with_quvi:BuildRequires:    libquvi-devel}
 BuildRequires: libraw1394-devel >= 2
 BuildRequires: librtmp-devel
-%{?with_shine:BuildRequires:   shine-devel}
+%{?with_ssh:BuildRequires:     libssh-devel}
 BuildRequires: libtheora-devel >= 1.0-0.beta3
 BuildRequires: libtool >= 2:1.4d-3
 BuildRequires: libv4l-devel
@@ -90,8 +97,11 @@ BuildRequires:       libv4l-devel
 BuildRequires: libvdpau-devel >= 0.2
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.7}
+%{?with_webp:BuildRequires:    libwebp-devel}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
+# X265_BUILD >= 7
+%{?with_x265:BuildRequires:    libx265-devel}
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
@@ -107,6 +117,7 @@ BuildRequires:      pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
+%{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
@@ -114,7 +125,7 @@ BuildRequires:      speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
 %{?with_utvideo:BuildRequires: utvideo-devel >= 12}
-%{?with_vidstab:BuildRequires: vid.stab-devel}
+%{?with_vidstab:BuildRequires: vid.stab-devel >= 0.98}
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
 %{?with_wavpack:BuildRequires: wavpack-devel}
@@ -126,6 +137,7 @@ BuildRequires:      xorg-lib-libXfixes-devel
 BuildRequires: xvid-devel >= 1:1.1.0
 BuildRequires: yasm
 %{?with_zmq:BuildRequires:     zeromq-devel}
+%{?with_zvbi:BuildRequires:    zvbi-devel}
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
 # overflows maximum hash table size
@@ -164,6 +176,10 @@ telewizyjnej.
 %package libs
 Summary:       ffmpeg libraries
 Summary(pl.UTF-8):     Biblioteki ffmpeg
+%if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
+# uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
+Requires:      gnutls-libs >= 3.0.20
+%endif
 Group:         Libraries
 
 %description libs
@@ -195,11 +211,11 @@ Requires: bzip2-devel
 Requires:      celt-devel >= 0.11.0
 %{?with_nonfree:Requires:      faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
+%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
-%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -224,12 +240,12 @@ Requires: opencore-amr-devel
 %{?with_opencv:Requires:       opencv-devel}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
-%{?with_shine:Requires:        shine-devel}
+%{?with_shine:Requires:        shine-devel >= 3.0.0}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
 %{?with_utvideo:Requires:      utvideo-devel >= 12}
-%{?with_vidstab:Requires:      vid.stab-devel}
+%{?with_vidstab:Requires:      vid.stab-devel >= 0.98}
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
 %{?with_wavpack:Requires:      wavpack-devel}
@@ -297,6 +313,20 @@ czasie dla źródeł na żywo (można przeskakiwać na położenia w
 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
 
+%package doc
+Summary:       FFmpeg documentation in HTML format
+Summary(pl.UTF-8):     Dokumentacja pakietu FFmpeg w formacie HTML
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description doc
+FFmpeg documentation in HTML format.
+
+%description doc -l pl.UTF-8
+Dokumentacja pakietu FFmpeg w formacie HTML.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -387,6 +417,7 @@ EOF
        --enable-version3 \
        --enable-fontconfig \
        %{?with_frei0r:--enable-frei0r} \
+       %{?with_ladspa:--enable-ladspa} \
        %{?with_aacplus:--enable-libaacplus} \
        --enable-libass \
        --enable-libbluray \
@@ -416,6 +447,7 @@ EOF
        %{?with_shine:--enable-libshine} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
+       %{?with_ssh:--enable-libssh} \
        --enable-libtheora \
        --enable-libtwolame \
        %{?with_utvideo:--enable-libutvideo} \
@@ -426,12 +458,15 @@ EOF
        --enable-libvorbis \
        %{?with_vpx:--enable-libvpx} \
        %{?with_wavpack:--enable-libwavpack} \
+       %{?with_webp:--enable-libwebp} \
        %{?with_x264:--enable-libx264} \
        --enable-libxavs \
        --enable-libxvid \
        %{?with_zmq:--enable-libzmq} \
+       %{?with_zvbi:--enable-libzvbi} \
        %{?with_openal:--enable-openal} \
        %{?with_opencl:--enable-opencl} \
+       %{?with_opengl:--enable-opengl} \
        --enable-postproc \
        --enable-pthreads \
        --enable-shared \
@@ -450,9 +485,6 @@ EOF
 %endif
        --enable-runtime-cpudetect
 
-# force oldscaler build
-%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
-
 %{__make} \
        V=1
 
@@ -517,7 +549,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
+%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
 %attr(755,root,root) %{_bindir}/ffmpeg
 %attr(755,root,root) %{_bindir}/ffprobe
 %attr(755,root,root) %{_bindir}/qt-faststart
@@ -547,7 +579,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
+%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.4
 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
@@ -635,3 +667,9 @@ fi
 %endif
 %dir %attr(770,root,ffserver) /var/cache/ffserver
 %dir %attr(770,root,ffserver) /var/log/ffserver
+
+%if %{with doc}
+%files doc
+%defattr(644,root,root,755)
+%doc doc/*.html
+%endif
This page took 0.238417 seconds and 4 git commands to generate.