]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- release 3 (by relup.sh)
[packages/ffmpeg.git] / ffmpeg.spec
index 2dec301eef5c03fe24bfc303898baf8bf854d048..01a3d1717c91df28aee487fb10d946dd312d54d8 100644 (file)
@@ -1,22 +1,26 @@
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
-#      1. make-request -r --without opencv ffmpeg.spec
+#      1. make-request -r --with bootstrap ffmpeg.spec
 #      2. make-request -r opencv.spec
 #      3. bump release of ffmpeg.spec
 #      4. make-request -r ffmpeg.spec
 #
 # Conditional build:
-%bcond_with    nonfree         # non free options of package (currently: faac)
+%bcond_with    bootstrap       # disable features to able to build without installed ffmpeg
+%bcond_with    nonfree         # non free options of package (currently: aacplus, faac, fdk_aac, nvenc)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
+%bcond_with    faac            # faac (requires nonfree)
 %bcond_without bs2b            # BS2B audio filter support
 %bcond_without caca            # textual display using libcaca
+%bcond_without dcadec          # DCA decoding via libdcadec
 %bcond_without decklink        # Blackmagic DeskLink output support
 %bcond_without flite           # flite voice synthesis support
 %bcond_without frei0r          # frei0r video filtering
 %bcond_without fribidi         # fribidi support
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without kvazaar         # Kvazaar HEVC encoder support
 %bcond_without ladspa          # LADSPA audio filtering
 %bcond_with    mfx             # MFX hardware acceleration support
 %bcond_with    nvenc           # NVIDIA NVENC support (requires nonfree)
@@ -28,6 +32,7 @@
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
+%bcond_without snappy          # Snappy compression support (needed for hap encoding)
 %bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
 %bcond_without doc             # don't build docs
 %bcond_with    tests           # "make check" (some tests fail as of 2.5)
 
+%if %{with bootstrap}
+%undefine      with_opencv
+%endif
+
 %ifnarch %{ix86} %{x8664} arm
 %undefine      with_x265
 %endif
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.7
-Release:       1
+Version:       2.8.3
+Release:       3
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
-Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 5a16425b0bde1b952f58cff71b569a45
+Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
+# Source0-md5: 2af2723dd53364ac0635efd20cf6e34e
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
+Patch0:                %{name}-kvazaar.patch
+Patch1:                libvpx-1.5.patch
+Patch2:                %{name}-utvideo.patch
 URL:           http://www.ffmpeg.org/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
@@ -74,7 +86,8 @@ BuildRequires:        SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
-%{?with_nonfree:BuildRequires: faac-devel}
+%{?with_dcadec:BuildRequires:  dcadec-devel}
+%{?with_faac:BuildRequires:    faac-devel}
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 %{?with_flite:BuildRequires:   flite-devel >= 1.4}
 BuildRequires: fontconfig-devel
@@ -86,8 +99,10 @@ BuildRequires:       freetype-devel
 # require version with altivec support fixed
 BuildRequires: gcc >= 5:3.3.2-3
 %endif
+BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
+%{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.7}
 %{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
@@ -114,10 +129,10 @@ BuildRequires:    libv4l-devel
 BuildRequires: libvdpau-devel >= 0.2
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 1.3.0}
-%{?with_webp:BuildRequires:    libwebp-devel >= 0.2.0}
+%{?with_webp:BuildRequires:    libwebp-devel >= 0.4.0}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
-# X265_BUILD >= 17
+# X265_BUILD >= 57
 %{?with_x265:BuildRequires:    libx265-devel >= 1.3-0.20150610.1}
 # libxcb xcb-shm xcb-xfixes xcb-shape
 BuildRequires: libxcb-devel >= 1.4
@@ -141,13 +156,14 @@ BuildRequires:    pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
 %{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
+%{?with_snappy:BuildRequires:  snappy-devel}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
 %{?with_doc:BuildRequires:     texi2html}
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
-%{?with_utvideo:BuildRequires: utvideo-devel >= 12}
+%{?with_utvideo:BuildRequires: utvideo-devel >= 15.3}
 %{?with_vidstab:BuildRequires: vid.stab-devel >= 0.98}
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
@@ -166,7 +182,7 @@ BuildRequires:      zlib-devel
 # overflows maximum hash table size
 BuildConflicts:        pdksh < 5.2.14-57
 Requires:      %{name}-libs = %{version}-%{release}
-%{?with_utvideo:Requires:      utvideo >= 12}
+%{?with_utvideo:Requires:      utvideo >= 15.3}
 %{?with_ilbc:Requires: webrtc-libilbc}
 Requires:      xvid >= 1:1.1.0
 Obsoletes:     libpostproc
@@ -234,7 +250,8 @@ Requires:   SDL-devel >= 1.2.1
 Requires:      alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
-%{?with_nonfree:Requires:      faac-devel}
+%{?with_dcadec:Requires:       dcadec-devel}
+%{?with_faac:Requires: faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
 %{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      fontconfig-devel
@@ -242,6 +259,7 @@ Requires:   freetype-devel
 %{?with_fribidi:Requires:      fribidi-devel}
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
+%{?with_kvazaar:Requires:      kvazaar-devel >= 0.7}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -263,7 +281,7 @@ Requires:   libtheora-devel >= 1.0-0.beta3
 %{?with_va:Requires:   libva-devel >= 1.0.3}
 Requires:      libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 1.3.0}
-%{?with_webp:Requires: libwebp-devel >= 0.2.0}
+%{?with_webp:Requires: libwebp-devel >= 0.4.0}
 %{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
 %{?with_x265:Requires: libx265-devel >= 1.3-0.20150610.1}
 %{?with_mfx:Requires:  mfx_dispatch-devel}
@@ -273,10 +291,11 @@ Requires: opencore-amr-devel
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
+%{?with_snappy:Requires:       snappy-devel}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
-%{?with_utvideo:Requires:      utvideo-devel >= 12}
+%{?with_utvideo:Requires:      utvideo-devel >= 15.3}
 %{?with_vidstab:Requires:      vid.stab-devel >= 0.98}
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
@@ -361,6 +380,9 @@ Dokumentacja pakietu FFmpeg w formacie HTML.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
@@ -441,6 +463,7 @@ EOF
        --disable-debug \
        --disable-optimizations \
        --disable-stripping \
+       %{!?with_doc:--disable-doc} \
        --enable-avfilter \
        --enable-avresample \
        %{?with_decklink:--enable-decklink} \
@@ -450,7 +473,6 @@ EOF
        --enable-fontconfig \
        %{?with_frei0r:--enable-frei0r} \
        %{?with_ladspa:--enable-ladspa} \
-       %{?with_aacplus:--enable-libaacplus} \
        --enable-libass \
        --enable-libbluray \
        %{?with_bs2b:--enable-libbs2b} \
@@ -458,7 +480,7 @@ EOF
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
-       %{?with_fdk_aac:--enable-libfdk-aac} \
+       %{?with_dcadec:--enable-libdcadec} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
        %{?with_fribidi:--enable-libfribidi} \
@@ -466,6 +488,7 @@ EOF
        --enable-libgsm \
        --enable-libiec61883 \
        %{?with_ilbc:--enable-libilbc} \
+       %{?with_kvazaar:--enable-libkvazaar} \
        %{?with_mfx:--enable-libmfx} \
        --enable-libmodplug \
        --enable-libmp3lame \
@@ -482,6 +505,7 @@ EOF
        --enable-libschroedinger \
        %{?with_shine:--enable-libshine} \
        %{?with_smb:--enable-libsmbclient} \
+       %{?with_snappy:--enable-libsnappy} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        %{?with_ssh:--enable-libssh} \
@@ -502,7 +526,6 @@ EOF
        --enable-libxvid \
        %{?with_zmq:--enable-libzmq} \
        %{?with_zvbi:--enable-libzvbi} \
-       %{?with_nvenc:--enable-nvenc} \
        %{?with_openal:--enable-openal} \
        %{?with_opencl:--enable-opencl} \
        %{?with_opengl:--enable-opengl} \
@@ -523,7 +546,10 @@ EOF
 %endif
 %if %{with nonfree}
        --enable-nonfree \
-       --enable-libfaac \
+       %{?with_aacplus:--enable-libaacplus} \
+       %{?with_faac:--enable-libfaac} \
+       %{?with_fdk_aac:--enable-libfdk-aac} \
+       %{?with_nvenc:--enable-nvenc} \
 %endif
        --enable-runtime-cpudetect
 
@@ -566,7 +592,9 @@ install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
 
 # packaged as %doc in -doc
+%if %{with doc}
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
+%endif
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.065303 seconds and 4 git commands to generate.