]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
f2b54b41fe7f1abece92f50706b1b6c2f131dc1c
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO:
2 # - libvmaf [BR: libvmaf.pc, libvmaf, libvmaf.h]
3 # - libndi_newtek[nonfree, BR: Processing.NDI.Lib.h]
4 # - libmysofa [BR: libmysofa, mysofa.h]
5 # - rkmpp[GPLv3, BR: rockchip_mpp.pc, rockchip/rk_mpi_cmd.h, libdrm]
6 #
7 # How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
8 #       1. make-request -r --with bootstrap ffmpeg.spec
9 #       2  bump release of opencv.spec and chromaprint.spec
10 #       3. make-request -r opencv.spec chromaprint.spec
11 #       4. bump release of ffmpeg.spec
12 #       5. make-request -r ffmpeg.spec
13 #
14 # Conditional build:
15 %bcond_with     bootstrap       # disable features to able to build without installed ffmpeg
16 %bcond_with     nonfree         # unblock non free options of package (currently: cuda_sdk, decklib, fdk_aac, libndi_newtek, npp, openssl)
17 %bcond_without  bs2b            # BS2B audio filter support
18 %bcond_without  caca            # textual display using libcaca
19 %bcond_without  chromaprint     # audio fingerprinting with chromaprint
20 %bcond_without  cuda            # NVIDIA CUDA code
21 %bcond_with     cudasdk         # NVIDIA CUDA code using SDK [BR: cuda.h, non-free]
22 %bcond_with     cuvid           # NVIDIA CUVID support
23 %bcond_with     decklink        # Blackmagic DeskLink output support (requires nonfree)
24 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
25 %bcond_without  flite           # flite voice synthesis support
26 %bcond_without  frei0r          # frei0r video filtering
27 %bcond_without  fribidi         # fribidi support
28 %bcond_without  gme             # Game Music Emu support
29 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
30 %bcond_without  kvazaar         # Kvazaar HEVC encoder support
31 %bcond_without  ladspa          # LADSPA audio filtering
32 %bcond_with     libdrm          # Linux Direct Rendering Manager code
33 %bcond_with     librsvg         # SVG rasterization via librsvg
34 %bcond_with     libxml2         # XML parsing using libxml2
35 %bcond_with     mfx             # MFX hardware acceleration support
36 %bcond_with     npp             # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
37 %bcond_with     nvenc           # NVIDIA NVENC support
38 %bcond_without  omx             # OpenMAX IL support
39 %bcond_without  openal          # OpenAL 1.1 capture support
40 %bcond_without  opencl          # OpenCL 1.2 code
41 %bcond_without  opencv          # OpenCV video filtering
42 %bcond_without  opengl          # OpenGL rendering support
43 %bcond_with     openh264        # OpenH264 H.264 encoder
44 %bcond_without  openmpt         # OpenMPT module decoder
45 %bcond_without  pulseaudio      # PulseAudio input support
46 %bcond_without  rubberband      # rubberband filter
47 %bcond_without  shine           # shine fixed-point MP3 encoder
48 %bcond_without  snappy          # Snappy compression support (needed for hap encoding)
49 %bcond_without  ssh             # SFTP protocol support via libssh
50 %bcond_with     smb             # SMB support via libsmbclient
51 %bcond_without  soxr            # SoX Resampler support
52 %bcond_with     tesseract       # OCR filter based on Tesseract
53 %bcond_without  x264            # H.264 x264 encoder
54 %bcond_without  x265            # H.265/HEVC x265 encoder
55 %bcond_without  va              # VAAPI (Video Acceleration API)
56 %bcond_without  vidstab         # vid.stab video stabilization support
57 %bcond_without  vpx             # VP8, a high-quality video codec
58 %bcond_without  wavpack         # wavpack encoding support
59 %bcond_without  webp            # WebP encoding support
60 %bcond_without  zimg            # zscale filter based on z.lib
61 %bcond_without  zmq             # 0MQ message passing
62 %bcond_without  zvbi            # teletext via libzvbi
63 %bcond_without  doc             # don't build docs
64 %bcond_with     tests           # "make check" (some tests fail as of 2.5)
65
66 %if %{with bootstrap}
67 %undefine       with_opencv
68 %undefine       with_chromaprint
69 %endif
70
71 %ifnarch %{ix86} %{x8664} %{arm}
72 %undefine       with_x265
73 %endif
74 %ifarch i386 i486
75 %undefine       with_x265
76 %endif
77 Summary:        FFmpeg - a very fast video and audio converter
78 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
79 Name:           ffmpeg
80 Version:        4.0
81 Release:        2
82 # LGPL or GPL, chosen at configure time (GPL version is more featured)
83 # (postprocessing, some filters, x264, x265, xavs, xvid, xcbgrab)
84 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
85 License:        GPL v3+ with LGPL v3+ parts
86 Group:          Applications/Multimedia
87 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
88 # Source0-md5:  1cc9e8cb027b9fd4c54f598f51002c19
89 Patch0:         %{name}-omx-libnames.patch
90 URL:            http://www.ffmpeg.org/
91 %{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.6.1}
92 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
93 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
94 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
95 # libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
96 %{?with_omx:BuildRequires:      OpenMAX-IL-devel}
97 BuildRequires:  SDL2-devel >= 2.0.1
98 BuildRequires:  SDL2-devel < 2.1.0
99 BuildRequires:  alsa-lib-devel
100 BuildRequires:  bzip2-devel
101 BuildRequires:  celt-devel >= 0.11.0
102 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
103 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
104 BuildRequires:  fontconfig-devel
105 BuildRequires:  freetype-devel
106 %{?with_frei0r:BuildRequires:   frei0r-devel}
107 %{?with_fribidi:BuildRequires:  fribidi-devel}
108 %{?with_gme:BuildRequires:      game-music-emu-devel}
109 %ifarch ppc
110 # require version with altivec support fixed
111 BuildRequires:  gcc >= 5:3.3.2-3
112 %endif
113 BuildRequires:  gmp-devel
114 BuildRequires:  gnutls-devel
115 BuildRequires:  jack-audio-connection-kit-devel
116 %{?with_kvazaar:BuildRequires:  kvazaar-devel >= 0.8.1}
117 %{?with_ladspa:BuildRequires:   ladspa-devel}
118 BuildRequires:  lame-libs-devel >= 3.98.3
119 BuildRequires:  libass-devel
120 BuildRequires:  libavc1394-devel
121 %{?with_bs2b:BuildRequires:     libbs2b-devel}
122 BuildRequires:  libbluray-devel
123 %{?with_caca:BuildRequires:     libcaca-devel}
124 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
125 %{?with_chromaprint:BuildRequires:      libchromaprint-devel}
126 BuildRequires:  libdc1394-devel >= 2
127 %{?with_libdrm:BuildRequires:   libdrm-devel}
128 BuildRequires:  libgsm-devel
129 BuildRequires:  libiec61883-devel
130 BuildRequires:  libmodplug-devel
131 %{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.2.6557}
132 BuildRequires:  libraw1394-devel >= 2
133 %{?with_librsvg:BuildRequires:  librsvg-devel >= 2}
134 BuildRequires:  librtmp-devel
135 %{?with_ssh:BuildRequires:      libssh-devel}
136 %{?with_smb:BuildRequires:      libsmbclient-devel}
137 BuildRequires:  libtheora-devel >= 1.0-0.beta3
138 BuildRequires:  libtool >= 2:1.4d-3
139 BuildRequires:  libv4l-devel
140 %if %{with va}
141 BuildRequires:  libva-devel >= 1.0.3
142 BuildRequires:  libva-drm-devel >= 1.0.3
143 BuildRequires:  libva-x11-devel >= 1.0.3
144 %endif
145 BuildRequires:  libvdpau-devel >= 0.2
146 BuildRequires:  libvorbis-devel
147 %{?with_vpx:BuildRequires:      libvpx-devel >= 1.3.0}
148 %{?with_webp:BuildRequires:     libwebp-devel >= 0.4.0}
149 # X264_BUILD >= 118
150 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
151 # X265_BUILD >= 68
152 %{?with_x265:BuildRequires:     libx265-devel >= 1.8}
153 # libxcb xcb-shm xcb-xfixes xcb-shape
154 BuildRequires:  libxcb-devel >= 1.4
155 %{?with_libxml2:BuildRequires:  libxml2-devel >= 2}
156 %{?with_mfx:BuildRequires:      mfx_dispatch-devel}
157 %ifarch %{ix86}
158 %ifnarch i386 i486
159 BuildRequires:  nasm
160 %endif
161 %endif
162 # which package?
163 #%{?with_nvenc:BuildRequires:   NVIDIA-NVENC-API} compat/nvenc/nvEncodeAPI.h
164 BuildRequires:  opencore-amr-devel
165 %{?with_opencv:BuildRequires:   opencv-devel}
166 %{?with_openh264:BuildRequires: openh264-devel >= 1.3}
167 BuildRequires:  openjpeg2-devel >= 2.1
168 BuildRequires:  opus-devel
169 BuildRequires:  perl-Encode
170 BuildRequires:  perl-tools-pod
171 BuildRequires:  pkgconfig
172 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
173 BuildRequires:  rpmbuild(macros) >= 1.470
174 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.8.1}
175 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
176 %{?with_snappy:BuildRequires:   snappy-devel}
177 %{?with_soxr:BuildRequires:     soxr-devel}
178 BuildRequires:  speex-devel >= 1:1.2-rc1
179 %{?with_tesseract:BuildRequires:        tesseract-devel}
180 %{?with_doc:BuildRequires:      tetex}
181 %{?with_doc:BuildRequires:      texi2html}
182 %{?with_doc:BuildRequires:      texinfo}
183 BuildRequires:  twolame-devel
184 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
185 BuildRequires:  vo-amrwbenc-devel
186 %{?with_wavpack:BuildRequires:  wavpack-devel}
187 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
188 BuildRequires:  xavs-devel
189 BuildRequires:  xorg-lib-libX11-devel
190 BuildRequires:  xorg-lib-libXext-devel
191 BuildRequires:  xorg-lib-libXfixes-devel
192 BuildRequires:  xvid-devel >= 1:1.1.0
193 BuildRequires:  xz-devel
194 BuildRequires:  yasm
195 %{?with_zmq:BuildRequires:      zeromq-devel}
196 %{?with_zimg:BuildRequires:     zimg-devel >= 2.7.0}
197 BuildRequires:  zlib-devel
198 %{?with_zvbi:BuildRequires:     zvbi-devel}
199 %{?with_autoreqdep:BuildConflicts:      libpostproc}
200 # overflows maximum hash table size
201 BuildConflicts: pdksh < 5.2.14-57
202 Requires:       %{name}-libs = %{version}-%{release}
203 %{?with_ilbc:Requires:  webrtc-libilbc}
204 Requires:       xvid >= 1:1.1.0
205 Obsoletes:      libpostproc
206 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
207
208 %define         specflags       -fno-strict-aliasing
209
210 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
211 %define         specflags_ia32  -fomit-frame-pointer
212 # -mmmx is needed to enable <mmintrin.h> code.
213 %define         specflags_i586  -mmmx
214 %define         specflags_i686  -mmmx
215 %define         specflags_ppc   -fPIC
216
217 %description
218 FFmpeg is a complete solution to record, convert and stream audio and
219 video. It is a command line tool to convert one video file format to
220 another. It also supports grabbing and encoding in real time from a TV
221 card.
222
223 %description -l pl.UTF-8
224 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
225 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
226 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
227 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
228 telewizyjnej.
229
230 %package libs
231 Summary:        ffmpeg libraries
232 Summary(pl.UTF-8):      Biblioteki ffmpeg
233 Group:          Libraries
234 Requires:       SDL2 >= 2.0.1
235 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
236 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
237 Requires:       gnutls-libs >= 3.0.20
238 %endif
239 %{?with_openmpt:Requires: libopenmpt >= 0.2.6557}
240 %{?with_vpx:Requires:   libvpx >= 1.3.0}
241 %{?with_rubberband:Requires:    rubberband-libs >= 1.8.1}
242 %{?with_zimg:Requires:  zimg >= 2.7.0}
243
244 %description libs
245 This package contains the ffmpeg shared libraries:
246 - the codec library (libavcodec). It supports most existing encoding
247   formats (MPEG, DivX, MPEG4, AC3, DV...),
248 - demuxer library (libavformat). It supports most existing file
249   formats (AVI, MPEG, OGG, Matroska, ASF...),
250 - video postprocessing library (libpostproc).
251
252 %description libs -l pl.UTF-8
253 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
254 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
255   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
256 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
257   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
258 - bibliotekę postprocessingu (libpostproc).
259
260 %package devel
261 Summary:        ffmpeg header files
262 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
263 Group:          Development/Libraries
264 Requires:       %{name}-libs = %{version}-%{release}
265 # Libs.private from *.pc (unreasonably they are all the same)
266 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
267 %{?with_opengl:Requires:        OpenGL-devel}
268 Requires:       SDL2-devel >= 2.0.1
269 Requires:       alsa-lib-devel
270 Requires:       bzip2-devel
271 Requires:       celt-devel >= 0.11.0
272 %{?with_fdk_aac:Requires:       fdk-aac-devel}
273 %{?with_flite:Requires: flite-devel >= 1.4}
274 Requires:       fontconfig-devel
275 Requires:       freetype-devel
276 %{?with_fribidi:Requires:       fribidi-devel}
277 %{?with_gme:Requires:   game-music-emu-devel}
278 Requires:       jack-audio-connection-kit-devel
279 %{?with_kvazaar:Requires:       kvazaar-devel >= 0.8.1}
280 Requires:       lame-libs-devel >= 3.98.3
281 Requires:       libass-devel
282 Requires:       libavc1394-devel
283 Requires:       libbluray-devel
284 %{?with_bs2b:Requires:  libbs2b-devel}
285 %{?with_caca:Requires:  libcaca-devel}
286 Requires:       libcdio-paranoia-devel >= 0.90-2
287 %{?with_chromaprint:Requires:   libchromaprint-devel}
288 Requires:       libdc1394-devel >= 2
289 %{?with_libdrm:Requires:        libdrm-devel}
290 Requires:       libgsm-devel
291 Requires:       libiec61883-devel
292 Requires:       libmodplug-devel
293 %{?with_openmpt:Requires: libopenmpt-devel >= 0.2.6557}
294 Requires:       libraw1394-devel >= 2
295 %{?with_librsvg:Requires:       librsvg-devel >= 2}
296 Requires:       librtmp-devel
297 %{?with_smb:Requires:   libsmbclient-devel}
298 Requires:       libtheora-devel >= 1.0-0.beta3
299 %{?with_va:Requires:    libva-devel >= 1.0.3}
300 Requires:       libvorbis-devel
301 %{?with_vpx:Requires:   libvpx-devel >= 1.3.0}
302 %{?with_webp:Requires:  libwebp-devel >= 0.4.0}
303 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
304 %{?with_x265:Requires:  libx265-devel >= 1.8}
305 %{?with_libxml2:Requires:       libxml2-devel >= 2}
306 %{?with_mfx:Requires:   mfx_dispatch-devel}
307 Requires:       opencore-amr-devel
308 %{?with_opencv:Requires:        opencv-devel}
309 %{?with_openh264:Requires:      openh264-devel >= 1.3}
310 Requires:       openjpeg2-devel >= 2.1
311 %{?with_rubberband:Requires:    rubberband-devel >= 1.8.1}
312 %{?with_shine:Requires: shine-devel >= 3.0.0}
313 %{?with_snappy:Requires:        snappy-devel}
314 %{?with_soxr:Requires:  soxr-devel}
315 Requires:       speex-devel >= 1:1.2-rc1
316 %{?with_tesseract:Requires:     tesseract-devel}
317 Requires:       twolame-devel
318 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
319 Requires:       vo-amrwbenc-devel
320 %{?with_wavpack:Requires:       wavpack-devel}
321 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
322 Requires:       xavs-devel
323 Requires:       xorg-lib-libXext-devel
324 Requires:       xorg-lib-libXfixes-devel
325 Requires:       xvid-devel >= 1:1.1.0
326 %{?with_zmq:Requires:   zeromq-devel}
327 %{?with_zimg:Requires:  zimg-devel >= 2.3.0}
328 Requires:       zlib-devel
329 Obsoletes:      libpostproc-devel
330
331 %description devel
332 ffmpeg header files.
333
334 %description devel -l pl.UTF-8
335 Pliki nagłówkowe ffmpeg.
336
337 %package static
338 Summary:        ffmpeg static libraries
339 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
340 Group:          Development/Libraries
341 Requires:       %{name}-devel = %{version}-%{release}
342
343 %description static
344 ffmpeg static libraries (libavcodec and libavformat).
345
346 %description static -l pl.UTF-8
347 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
348
349 %package ffplay
350 Summary:        FFplay - SDL-based media player
351 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
352 Group:          Applications/Multimedia
353 Requires:       %{name}-libs = %{version}-%{release}
354
355 %description ffplay
356 FFplay is a very simple and portable media player using the FFmpeg
357 libraries and the SDL library. It is mostly used as a test bench for
358 the various APIs of FFmpeg.
359
360 %description ffplay -l pl.UTF-8
361 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
362 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
363 testowania różnych API FFmpeg.
364
365 %package doc
366 Summary:        FFmpeg documentation in HTML format
367 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
368 Group:          Documentation
369 %if "%{_rpmversion}" >= "5"
370 BuildArch:      noarch
371 %endif
372
373 %description doc
374 FFmpeg documentation in HTML format.
375
376 %description doc -l pl.UTF-8
377 Dokumentacja pakietu FFmpeg w formacie HTML.
378
379 %prep
380 %setup -q
381 %patch0 -p1
382
383 # package the grep result for mplayer, the result formatted as ./mplayer/configure
384 cat <<EOF > ffmpeg-avconfig
385 #! /bin/sh
386 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
387 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
388 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
389 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
390 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
391 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
392 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
393 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
394 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
395 EOF
396 cat <<'EOF' >> ffmpeg-avconfig
397
398 case "$1" in
399 --decoders)
400         echo $libavdecoders_all
401         ;;
402 --encoders)
403         echo $libavencoders_all
404         ;;
405 --parsers)
406         echo $libavparsers_all
407         ;;
408 --bsfs)
409         echo $libavbsfs_all
410         ;;
411 --demuxers)
412         echo $libavdemuxers_all
413         ;;
414 --muxers)
415         echo $libavmuxers_all
416         ;;
417 --protocols)
418         echo $libavprotocols_all
419         ;;
420 --hwaccels)
421         echo $libavhwaccels_all
422         ;;
423 --filters)
424         echo $libavfilters_all
425         ;;
426 *)
427         cat <<USAGE
428 Usage: $0 [OPTION]
429 Options:
430   --decoders
431   --encoders
432   --parsers
433   --bsfs
434   --demuxers
435   --muxers
436   --protocols
437   --hwaccels
438   --filters
439 USAGE
440         exit 1;;
441 esac
442
443 exit 0
444 EOF
445
446 %build
447 # notes:
448 # - it's not autoconf configure
449 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
450 ./configure \
451         --arch=%{_target_base_arch} \
452         --prefix=%{_prefix} \
453         --libdir=%{_libdir} \
454         --shlibdir=%{_libdir} \
455         --mandir=%{_mandir} \
456         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
457         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
458         --cc="%{__cc}" \
459         --disable-debug \
460         --disable-optimizations \
461         --disable-stripping \
462         %{!?with_doc:--disable-doc} \
463         --enable-avfilter \
464         --enable-avresample \
465         %{?with_chromaprint:--enable-chromaprint} \
466         %{!?with_cuda:--disable-cuda} \
467         %{?with_cudasdk:--enable-cuda-sdk} \
468         %{!?with_cuvid:--disable-cuvid} \
469         %{?with_decklink:--enable-decklink} \
470         --enable-gnutls \
471         --enable-gpl \
472         --enable-version3 \
473         %{?with_frei0r:--enable-frei0r} \
474         %{?with_ladspa:--enable-ladspa} \
475         --enable-libass \
476         --enable-libbluray \
477         %{?with_bs2b:--enable-libbs2b} \
478         %{?with_caca:--enable-libcaca} \
479         --enable-libcelt \
480         --enable-libcdio \
481         --enable-libdc1394 \
482         %{?with_libdrm:--enable-libdrm} \
483         %{?with_flite:--enable-libflite} \
484         --enable-libfontconfig \
485         --enable-libfreetype \
486         %{?with_fribidi:--enable-libfribidi} \
487         %{?with_gme:--enable-libgme} \
488         --enable-libgsm \
489         --enable-libiec61883 \
490         %{?with_ilbc:--enable-libilbc} \
491         %{?with_kvazaar:--enable-libkvazaar} \
492         %{?with_mfx:--enable-libmfx} \
493         --enable-libmodplug \
494         --enable-libmp3lame \
495         --enable-libopencore-amrnb \
496         --enable-libopencore-amrwb \
497         %{?with_opencv:--enable-libopencv} \
498         %{?with_openh264:--enable-libopenh264} \
499         --enable-libopenjpeg \
500         %{?with_openmpt:--enable-libopenmpt} \
501         --enable-libopus \
502         %{?with_pulseaudio:--enable-libpulse} \
503         %{?with_librsvg:--enable-librsvg} \
504         --enable-librtmp \
505         %{?with_libxml2:--enable-libxml2} \
506         %{?with_rubberband:--enable-librubberband} \
507         %{?with_shine:--enable-libshine} \
508         %{?with_smb:--enable-libsmbclient} \
509         %{?with_snappy:--enable-libsnappy} \
510         %{?with_soxr:--enable-libsoxr} \
511         --enable-libspeex \
512         %{?with_ssh:--enable-libssh} \
513         %{?with_tesseract:--enable-libtesseract} \
514         --enable-libtheora \
515         --enable-libtwolame \
516         --enable-libv4l2 \
517         %{?with_vidstab:--enable-libvidstab} \
518         --enable-libvo-amrwbenc \
519         --enable-libvorbis \
520         %{?with_vpx:--enable-libvpx} \
521         %{?with_wavpack:--enable-libwavpack} \
522         %{?with_webp:--enable-libwebp} \
523         %{?with_x264:--enable-libx264} \
524         %{?with_x265:--enable-libx265} \
525         --enable-libxavs \
526         --enable-libxcb \
527         --enable-libxvid \
528         %{?with_zimg:--enable-libzimg} \
529         %{?with_zmq:--enable-libzmq} \
530         %{?with_zvbi:--enable-libzvbi} \
531         %{!?with_nvenc:--disable-nvenc} \
532         %{?with_omx:--enable-omx} \
533         %{?with_openal:--enable-openal} \
534         %{?with_opencl:--enable-opencl} \
535         %{?with_opengl:--enable-opengl} \
536         --enable-postproc \
537         --enable-pthreads \
538         --enable-shared \
539         --enable-swscale \
540         %{!?with_va:--disable-vaapi} \
541 %ifnarch %{ix86} %{x8664}
542         --disable-mmx \
543 %endif
544 %ifarch i386 i486
545         --disable-mmx \
546 %endif
547 %ifarch x32
548         --disable-asm \
549 %endif
550 %if %{with nonfree}
551         --enable-nonfree \
552         %{?with_fdk_aac:--enable-libfdk-aac} \
553         %{?with_npp:--enable-libnpp} \
554 %endif
555         --enable-runtime-cpudetect
556
557 %{__make} \
558         V=1
559
560 # CC_O to add -c to commandline. makefile should be patched
561 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
562
563 %{?with_tests:%{__make} check V=1}
564
565 %install
566 rm -rf $RPM_BUILD_ROOT
567 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
568         $RPM_BUILD_ROOT%{_includedir}/ffmpeg
569
570 %{__make} install install-headers \
571         DESTDIR=$RPM_BUILD_ROOT \
572         V=1
573
574 # install nonstandard, non-public headers manually
575 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
576 for a in libavutil/*/{asm,bswap}.h; do
577         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
578 done
579 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
580
581 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
582
583 # install as ffmpeg-avconfig to avoid with possible programs looking for
584 # ffmpeg-config and expecting --libs output from it which is not implemented
585 # simple to do (by querying pkgconfig), but why?
586 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
587
588 # packaged as %doc in -doc
589 %if %{with doc}
590 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
591 %endif
592
593 install -d $RPM_BUILD_ROOT%{_examplesdir}
594 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
595
596 %clean
597 rm -rf $RPM_BUILD_ROOT
598
599 %post   libs -p /sbin/ldconfig
600 %postun libs -p /sbin/ldconfig
601
602 %files
603 %defattr(644,root,root,755)
604 %doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
605 %attr(755,root,root) %{_bindir}/ffmpeg
606 %attr(755,root,root) %{_bindir}/ffprobe
607 %attr(755,root,root) %{_bindir}/qt-faststart
608 %dir %{_datadir}/ffmpeg
609 %{_datadir}/ffmpeg/*.ffpreset
610 %{_datadir}/ffmpeg/ffprobe.xsd
611 %if %{with doc}
612 %{_mandir}/man1/ffmpeg.1*
613 %{_mandir}/man1/ffmpeg-all.1*
614 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
615 %{_mandir}/man1/ffmpeg-codecs.1*
616 %{_mandir}/man1/ffmpeg-devices.1*
617 %{_mandir}/man1/ffmpeg-filters.1*
618 %{_mandir}/man1/ffmpeg-formats.1*
619 %{_mandir}/man1/ffmpeg-protocols.1*
620 %{_mandir}/man1/ffmpeg-resampler.1*
621 %{_mandir}/man1/ffmpeg-scaler.1*
622 %{_mandir}/man1/ffmpeg-utils.1*
623 %{_mandir}/man1/ffprobe.1*
624 %{_mandir}/man1/ffprobe-all.1*
625 %endif
626
627 %files libs
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
631 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
633 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
635 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
637 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
639 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
641 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
643 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
645 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
647
648 %files devel
649 %defattr(644,root,root,755)
650 %doc doc/optimization.txt
651 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
652 %attr(755,root,root) %{_libdir}/libavcodec.so
653 %attr(755,root,root) %{_libdir}/libavdevice.so
654 %attr(755,root,root) %{_libdir}/libavfilter.so
655 %attr(755,root,root) %{_libdir}/libavformat.so
656 %attr(755,root,root) %{_libdir}/libavresample.so
657 %attr(755,root,root) %{_libdir}/libavutil.so
658 %attr(755,root,root) %{_libdir}/libpostproc.so
659 %attr(755,root,root) %{_libdir}/libswresample.so
660 %attr(755,root,root) %{_libdir}/libswscale.so
661 %{_includedir}/ffmpeg
662 %{_includedir}/libavcodec
663 %{_includedir}/libavdevice
664 %{_includedir}/libavfilter
665 %{_includedir}/libavformat
666 %{_includedir}/libavresample
667 %{_includedir}/libavutil
668 %{_includedir}/libpostproc
669 %{_includedir}/libswresample
670 %{_includedir}/libswscale
671 %{_pkgconfigdir}/libavcodec.pc
672 %{_pkgconfigdir}/libavdevice.pc
673 %{_pkgconfigdir}/libavfilter.pc
674 %{_pkgconfigdir}/libavformat.pc
675 %{_pkgconfigdir}/libavresample.pc
676 %{_pkgconfigdir}/libavutil.pc
677 %{_pkgconfigdir}/libpostproc.pc
678 %{_pkgconfigdir}/libswresample.pc
679 %{_pkgconfigdir}/libswscale.pc
680 %if %{with doc}
681 %{_mandir}/man3/libavcodec.3*
682 %{_mandir}/man3/libavdevice.3*
683 %{_mandir}/man3/libavfilter.3*
684 %{_mandir}/man3/libavformat.3*
685 %{_mandir}/man3/libavutil.3*
686 %{_mandir}/man3/libswresample.3*
687 %{_mandir}/man3/libswscale.3*
688 %endif
689 %{_examplesdir}/%{name}-%{version}
690
691 %files static
692 %defattr(644,root,root,755)
693 %{_libdir}/libavcodec.a
694 %{_libdir}/libavdevice.a
695 %{_libdir}/libavfilter.a
696 %{_libdir}/libavformat.a
697 %{_libdir}/libavresample.a
698 %{_libdir}/libavutil.a
699 %{_libdir}/libpostproc.a
700 %{_libdir}/libswresample.a
701 %{_libdir}/libswscale.a
702
703 %files ffplay
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_bindir}/ffplay
706 %if %{with doc}
707 %{_mandir}/man1/ffplay.1*
708 %{_mandir}/man1/ffplay-all.1*
709 %endif
710
711 %if %{with doc}
712 %files doc
713 %defattr(644,root,root,755)
714 %doc doc/*.html
715 %endif
This page took 0.104005 seconds and 2 git commands to generate.