]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- added codec2 support
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO:
2 # - libndi_newtek[nonfree, BR: Processing.NDI.Lib.h - probably https://www.newtek.com/ndi/sdk/]
3 # - libdavs2 [pkgconfig(davs2) >= 1.5.115 davs2.h]
4 # - libklvanc [-lklvanc libklvanc/vanc.h]
5 # - libtensorflow [-ltensorflow tensorflow/c/c_api.h]
6 # - libxavs2 [pkgconfig(xavs2) >= 1.2.77
7 # - AMF >= 1.4.4.1 (available at https://github.com/GPUOpen-LibrariesAndSDKs/AMF, where is original source?)
8 #
9 # How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
10 #       1. make-request -r --with bootstrap ffmpeg.spec
11 #       2  bump release of opencv.spec and chromaprint.spec
12 #       3. make-request -r opencv.spec chromaprint.spec
13 #       4. bump release of ffmpeg.spec
14 #       5. make-request -r ffmpeg.spec
15 #
16 # Conditional build:
17 %bcond_with     bootstrap       # disable features to able to build without installed ffmpeg
18 %bcond_with     nonfree         # unblock non free options of package (currently: cuda_sdk, decklib, fdk_aac, libndi_newtek, npp, openssl, libressl/libtls)
19 %bcond_without  bs2b            # BS2B audio filter support
20 %bcond_without  caca            # textual display using libcaca
21 %bcond_without  codec2          # codec2 support using libcodec2
22 %bcond_without  chromaprint     # audio fingerprinting with chromaprint
23 %bcond_with     cudasdk         # NVIDIA CUDA code using SDK [BR: cuda.h, non-free]
24 %bcond_with     decklink        # Blackmagic DeskLink output support (requires nonfree)
25 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
26 %bcond_without  ffnvcodec       # NVIDIA codecs support using ffnvcodec headers (covered: cuda cuvid nvdec nvenc)
27 %bcond_without  flite           # flite voice synthesis support
28 %bcond_without  frei0r          # frei0r video filtering
29 %bcond_without  fribidi         # fribidi support
30 %bcond_without  gme             # Game Music Emu support
31 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
32 %bcond_without  kvazaar         # Kvazaar HEVC encoder support
33 %bcond_without  ladspa          # LADSPA audio filtering
34 %bcond_without  lensfun         # lensfun lens correction
35 %bcond_with     libdrm          # Linux Direct Rendering Manager code
36 %bcond_without  libmysofa       # sofalizer filter
37 %bcond_with     librsvg         # SVG rasterization via librsvg
38 %bcond_with     libxml2         # XML parsing using libxml2
39 %bcond_without  lv2             # LV2 audio filtering
40 %bcond_with     mfx             # MFX hardware acceleration support
41 %bcond_with     npp             # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
42 %bcond_without  omx             # OpenMAX IL support
43 %bcond_without  openal          # OpenAL 1.1 capture support
44 %bcond_without  opencl          # OpenCL 1.2 code
45 %bcond_without  opencv          # OpenCV video filtering
46 %bcond_without  opengl          # OpenGL rendering support
47 %bcond_with     openh264        # OpenH264 H.264 encoder
48 %bcond_without  openmpt         # OpenMPT module decoder
49 %bcond_without  pulseaudio      # PulseAudio input support
50 %bcond_with     rkmpp           # Rockchip Media Process Platform code [implies libdrm]
51 %bcond_without  rubberband      # rubberband filter
52 %bcond_without  shine           # shine fixed-point MP3 encoder
53 %bcond_without  snappy          # Snappy compression support (needed for hap encoding)
54 %bcond_without  srt             # Haivision SRT protocol support
55 %bcond_without  ssh             # SFTP protocol support via libssh
56 %bcond_with     smb             # SMB support via libsmbclient
57 %bcond_without  soxr            # SoX Resampler support
58 %bcond_with     tesseract       # OCR filter based on Tesseract
59 %bcond_without  vmaf            # VMAF filter support
60 %bcond_without  x264            # H.264 x264 encoder
61 %bcond_without  x265            # H.265/HEVC x265 encoder
62 %bcond_without  va              # VAAPI (Video Acceleration API)
63 %bcond_without  vapoursynth     # VapourSynth demuxer
64 %bcond_without  vidstab         # vid.stab video stabilization support
65 %bcond_without  vpx             # VP8, a high-quality video codec
66 %bcond_without  wavpack         # wavpack encoding support
67 %bcond_without  webp            # WebP encoding support
68 %bcond_without  zimg            # zscale filter based on z.lib
69 %bcond_without  zmq             # 0MQ message passing
70 %bcond_without  zvbi            # teletext via libzvbi
71 %bcond_without  doc             # don't build docs
72 %bcond_with     tests           # "make check" (some tests fail as of 2.5)
73
74 %if %{with bootstrap}
75 %undefine       with_opencv
76 %undefine       with_chromaprint
77 %endif
78 %if %{with rkmpp}
79 %define         with_libdrm     1
80 %endif
81
82 %ifnarch %{ix86} %{x8664}
83 %undefine       with_ffnvcodec
84 %endif
85 %ifnarch %{ix86} %{x8664} %{arm}
86 %undefine       with_x265
87 %endif
88 %ifarch i386 i486
89 %undefine       with_x265
90 %endif
91 Summary:        FFmpeg - a very fast video and audio converter
92 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
93 Name:           ffmpeg
94 Version:        4.1.4
95 Release:        1
96 # LGPL or GPL, chosen at configure time (GPL version is more featured)
97 # GPL: frei0r libcdio libdavs2 rubberband vidstab x264 x265 xavs xavs2 xvid
98 # v3 (allows *GPLv3 or Apache-licensed libs): gmp lensfun opencore-amr vmaf vo-*enc rkmpp
99 # GPLv3: smbclient
100 License:        GPL v3+ with LGPL v3+ parts
101 Group:          Applications/Multimedia
102 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
103 # Source0-md5:  5307931aeb7aaee5e1509d9996040661
104 Patch0:         %{name}-omx-libnames.patch
105 URL:            http://www.ffmpeg.org/
106 %{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.9.5}
107 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
108 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
109 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
110 # libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
111 %{?with_omx:BuildRequires:      OpenMAX-IL-devel}
112 BuildRequires:  SDL2-devel >= 2.0.1
113 BuildRequires:  SDL2-devel < 2.1.0
114 BuildRequires:  alsa-lib-devel
115 BuildRequires:  aom-devel >= 1.0.0
116 BuildRequires:  bzip2-devel
117 BuildRequires:  celt-devel >= 0.11.0
118 %{?with_codec2:BuildRequires:   codec2-devel}
119 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
120 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
121 BuildRequires:  fontconfig-devel
122 BuildRequires:  freetype-devel
123 %{?with_frei0r:BuildRequires:   frei0r-devel}
124 %{?with_fribidi:BuildRequires:  fribidi-devel}
125 %{?with_gme:BuildRequires:      game-music-emu-devel}
126 %ifarch ppc
127 # require version with altivec support fixed
128 BuildRequires:  gcc >= 5:3.3.2-3
129 %endif
130 BuildRequires:  gmp-devel
131 BuildRequires:  gnutls-devel
132 BuildRequires:  jack-audio-connection-kit-devel
133 %{?with_kvazaar:BuildRequires:  kvazaar-devel >= 0.8.1}
134 %{?with_ladspa:BuildRequires:   ladspa-devel}
135 BuildRequires:  lame-libs-devel >= 3.98.3
136 %{?with_lensfun:BuildRequires:  lensfun-devel}
137 BuildRequires:  libass-devel
138 BuildRequires:  libavc1394-devel
139 %{?with_bs2b:BuildRequires:     libbs2b-devel}
140 BuildRequires:  libbluray-devel
141 %{?with_caca:BuildRequires:     libcaca-devel}
142 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
143 %{?with_chromaprint:BuildRequires:      libchromaprint-devel}
144 BuildRequires:  libcrystalhd-devel
145 BuildRequires:  libdc1394-devel >= 2
146 %{?with_libdrm:BuildRequires:   libdrm-devel}
147 BuildRequires:  libgsm-devel
148 BuildRequires:  libiec61883-devel
149 BuildRequires:  libmodplug-devel
150 %{?with_libmysofa:BuildRequires:        libmysofa-devel}
151 %{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.2.6557}
152 BuildRequires:  libraw1394-devel >= 2
153 %{?with_librsvg:BuildRequires:  librsvg-devel >= 2}
154 BuildRequires:  librtmp-devel
155 %{?with_ssh:BuildRequires:      libssh-devel}
156 %{?with_smb:BuildRequires:      libsmbclient-devel}
157 BuildRequires:  libtheora-devel >= 1.0-0.beta3
158 BuildRequires:  libtool >= 2:1.4d-3
159 BuildRequires:  libv4l-devel
160 %if %{with va}
161 BuildRequires:  libva-devel >= 1.0.3
162 BuildRequires:  libva-drm-devel >= 1.0.3
163 BuildRequires:  libva-x11-devel >= 1.0.3
164 %endif
165 BuildRequires:  libvdpau-devel >= 0.2
166 BuildRequires:  libvorbis-devel
167 %{?with_vpx:BuildRequires:      libvpx-devel >= 1.4.0}
168 %{?with_webp:BuildRequires:     libwebp-devel >= 0.4.0}
169 # X264_BUILD >= 118
170 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
171 # X265_BUILD >= 68
172 %{?with_x265:BuildRequires:     libx265-devel >= 1.8}
173 # libxcb xcb-shm xcb-xfixes xcb-shape
174 BuildRequires:  libxcb-devel >= 1.4
175 %{?with_libxml2:BuildRequires:  libxml2-devel >= 2}
176 %{?with_lv2:BuildRequires:      lilv-devel}
177 %{?with_lv2:BuildRequires:      lv2-devel}
178 %{?with_mfx:BuildRequires:      mfx_dispatch-devel}
179 %ifarch %{ix86}
180 %ifnarch i386 i486
181 BuildRequires:  nasm
182 %endif
183 %endif
184 %{?with_ffnvcodec:BuildRequires:        nv-codec-headers >= 8.1.24.2}
185 # amrnb,amrwb
186 BuildRequires:  opencore-amr-devel
187 %{?with_opencv:BuildRequires:   opencv-devel >= 2}
188 %{?with_openh264:BuildRequires: openh264-devel >= 1.3}
189 BuildRequires:  openjpeg2-devel >= 2.1
190 BuildRequires:  opus-devel
191 BuildRequires:  perl-Encode
192 BuildRequires:  perl-tools-pod
193 BuildRequires:  pkgconfig
194 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
195 %{?with_rkmpp:BuildRequires:    rockchip-mpp-devel >= 1.3.7}
196 BuildRequires:  rpmbuild(macros) >= 1.470
197 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.8.1}
198 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
199 %{?with_snappy:BuildRequires:   snappy-devel}
200 %{?with_soxr:BuildRequires:     soxr-devel}
201 BuildRequires:  speex-devel >= 1:1.2-rc1
202 %{?with_srt:BuildRequires:      srt-devel >= 1.3}
203 %{?with_tesseract:BuildRequires:        tesseract-devel}
204 %{?with_doc:BuildRequires:      tetex}
205 %{?with_doc:BuildRequires:      texi2html}
206 %{?with_doc:BuildRequires:      texinfo}
207 BuildRequires:  twolame-devel >= 0.3.10
208 %{?with_vapoursynth:BuildRequires:      vapoursynth-devel >= 42}
209 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
210 %{?with_vmaf:BuildRequires:     vmaf-devel >= 1.3.9}
211 BuildRequires:  vo-amrwbenc-devel
212 %{?with_wavpack:BuildRequires:  wavpack-devel}
213 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
214 BuildRequires:  xavs-devel
215 BuildRequires:  xorg-lib-libX11-devel
216 BuildRequires:  xorg-lib-libXext-devel
217 BuildRequires:  xorg-lib-libXv-devel
218 BuildRequires:  xvid-devel >= 1:1.1.0
219 BuildRequires:  xz-devel
220 BuildRequires:  yasm
221 %{?with_zmq:BuildRequires:      zeromq-devel}
222 %{?with_zimg:BuildRequires:     zimg-devel >= 2.7.0}
223 BuildRequires:  zlib-devel
224 %{?with_zvbi:BuildRequires:     zvbi-devel >= 0.2.28}
225 %{?with_autoreqdep:BuildConflicts:      libpostproc}
226 # overflows maximum hash table size
227 BuildConflicts: pdksh < 5.2.14-57
228 Requires:       %{name}-libs = %{version}-%{release}
229 Obsoletes:      libpostproc
230 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
231
232 %define         specflags       -fno-strict-aliasing
233
234 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
235 %define         specflags_ia32  -fomit-frame-pointer
236 # -mmmx is needed to enable <mmintrin.h> code.
237 %define         specflags_i586  -mmmx
238 %define         specflags_i686  -mmmx
239 %define         specflags_ppc   -fPIC
240
241 %description
242 FFmpeg is a complete solution to record, convert and stream audio and
243 video. It is a command line tool to convert one video file format to
244 another. It also supports grabbing and encoding in real time from a TV
245 card.
246
247 %description -l pl.UTF-8
248 FFmpeg to kompletne rozwiÄ…zanie nagrywania, konwersji i transmisji
249 strumieni dźwiÄ™ku i obrazu. Jest to dziaÅ‚ajÄ…ce z linii poleceÅ„
250 narzÄ™dzie do konwersji obrazu z jednego formatu do innego. ObsÅ‚uguje
251 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
252 telewizyjnej.
253
254 %package libs
255 Summary:        ffmpeg libraries
256 Summary(pl.UTF-8):      Biblioteki ffmpeg
257 Group:          Libraries
258 Requires:       SDL2 >= 2.0.1
259 Requires:       aom >= 1.0.0
260 Requires:       celt >= 0.11.0
261 %{?with_flite:Requires: flite >= 1.4}
262 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
263 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
264 Requires:       gnutls-libs >= 3.0.20
265 %endif
266 %{?with_kvazaar:Requires:       kvazaar-libs >= 0.8.1}
267 %{?with_openmpt:Requires: libopenmpt >= 0.2.6557}
268 Requires:       libtheora >= 1.0-0.beta3
269 %if %{with va}
270 Requires:       libva >= 1.0.3
271 Requires:       libva-drm >= 1.0.3
272 Requires:       libva-x11 >= 1.0.3
273 %endif
274 Requires:       libvdpau >= 0.2
275 %{?with_vpx:Requires:   libvpx >= 1.4.0}
276 %{?with_webp:Requires:  libwebp >= 0.4.0}
277 %{?with_x264:Requires:  libx264 >= 0.1.3-1.20111212_2245}
278 %{?with_x265:Requires:  libx265 >= 1.8}
279 Requires:       libxcb >= 1.4
280 Requires:       lame-libs >= 3.98.3
281 %{?with_openh264:Requires:      openh264 >= 1.3}
282 Requires:       openjpeg2 >= 2.1
283 %{?with_rkmpp:Requires: rockchip-mpp >= 1.3.7}
284 %{?with_rubberband:Requires:    rubberband-libs >= 1.8.1}
285 %{?with_shine:Requires: shine >= 3.0.0}
286 Requires:       speex >= 1:1.2-rc1
287 %{?with_srt:Requires:   srt >= 1.3}
288 Requires:       twolame-libs >= 0.3.10
289 %{?with_vapoursynth:Requires:   vapoursynth >= 42}
290 %{?with_vidstab:Requires:       vid.stab >= 0.98}
291 %{?with_vmaf:Requires:  vmaf-libs >= 1.3.9}
292 Requires:       xvid >= 1:1.1.0
293 %{?with_zimg:Requires:  zimg >= 2.7.0}
294 %{?with_zvbi:Requires:  zvbi >= 0.2.28}
295
296 %description libs
297 This package contains the ffmpeg shared libraries:
298 - the codec library (libavcodec). It supports most existing encoding
299   formats (MPEG, DivX, MPEG4, AC3, DV...),
300 - demuxer library (libavformat). It supports most existing file
301   formats (AVI, MPEG, OGG, Matroska, ASF...),
302 - video postprocessing library (libpostproc).
303
304 %description libs -l pl.UTF-8
305 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
306 - bibliotekÄ™ kodeków (libavcodec); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
307   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
308 - bibliotekÄ™ demuksera (libavformat); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
309   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
310 - bibliotekÄ™ postprocessingu (libpostproc).
311
312 %package devel
313 Summary:        ffmpeg header files
314 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
315 Group:          Development/Libraries
316 Requires:       %{name}-libs = %{version}-%{release}
317 # Libs.private from *.pc
318 %{?with_openal:Requires:        OpenAL-devel >= 1.1}
319 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
320 %{?with_opengl:Requires:        OpenGL-devel}
321 Requires:       SDL2-devel >= 2.0.1
322 Requires:       alsa-lib-devel
323 Requires:       aom-devel >= 1.0.0
324 Requires:       bzip2-devel
325 Requires:       celt-devel >= 0.11.0
326 %{?with_codec2:Requires:        codec2-devel}
327 %{?with_fdk_aac:Requires:       fdk-aac-devel}
328 %{?with_flite:Requires: flite-devel >= 1.4}
329 Requires:       fontconfig-devel
330 Requires:       freetype-devel
331 %{?with_fribidi:Requires:       fribidi-devel}
332 %{?with_gme:Requires:   game-music-emu-devel}
333 Requires:       gnutls-devel
334 Requires:       jack-audio-connection-kit-devel
335 %{?with_kvazaar:Requires:       kvazaar-devel >= 0.8.1}
336 Requires:       lame-libs-devel >= 3.98.3
337 %{?with_lensfun:Requires:       lensfun-devel}
338 Requires:       libass-devel
339 Requires:       libavc1394-devel
340 Requires:       libbluray-devel
341 %{?with_bs2b:Requires:  libbs2b-devel}
342 %{?with_caca:Requires:  libcaca-devel}
343 Requires:       libcdio-paranoia-devel >= 0.90-2
344 %{?with_chromaprint:Requires:   libchromaprint-devel}
345 Requires:       libcrystalhd-devel
346 Requires:       libdc1394-devel >= 2
347 %{?with_libdrm:Requires:        libdrm-devel}
348 Requires:       libgsm-devel
349 Requires:       libiec61883-devel
350 Requires:       libmodplug-devel
351 %{?with_libmysofa:Requires:     libmysofa-devel}
352 %{?with_openmpt:Requires: libopenmpt-devel >= 0.2.6557}
353 Requires:       libraw1394-devel >= 2
354 %{?with_librsvg:Requires:       librsvg-devel >= 2}
355 Requires:       librtmp-devel
356 %{?with_smb:Requires:   libsmbclient-devel}
357 %{?with_ssh:Requires:   libssh-devel}
358 Requires:       libstdc++-devel
359 Requires:       libtheora-devel >= 1.0-0.beta3
360 Requires:       libv4l-devel
361 %{?with_va:Requires:    libva-devel >= 1.0.3}
362 %{?with_va:Requires:    libva-drm-devel >= 1.0.3}
363 %{?with_va:Requires:    libva-x11-devel >= 1.0.3}
364 Requires:       libvdpau-devel >= 0.2
365 Requires:       libvorbis-devel
366 %{?with_vpx:Requires:   libvpx-devel >= 1.4.0}
367 %{?with_webp:Requires:  libwebp-devel >= 0.4.0}
368 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
369 %{?with_x265:Requires:  libx265-devel >= 1.8}
370 # libxcb xcb-shm xcb-xfixes xcb-shape
371 Requires:       libxcb-devel >= 1.4
372 %{?with_libxml2:Requires:       libxml2-devel >= 2}
373 %{?with_lv2:Requires:   lilv-devel}
374 %{?with_mfx:Requires:   mfx_dispatch-devel}
375 Requires:       opencore-amr-devel
376 %{?with_opencv:Requires:        opencv-devel >= 2}
377 %{?with_openh264:Requires:      openh264-devel >= 1.3}
378 Requires:       openjpeg2-devel >= 2.1
379 Requires:       opus-devel
380 %{?with_pulseaudio:Requires:    pulseaudio-devel}
381 %{?with_rkmpp:Requires: rockchip-mpp-devel >= 1.3.7}
382 %{?with_rubberband:Requires:    rubberband-devel >= 1.8.1}
383 %{?with_shine:Requires: shine-devel >= 3.0.0}
384 %{?with_snappy:Requires:        snappy-devel}
385 %{?with_soxr:Requires:  soxr-devel}
386 Requires:       speex-devel >= 1:1.2-rc1
387 %{?with_srt:Requires:   srt-devel >= 1.3}
388 %{?with_tesseract:Requires:     tesseract-devel}
389 Requires:       twolame-devel >= 0.3.10
390 %{?with_vapoursynth:Requires:   vapoursynth-devel >= 42}
391 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
392 Requires:       vo-amrwbenc-devel
393 %{?with_vmaf:Requires:  vmaf-devel >= 1.3.9}
394 %{?with_wavpack:Requires:       wavpack-devel}
395 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
396 Requires:       xavs-devel
397 Requires:       xorg-lib-libX11-devel
398 Requires:       xorg-lib-libXext-devel
399 Requires:       xorg-lib-libXv-devel
400 Requires:       xvid-devel >= 1:1.1.0
401 Requires:       xz-devel
402 %{?with_zmq:Requires:   zeromq-devel}
403 %{?with_zimg:Requires:  zimg-devel >= 2.7.0}
404 Requires:       zlib-devel
405 %{?with_zvbi:Requires:  zvbi-devel >= 0.2.28}
406 Obsoletes:      libpostproc-devel
407
408 %description devel
409 ffmpeg header files.
410
411 %description devel -l pl.UTF-8
412 Pliki nagłówkowe ffmpeg.
413
414 %package static
415 Summary:        ffmpeg static libraries
416 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
417 Group:          Development/Libraries
418 Requires:       %{name}-devel = %{version}-%{release}
419
420 %description static
421 ffmpeg static libraries (libavcodec and libavformat).
422
423 %description static -l pl.UTF-8
424 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
425
426 %package ffplay
427 Summary:        FFplay - SDL-based media player
428 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
429 Group:          Applications/Multimedia
430 Requires:       %{name}-libs = %{version}-%{release}
431
432 %description ffplay
433 FFplay is a very simple and portable media player using the FFmpeg
434 libraries and the SDL library. It is mostly used as a test bench for
435 the various APIs of FFmpeg.
436
437 %description ffplay -l pl.UTF-8
438 FFplay to bardzo prosty i przenoÅ›ny odtwarzacz mediów używajÄ…cy
439 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
440 testowania różnych API FFmpeg.
441
442 %package doc
443 Summary:        FFmpeg documentation in HTML format
444 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
445 Group:          Documentation
446 %if "%{_rpmversion}" >= "5"
447 BuildArch:      noarch
448 %endif
449
450 %description doc
451 FFmpeg documentation in HTML format.
452
453 %description doc -l pl.UTF-8
454 Dokumentacja pakietu FFmpeg w formacie HTML.
455
456 %prep
457 %setup -q
458 %patch0 -p1
459
460 # package the grep result for mplayer, the result formatted as ./mplayer/configure
461 cat <<EOF > ffmpeg-avconfig
462 #! /bin/sh
463 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
464 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
465 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
466 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
467 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
468 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
469 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
470 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
471 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
472 EOF
473 cat <<'EOF' >> ffmpeg-avconfig
474
475 case "$1" in
476 --decoders)
477         echo $libavdecoders_all
478         ;;
479 --encoders)
480         echo $libavencoders_all
481         ;;
482 --parsers)
483         echo $libavparsers_all
484         ;;
485 --bsfs)
486         echo $libavbsfs_all
487         ;;
488 --demuxers)
489         echo $libavdemuxers_all
490         ;;
491 --muxers)
492         echo $libavmuxers_all
493         ;;
494 --protocols)
495         echo $libavprotocols_all
496         ;;
497 --hwaccels)
498         echo $libavhwaccels_all
499         ;;
500 --filters)
501         echo $libavfilters_all
502         ;;
503 *)
504         cat <<USAGE
505 Usage: $0 [OPTION]
506 Options:
507   --decoders
508   --encoders
509   --parsers
510   --bsfs
511   --demuxers
512   --muxers
513   --protocols
514   --hwaccels
515   --filters
516 USAGE
517         exit 1;;
518 esac
519
520 exit 0
521 EOF
522
523 %build
524 # notes:
525 # - it's not autoconf configure
526 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
527 ./configure \
528         --arch=%{_target_base_arch} \
529         --prefix=%{_prefix} \
530         --libdir=%{_libdir} \
531         --shlibdir=%{_libdir} \
532         --mandir=%{_mandir} \
533         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
534         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
535         --cc="%{__cc}" \
536         --disable-debug \
537         --disable-optimizations \
538         --disable-stripping \
539         %{!?with_doc:--disable-doc} \
540         --enable-avfilter \
541         --enable-avresample \
542         %{?with_chromaprint:--enable-chromaprint} \
543         %{?with_cudasdk:--enable-cuda-sdk} \
544         %{?with_decklink:--enable-decklink} \
545         %{!?with_ffnvcodec:--disable-ffnvcodec} \
546         --enable-gnutls \
547         --enable-gpl \
548         --enable-version3 \
549         %{?with_frei0r:--enable-frei0r} \
550         %{?with_ladspa:--enable-ladspa} \
551         --enable-libaom \
552         --enable-libass \
553         --enable-libbluray \
554         %{?with_bs2b:--enable-libbs2b} \
555         %{?with_caca:--enable-libcaca} \
556         --enable-libcelt \
557         --enable-libcdio \
558         %{?with_codec2:--enable-libcodec2} \
559         --enable-libdc1394 \
560         %{?with_libdrm:--enable-libdrm} \
561         %{?with_flite:--enable-libflite} \
562         --enable-libfontconfig \
563         --enable-libfreetype \
564         %{?with_fribidi:--enable-libfribidi} \
565         %{?with_gme:--enable-libgme} \
566         --enable-libgsm \
567         --enable-libiec61883 \
568         %{?with_ilbc:--enable-libilbc} \
569         --enable-libjack \
570         %{?with_kvazaar:--enable-libkvazaar} \
571         %{?with_lensfun:--enable-liblensfun} \
572         %{?with_mfx:--enable-libmfx} \
573         --enable-libmodplug \
574         --enable-libmp3lame \
575         %{?with_libmysofa:--enable-libmysofa} \
576         --enable-libopencore-amrnb \
577         --enable-libopencore-amrwb \
578         %{?with_opencv:--enable-libopencv} \
579         %{?with_openh264:--enable-libopenh264} \
580         --enable-libopenjpeg \
581         %{?with_openmpt:--enable-libopenmpt} \
582         --enable-libopus \
583         %{?with_pulseaudio:--enable-libpulse} \
584         %{?with_librsvg:--enable-librsvg} \
585         --enable-librtmp \
586         %{?with_srt:--enable-libsrt} \
587         %{?with_libxml2:--enable-libxml2} \
588         %{?with_rubberband:--enable-librubberband} \
589         %{?with_shine:--enable-libshine} \
590         %{?with_smb:--enable-libsmbclient} \
591         %{?with_snappy:--enable-libsnappy} \
592         %{?with_soxr:--enable-libsoxr} \
593         --enable-libspeex \
594         %{?with_ssh:--enable-libssh} \
595         %{?with_tesseract:--enable-libtesseract} \
596         --enable-libtheora \
597         --enable-libtwolame \
598         --enable-libv4l2 \
599         %{?with_vidstab:--enable-libvidstab} \
600         %{?with_vmaf:--enable-libvmaf} \
601         --enable-libvo-amrwbenc \
602         --enable-libvorbis \
603         %{?with_vpx:--enable-libvpx} \
604         %{?with_wavpack:--enable-libwavpack} \
605         %{?with_webp:--enable-libwebp} \
606         %{?with_x264:--enable-libx264} \
607         %{?with_x265:--enable-libx265} \
608         --enable-libxavs \
609         --enable-libxcb \
610         --enable-libxvid \
611         %{?with_zimg:--enable-libzimg} \
612         %{?with_zmq:--enable-libzmq} \
613         %{?with_zvbi:--enable-libzvbi} \
614         %{?with_lv2:--enable-lv2} \
615         %{?with_omx:--enable-omx} \
616         %{?with_openal:--enable-openal} \
617         %{?with_opencl:--enable-opencl} \
618         %{?with_opengl:--enable-opengl} \
619         --enable-postproc \
620         --enable-pthreads \
621         %{?with_rkmpp:--enable-rkmpp} \
622         --enable-shared \
623         --enable-swscale \
624         %{!?with_va:--disable-vaapi} \
625         %{?with_vapoursynth:--enable-vapoursynth} \
626 %ifnarch %{ix86} %{x8664}
627         --disable-mmx \
628 %endif
629 %ifarch i386 i486
630         --disable-mmx \
631 %endif
632 %ifarch x32
633         --disable-asm \
634 %endif
635 %if %{with nonfree}
636         --enable-nonfree \
637         %{?with_fdk_aac:--enable-libfdk-aac} \
638         %{?with_npp:--enable-libnpp} \
639 %endif
640         --enable-runtime-cpudetect
641
642 %{__make} \
643         V=1
644
645 # CC_O to add -c to commandline. makefile should be patched
646 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
647
648 %{?with_tests:%{__make} check V=1}
649
650 %install
651 rm -rf $RPM_BUILD_ROOT
652 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
653         $RPM_BUILD_ROOT%{_includedir}/ffmpeg
654
655 %{__make} install install-headers \
656         DESTDIR=$RPM_BUILD_ROOT \
657         V=1
658
659 # install nonstandard, non-public headers manually
660 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
661 for a in libavutil/*/{asm,bswap}.h; do
662         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
663 done
664 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
665
666 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
667
668 # install as ffmpeg-avconfig to avoid with possible programs looking for
669 # ffmpeg-config and expecting --libs output from it which is not implemented
670 # simple to do (by querying pkgconfig), but why?
671 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
672
673 # packaged as %doc in -doc
674 %if %{with doc}
675 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
676 %endif
677
678 install -d $RPM_BUILD_ROOT%{_examplesdir}
679 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
680
681 %clean
682 rm -rf $RPM_BUILD_ROOT
683
684 %post   libs -p /sbin/ldconfig
685 %postun libs -p /sbin/ldconfig
686
687 %files
688 %defattr(644,root,root,755)
689 %doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
690 %attr(755,root,root) %{_bindir}/ffmpeg
691 %attr(755,root,root) %{_bindir}/ffprobe
692 %attr(755,root,root) %{_bindir}/qt-faststart
693 %dir %{_datadir}/ffmpeg
694 %{_datadir}/ffmpeg/*.ffpreset
695 %{_datadir}/ffmpeg/ffprobe.xsd
696 %if %{with doc}
697 %{_mandir}/man1/ffmpeg.1*
698 %{_mandir}/man1/ffmpeg-all.1*
699 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
700 %{_mandir}/man1/ffmpeg-codecs.1*
701 %{_mandir}/man1/ffmpeg-devices.1*
702 %{_mandir}/man1/ffmpeg-filters.1*
703 %{_mandir}/man1/ffmpeg-formats.1*
704 %{_mandir}/man1/ffmpeg-protocols.1*
705 %{_mandir}/man1/ffmpeg-resampler.1*
706 %{_mandir}/man1/ffmpeg-scaler.1*
707 %{_mandir}/man1/ffmpeg-utils.1*
708 %{_mandir}/man1/ffprobe.1*
709 %{_mandir}/man1/ffprobe-all.1*
710 %endif
711
712 %files libs
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
716 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
718 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
720 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
722 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
724 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
726 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
728 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
730 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
732
733 %files devel
734 %defattr(644,root,root,755)
735 %doc doc/optimization.txt
736 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
737 %attr(755,root,root) %{_libdir}/libavcodec.so
738 %attr(755,root,root) %{_libdir}/libavdevice.so
739 %attr(755,root,root) %{_libdir}/libavfilter.so
740 %attr(755,root,root) %{_libdir}/libavformat.so
741 %attr(755,root,root) %{_libdir}/libavresample.so
742 %attr(755,root,root) %{_libdir}/libavutil.so
743 %attr(755,root,root) %{_libdir}/libpostproc.so
744 %attr(755,root,root) %{_libdir}/libswresample.so
745 %attr(755,root,root) %{_libdir}/libswscale.so
746 %{_includedir}/ffmpeg
747 %{_includedir}/libavcodec
748 %{_includedir}/libavdevice
749 %{_includedir}/libavfilter
750 %{_includedir}/libavformat
751 %{_includedir}/libavresample
752 %{_includedir}/libavutil
753 %{_includedir}/libpostproc
754 %{_includedir}/libswresample
755 %{_includedir}/libswscale
756 %{_pkgconfigdir}/libavcodec.pc
757 %{_pkgconfigdir}/libavdevice.pc
758 %{_pkgconfigdir}/libavfilter.pc
759 %{_pkgconfigdir}/libavformat.pc
760 %{_pkgconfigdir}/libavresample.pc
761 %{_pkgconfigdir}/libavutil.pc
762 %{_pkgconfigdir}/libpostproc.pc
763 %{_pkgconfigdir}/libswresample.pc
764 %{_pkgconfigdir}/libswscale.pc
765 %if %{with doc}
766 %{_mandir}/man3/libavcodec.3*
767 %{_mandir}/man3/libavdevice.3*
768 %{_mandir}/man3/libavfilter.3*
769 %{_mandir}/man3/libavformat.3*
770 %{_mandir}/man3/libavutil.3*
771 %{_mandir}/man3/libswresample.3*
772 %{_mandir}/man3/libswscale.3*
773 %endif
774 %{_examplesdir}/%{name}-%{version}
775
776 %files static
777 %defattr(644,root,root,755)
778 %{_libdir}/libavcodec.a
779 %{_libdir}/libavdevice.a
780 %{_libdir}/libavfilter.a
781 %{_libdir}/libavformat.a
782 %{_libdir}/libavresample.a
783 %{_libdir}/libavutil.a
784 %{_libdir}/libpostproc.a
785 %{_libdir}/libswresample.a
786 %{_libdir}/libswscale.a
787
788 %files ffplay
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_bindir}/ffplay
791 %if %{with doc}
792 %{_mandir}/man1/ffplay.1*
793 %{_mandir}/man1/ffplay-all.1*
794 %endif
795
796 %if %{with doc}
797 %files doc
798 %defattr(644,root,root,755)
799 %doc doc/*.html
800 %endif
This page took 0.165294 seconds and 3 git commands to generate.