]> git.pld-linux.org Git - packages/ffmpeg.git/blame_incremental - ffmpeg.spec
- rel 13
[packages/ffmpeg.git] / ffmpeg.spec
... / ...
CommitLineData
1#
2# TODO: update for lzo 2.x (currently only lzo 1.x is supported)
3#
4# Conditional build:
5%bcond_without amr # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
6%bcond_without autoreqdep # don't care about package name deps generated by rpm
7%bcond_without imlib2 # don't build imlib2 vhook module
8%bcond_with lzo # build with LZO support
9#
10Summary: Realtime audio/video encoder and streaming server
11Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
12Name: ffmpeg
13Version: 0.4.9
14%define snap 20060129
15%define _rel 13
16Release: 3.%{snap}.%{_rel}
17# LGPL or GPL, chosen at configure time (GPL version is more featured)
18# (postprocessing, a52, xvid, x264, dts, faad)
19License: GPL with LGPL parts
20Group: Applications/Multimedia
21#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
22#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
23Source0: %{name}-%{snap}.tar.bz2
24# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
25Source1: ffserver.init
26Source2: ffserver.sysconfig
27Source3: ffserver.conf
28Patch0: %{name}-libtool.patch
29Patch1: %{name}-libdir.patch
30Patch2: %{name}-gcc4.patch
31Patch3: %{name}-system-amr.patch
32URL: http://ffmpeg.mplayerhq.hu/
33BuildRequires: SDL-devel
34%if %{with amr}
35BuildRequires: amrnb-devel
36BuildRequires: amrwb-devel >= 5.3.0
37%endif
38BuildRequires: faac-devel
39BuildRequires: faad2-devel
40BuildRequires: freetype-devel
41%ifarch ppc
42# require version with altivec support fixed
43BuildRequires: gcc >= 5:3.3.2-3
44%endif
45%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
46BuildRequires: lame-libs-devel
47BuildRequires: libdts-devel
48BuildRequires: libgsm-devel
49BuildRequires: libtheora-devel
50BuildRequires: libtool >= 2:1.4d-3
51BuildRequires: libvorbis-devel
52BuildRequires: libx264-devel >= 0.1.2-1.20060430_2245.1
53%{?with_lzo:BuildRequires: lzo-devel < 2.0}
54%ifarch %{ix86}
55%ifnarch i386 i486
56BuildRequires: nasm
57%endif
58%endif
59BuildRequires: perl-tools-pod
60BuildRequires: rpmbuild(macros) >= 1.268
61BuildRequires: tetex
62BuildRequires: texinfo
63%{?with_amr:BuildRequires: unzip}
64BuildRequires: xvid-devel >= 1:1.1.0
65BuildRequires: zlib-devel
66%{?with_autoreqdep:BuildConflicts: libpostproc}
67Requires: %{name}-libs = %{version}-%{release}
68Requires: xvid >= 1:1.1.0
69Obsoletes: libpostproc
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%define _noautoreqdep libGL.so.1 libGLU.so.1
73
74%define specflags -fno-strict-aliasing
75
76# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
77%define specflags_ia32 -fomit-frame-pointer
78# -mmmx is needed to enable <mmintrin.h> code.
79%define specflags_i586 -mmmx
80%define specflags_i686 -mmmx
81
82%description
83ffmpeg is a hyper fast realtime audio/video encoder and streaming
84server. It can grab from a standard Video4Linux video source and
85convert it into several file formats based on DCT/motion compensation
86encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
87compatible stream.
88
89%description -l pl
90ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
91