]> git.pld-linux.org Git - packages/ffmpeg.git/blame_incremental - ffmpeg.spec
- -devel R: lzo-devel if used (but lzo 2 is not supported)
[packages/ffmpeg.git] / ffmpeg.spec
... / ...
CommitLineData
1#
2# TODO: only lzo 1.x is supported
3#
4# Conditional build:
5%bcond_without imlib2 # don't build imlib2 vhook module
6%bcond_without autoreqdep # don't care about package name deps generated by rpm
7#
8%define snap 20060129
9%define _rel 8.7
10Summary: Realtime audio/video encoder and streaming server
11Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
12Name: ffmpeg
13Version: 0.4.9
14Release: 3.%{snap}.%{_rel}
15# LGPL or GPL, chosen at configure time (GPL version is more featured)
16License: GPL
17Group: Applications/Multimedia
18#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
19#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
20Source0: %{name}-%{snap}.tar.bz2
21# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
22Source1: ffserver.init
23Source2: ffserver.sysconfig
24Source3: ffserver.conf
25Patch0: %{name}-libtool.patch
26Patch1: %{name}-libdir.patch
27Patch2: %{name}-gcc4.patch
28URL: http://ffmpeg.sourceforge.net/
29BuildRequires: SDL-devel
30BuildRequires: faac-devel
31BuildRequires: faad2-devel
32BuildRequires: freetype-devel
33%ifarch ppc
34# require version with altivec support fixed
35BuildRequires: gcc >= 5:3.3.2-3
36%endif
37%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
38BuildRequires: lame-libs-devel
39BuildRequires: libdts-devel
40BuildRequires: libgsm-devel
41BuildRequires: libtheora-devel
42BuildRequires: libtool >= 2:1.4d-3
43BuildRequires: libvorbis-devel
44#BuildRequires: libx264-devel
45BuildRequires: lzo-devel
46%ifarch %{ix86}
47%ifnarch i386 i486
48BuildRequires: nasm
49%endif
50%endif
51BuildRequires: perl-tools-pod
52BuildRequires: rpmbuild(macros) >= 1.268
53BuildRequires: tetex
54BuildRequires: texinfo
55BuildRequires: xvid-devel >= 1:1.1.0
56BuildRequires: zlib-devel
57%{?with_autoreqdep:BuildConflicts: libpostproc}
58Requires: %{name}-libs = %{version}-%{release}
59Requires: xvid >= 1:1.1.0
60Obsoletes: libpostproc
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63%define _noautoreqdep libGL.so.1 libGLU.so.1
64
65%define specflags -fno-strict-aliasing
66
67# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
68%define specflags_ia32 -fomit-frame-pointer
69# -mmmx is needed to enable <mmintrin.h> code.
70%define specflags_i586 -mmmx
71%define specflags_i686 -mmmx
72
73%description
74ffmpeg is a hyper fast realtime audio/video encoder and streaming
75server. It can grab from a standard Video4Linux video source and
76convert it into several file formats based on DCT/motion compensation
77encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
78compatible stream.
79
80%description -l pl
81ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
82