]> git.pld-linux.org Git - packages/ffmpeg.git/blame_incremental - ffmpeg.spec
- ah, merge from DEVEL
[packages/ffmpeg.git] / ffmpeg.spec
... / ...
CommitLineData
1#
2# TODO: update for lzo 2.x (currently only lzo 1.x is supported)
3#
4# Conditional build:
5%bcond_with amr # build 3GPP Adaptive Multi Rate (AMR) speech codec
6%bcond_without autoreqdep # don't care about package name deps generated by rpm
7%bcond_without imlib2 # don't build imlib2 vhook module
8%bcond_with lzo # build with LZO support
9#
10%define _snap 2006-12-04
11%define snap %(echo %{_snap} | tr -d -)
12%define _rel 0.3
13Summary: Realtime audio/video encoder and streaming server
14Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
15Name: ffmpeg
16Version: 0.4.9
17Release: 3.%{snap}.%{_rel}
18# LGPL or GPL, chosen at configure time (GPL version is more featured)
19# (postprocessing, a52, xvid, x264, dts, faad)
20License: GPL with LGPL parts
21Group: Applications/Multimedia
22#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
23#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
24#Source0: %{name}-%{snap}.tar.bz2
25Source0: http://ffmpeg.mplayerhq.hu/%{name}-export-snapshot.tar.bz2
26# Source0-md5: 5be2e4d1e326bb7809205a3401204621
27Source1: ffserver.init
28Source2: ffserver.sysconfig
29Source3: ffserver.conf
30Patch0: %{name}-libtool.patch
31Patch1: %{name}-libdir.patch
32Patch2: %{name}-gcc4.patch
33Patch3: %{name}-system-amr.patch
34Patch4: %{name}-x264-symbol.patch
35Patch5: %{name}-as_needed.patch
36URL: http://ffmpeg.mplayerhq.hu/
37BuildRequires: SDL-devel
38%if %{with amr}
39BuildRequires: amrnb-devel
40BuildRequires: amrwb-devel >= 5.3.0
41%endif
42BuildRequires: faac-devel
43BuildRequires: faad2-devel
44BuildRequires: freetype-devel
45%ifarch ppc
46# require version with altivec support fixed
47BuildRequires: gcc >= 5:3.3.2-3
48%endif
49%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
50BuildRequires: lame-libs-devel
51BuildRequires: libdts-devel
52BuildRequires: libgsm-devel
53BuildRequires: libtheora-devel
54BuildRequires: libtool >= 2:1.4d-3
55BuildRequires: libvorbis-devel
56BuildRequires: libx264-devel >= 0.1.2-1.20061024_2245.1
57#%{?with_lzo:BuildRequires: lzo-devel < 2.0}
58%ifarch %{ix86}
59%ifnarch i386 i486
60BuildRequires: nasm
61%endif
62%endif
63BuildRequires: perl-tools-pod
64BuildRequires: rpmbuild(macros) >= 1.268
65BuildRequires: tetex
66BuildRequires: texinfo
67%{?with_amr:BuildRequires: unzip}
68BuildRequires: xvid-devel >= 1:1.1.0
69BuildRequires: zlib-devel
70%{?with_autoreqdep:BuildConflicts: libpostproc}
71Requires: %{name}-libs = %{version}-%{release}
72Requires: xvid >= 1:1.1.0
73Obsoletes: libpostproc
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76%define _noautoreqdep libGL.so.1 libGLU.so.1
77
78%define specflags -fno-strict-aliasing
79
80# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
81%define specflags_ia32 -fomit-frame-pointer
82# -mmmx is needed to enable <mmintrin.h> code.
83%define specflags_i586 -mmmx
84%define specflags_i686 -mmmx
85
86%description
87ffmpeg is a hyper fast realtime audio/video encoder and streaming
88server. It can grab from a standard Video4Linux video source and
89convert it into several file formats based on DCT/motion compensation
90encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
91compatible stream.
92
93%description -l pl
94ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
95