]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- release 2 (by relup.sh)
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
44f5d561
JB
1# TODO:
2# - libvmaf [BR: libvmaf.pc, libvmaf, libvmaf.h]
3# - libndi_newtek[nonfree, BR: Processing.NDI.Lib.h]
4# - libmysofa [BR: libmysofa, mysofa.h]
5# - rkmpp[GPLv3, BR: rockchip_mpp.pc, rockchip/rk_mpi_cmd.h, libdrm]
197f4211 6#
d0745ce6 7# How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
29c7bf5c 8# 1. make-request -r --with bootstrap ffmpeg.spec
d0745ce6
JR
9# 2 bump release of opencv.spec and chromaprint.spec
10# 3. make-request -r opencv.spec chromaprint.spec
11# 4. bump release of ffmpeg.spec
12# 5. make-request -r ffmpeg.spec
192f9f57 13#
2b3b2117 14# Conditional build:
29c7bf5c 15%bcond_with bootstrap # disable features to able to build without installed ffmpeg
44f5d561 16%bcond_with nonfree # unblock non free options of package (currently: cuda_sdk, decklib, fdk_aac, libndi_newtek, npp, openssl)
4474c07d 17%bcond_without bs2b # BS2B audio filter support
1c1d1368 18%bcond_without caca # textual display using libcaca
0fdde3cc 19%bcond_without chromaprint # audio fingerprinting with chromaprint
44f5d561
JB
20%bcond_without cuda # NVIDIA CUDA code
21%bcond_with cudasdk # NVIDIA CUDA code using SDK [BR: cuda.h, non-free]
7003e3a3
JB
22%bcond_with cuvid # NVIDIA CUVID support
23%bcond_with decklink # Blackmagic DeskLink output support (requires nonfree)
24%bcond_with fdk_aac # AAC de/encoding via libfdk_aac (requires nonfree)
a584ded4
JB
25%bcond_without flite # flite voice synthesis support
26%bcond_without frei0r # frei0r video filtering
4474c07d 27%bcond_without fribidi # fribidi support
22745365 28%bcond_without gme # Game Music Emu support
cbeed0a5 29%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
7160e157 30%bcond_without kvazaar # Kvazaar HEVC encoder support
5f3dc7d9 31%bcond_without ladspa # LADSPA audio filtering
44f5d561
JB
32%bcond_with libdrm # Linux Direct Rendering Manager code
33%bcond_with librsvg # SVG rasterization via librsvg
34%bcond_with libxml2 # XML parsing using libxml2
0258feb8 35%bcond_with mfx # MFX hardware acceleration support
7003e3a3
JB
36%bcond_with npp # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
37%bcond_with nvenc # NVIDIA NVENC support
38%bcond_without omx # OpenMAX IL support
a584ded4 39%bcond_without openal # OpenAL 1.1 capture support
6513d7e3 40%bcond_without opencl # OpenCL 1.2 code
a584ded4 41%bcond_without opencv # OpenCV video filtering
0258feb8
JB
42%bcond_without opengl # OpenGL rendering support
43%bcond_with openh264 # OpenH264 H.264 encoder
6dfc7c2a 44%bcond_without openmpt # OpenMPT module decoder
a584ded4 45%bcond_without pulseaudio # PulseAudio input support
0fdde3cc 46%bcond_without rubberband # rubberband filter
f56b6dce 47%bcond_without shine # shine fixed-point MP3 encoder
7160e157 48%bcond_without snappy # Snappy compression support (needed for hap encoding)
0258feb8 49%bcond_without ssh # SFTP protocol support via libssh
4474c07d 50%bcond_with smb # SMB support via libsmbclient
05408820 51%bcond_without soxr # SoX Resampler support
e5c1d36e 52%bcond_with tesseract # OCR filter based on Tesseract
8b9d2787 53%bcond_without x264 # H.264 x264 encoder
90ab353a 54%bcond_without x265 # H.265/HEVC x265 encoder
1ef27ea1 55%bcond_without va # VAAPI (Video Acceleration API)
f56b6dce 56%bcond_without vidstab # vid.stab video stabilization support
1ef27ea1 57%bcond_without vpx # VP8, a high-quality video codec
22745365 58%bcond_without wavpack # wavpack encoding support
8b9d2787 59%bcond_without webp # WebP encoding support
e5c1d36e 60%bcond_without zimg # zscale filter based on z.lib
6a6b11be 61%bcond_without zmq # 0MQ message passing
5f3dc7d9 62%bcond_without zvbi # teletext via libzvbi
1ef27ea1 63%bcond_without doc # don't build docs
560d82ce 64%bcond_with tests # "make check" (some tests fail as of 2.5)
314ef0df 65
29c7bf5c
ER
66%if %{with bootstrap}
67%undefine with_opencv
d0745ce6 68%undefine with_chromaprint
29c7bf5c
ER
69%endif
70
7003e3a3 71%ifnarch %{ix86} %{x8664} %{arm}
a6755e78
JB
72%undefine with_x265
73%endif
74%ifarch i386 i486
75%undefine with_x265
76%endif
cbdd2688
JB
77Summary: FFmpeg - a very fast video and audio converter
78Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 79Name: ffmpeg
c9c40358 80Version: 4.1.3
574eb824 81Release: 2
9cf4d8a4 82# LGPL or GPL, chosen at configure time (GPL version is more featured)
1913be3c 83# (postprocessing, some filters, x264, x265, xavs, xvid, xcbgrab)
38cefaee 84# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 85License: GPL v3+ with LGPL v3+ parts
fde29260 86Group: Applications/Multimedia
ad057c0a 87Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
c9c40358 88# Source0-md5: dcc20dd2682ea01c678b7b8324339d43
7003e3a3 89Patch0: %{name}-omx-libnames.patch
85f7cea1 90URL: http://www.ffmpeg.org/
1cfb9896 91%{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.6.1}
28673856 92%{?with_openal:BuildRequires: OpenAL-devel >= 1.1}
6a6b11be 93%{?with_opencl:BuildRequires: OpenCL-devel >= 1.2}
8b9d2787 94%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
7003e3a3
JB
95# libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
96%{?with_omx:BuildRequires: OpenMAX-IL-devel}
97BuildRequires: SDL2-devel >= 2.0.1
44f5d561 98BuildRequires: SDL2-devel < 2.1.0
cbdd2688 99BuildRequires: alsa-lib-devel
a8e80bf7 100BuildRequires: aom-devel >= 1.0.0
38cefaee 101BuildRequires: bzip2-devel
9f9ba8ac 102BuildRequires: celt-devel >= 0.11.0
004e5628 103%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 104%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 105BuildRequires: fontconfig-devel
0aad4bf2 106BuildRequires: freetype-devel
d7a39558 107%{?with_frei0r:BuildRequires: frei0r-devel}
4474c07d 108%{?with_fribidi:BuildRequires: fribidi-devel}
22745365 109%{?with_gme:BuildRequires: game-music-emu-devel}
4bee03f0
JB
110%ifarch ppc
111# require version with altivec support fixed
112BuildRequires: gcc >= 5:3.3.2-3
113%endif
fecf9f23 114BuildRequires: gmp-devel
d5aef92e 115BuildRequires: gnutls-devel
cbdd2688 116BuildRequires: jack-audio-connection-kit-devel
bd64dc4c 117%{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.8.1}
5f3dc7d9 118%{?with_ladspa:BuildRequires: ladspa-devel}
cbdd2688 119BuildRequires: lame-libs-devel >= 3.98.3
d5aef92e 120BuildRequires: libass-devel
1c1d1368 121BuildRequires: libavc1394-devel
4474c07d 122%{?with_bs2b:BuildRequires: libbs2b-devel}
3dcb8642 123BuildRequires: libbluray-devel
1c1d1368 124%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 125BuildRequires: libcdio-paranoia-devel >= 0.90-2
0fdde3cc 126%{?with_chromaprint:BuildRequires: libchromaprint-devel}
9c4296c2 127BuildRequires: libdc1394-devel >= 2
44f5d561 128%{?with_libdrm:BuildRequires: libdrm-devel}
f1669449 129BuildRequires: libgsm-devel
1c1d1368 130BuildRequires: libiec61883-devel
d5aef92e 131BuildRequires: libmodplug-devel
6dfc7c2a 132%{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.2.6557}
7571bfa0 133BuildRequires: libraw1394-devel >= 2
44f5d561 134%{?with_librsvg:BuildRequires: librsvg-devel >= 2}
cbdd2688 135BuildRequires: librtmp-devel
5f3dc7d9 136%{?with_ssh:BuildRequires: libssh-devel}
4474c07d 137%{?with_smb:BuildRequires: libsmbclient-devel}
9042663c 138BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 139BuildRequires: libtool >= 2:1.4d-3
daf9a670 140BuildRequires: libv4l-devel
7003e3a3
JB
141%if %{with va}
142BuildRequires: libva-devel >= 1.0.3
143BuildRequires: libva-drm-devel >= 1.0.3
144BuildRequires: libva-x11-devel >= 1.0.3
145%endif
9c4296c2 146BuildRequires: libvdpau-devel >= 0.2
e380e18a 147BuildRequires: libvorbis-devel
ff838fc6 148%{?with_vpx:BuildRequires: libvpx-devel >= 1.4.0}
fecf9f23 149%{?with_webp:BuildRequires: libwebp-devel >= 0.4.0}
660918c5
AM
150# X264_BUILD >= 118
151%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
44f5d561
JB
152# X265_BUILD >= 68
153%{?with_x265:BuildRequires: libx265-devel >= 1.8}
560d82ce 154# libxcb xcb-shm xcb-xfixes xcb-shape
0258feb8 155BuildRequires: libxcb-devel >= 1.4
44f5d561 156%{?with_libxml2:BuildRequires: libxml2-devel >= 2}
0258feb8 157%{?with_mfx:BuildRequires: mfx_dispatch-devel}
e1fe03f7 158%ifarch %{ix86}
159%ifnarch i386 i486
76243dbd
JB
160BuildRequires: nasm
161%endif
e1fe03f7 162%endif
0258feb8 163# which package?
7003e3a3 164#%{?with_nvenc:BuildRequires: NVIDIA-NVENC-API} compat/nvenc/nvEncodeAPI.h
1c1d1368
JB
165BuildRequires: opencore-amr-devel
166%{?with_opencv:BuildRequires: opencv-devel}
62da4e00 167%{?with_openh264:BuildRequires: openh264-devel >= 1.3}
7003e3a3 168BuildRequires: openjpeg2-devel >= 2.1
1c1d1368 169BuildRequires: opus-devel
136f0f45 170BuildRequires: perl-Encode
1463656a 171BuildRequires: perl-tools-pod
ef3c0513 172BuildRequires: pkgconfig
1c1d1368 173%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 174BuildRequires: rpmbuild(macros) >= 1.470
0fdde3cc 175%{?with_rubberband:BuildRequires: rubberband-devel >= 1.8.1}
4a11c99e 176%{?with_shine:BuildRequires: shine-devel >= 3.0.0}
7160e157 177%{?with_snappy:BuildRequires: snappy-devel}
05408820 178%{?with_soxr:BuildRequires: soxr-devel}
1c1d1368 179BuildRequires: speex-devel >= 1:1.2-rc1
e5c1d36e 180%{?with_tesseract:BuildRequires: tesseract-devel}
64f8f109
ER
181%{?with_doc:BuildRequires: tetex}
182%{?with_doc:BuildRequires: texi2html}
183%{?with_doc:BuildRequires: texinfo}
ff838fc6 184BuildRequires: twolame-devel >= 0.3.10
9befe454 185%{?with_vidstab:BuildRequires: vid.stab-devel >= 0.98}
5dc039cb 186BuildRequires: vo-amrwbenc-devel
22745365 187%{?with_wavpack:BuildRequires: wavpack-devel}
cbeed0a5 188%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 189BuildRequires: xavs-devel
28673856 190BuildRequires: xorg-lib-libX11-devel
cbdd2688
JB
191BuildRequires: xorg-lib-libXext-devel
192BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 193BuildRequires: xvid-devel >= 1:1.1.0
7003e3a3 194BuildRequires: xz-devel
cbeed0a5 195BuildRequires: yasm
6a6b11be 196%{?with_zmq:BuildRequires: zeromq-devel}
d2c2eb42 197%{?with_zimg:BuildRequires: zimg-devel >= 2.7.0}
33a1c0f3 198BuildRequires: zlib-devel
e5c1d36e 199%{?with_zvbi:BuildRequires: zvbi-devel}
57ebb8ad 200%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
201# overflows maximum hash table size
202BuildConflicts: pdksh < 5.2.14-57
54ec280e 203Requires: %{name}-libs = %{version}-%{release}
92a3edff 204%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 205Requires: xvid >= 1:1.1.0
af49d6ab 206Obsoletes: libpostproc
539b540f 207BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 208
c01d7857
PS
209%define specflags -fno-strict-aliasing
210
211# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
212%define specflags_ia32 -fomit-frame-pointer
213# -mmmx is needed to enable <mmintrin.h> code.
214%define specflags_i586 -mmmx
215%define specflags_i686 -mmmx
1162803a 216%define specflags_ppc -fPIC
c01d7857 217
9fc4ad22 218%description
85f7cea1
ER
219FFmpeg is a complete solution to record, convert and stream audio and
220video. It is a command line tool to convert one video file format to
221another. It also supports grabbing and encoding in real time from a TV
222card.
9fc4ad22 223
cdb7b42e 224%description -l pl.UTF-8
cbdd2688
JB
225FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
226strumieni dźwięku i obrazu. Jest to działające z linii poleceń
227narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
228także przechwytywanie i kodowanie w czasie rzeczywistym z karty
229telewizyjnej.
9fc4ad22 230
54ec280e
PG
231%package libs
232Summary: ffmpeg libraries
adcc0f76 233Summary(pl.UTF-8): Biblioteki ffmpeg
1be5865c 234Group: Libraries
7003e3a3 235Requires: SDL2 >= 2.0.1
a8e80bf7 236Requires: aom >= 1.0.0
143c6eec
JB
237%if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
238# uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
f9cce0c9 239Requires: gnutls-libs >= 3.0.20
143c6eec 240%endif
6dfc7c2a 241%{?with_openmpt:Requires: libopenmpt >= 0.2.6557}
ff838fc6 242%{?with_vpx:Requires: libvpx >= 1.4.0}
0fdde3cc 243%{?with_rubberband:Requires: rubberband-libs >= 1.8.1}
ff838fc6 244Requires: twolame-libs >= 0.3.10
80c0841f 245%{?with_zimg:Requires: zimg >= 2.7.0}
54ec280e
PG
246
247%description libs
cbdd2688
JB
248This package contains the ffmpeg shared libraries:
249- the codec library (libavcodec). It supports most existing encoding
250 formats (MPEG, DivX, MPEG4, AC3, DV...),
251- demuxer library (libavformat). It supports most existing file
252 formats (AVI, MPEG, OGG, Matroska, ASF...),
253- video postprocessing library (libpostproc).
54ec280e 254
cdb7b42e 255%description libs -l pl.UTF-8
cbdd2688
JB
256Ten pakiet zawiera biblioteki współdzielone ffmpeg:
257- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
258 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
259- bibliotekę demuksera (libavformat); obsługuje większość istniejących
260 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
261- bibliotekę postprocessingu (libpostproc).
54ec280e 262
af49d6ab
JB
263%package devel
264Summary: ffmpeg header files
adcc0f76 265Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 266Group: Development/Libraries
54ec280e 267Requires: %{name}-libs = %{version}-%{release}
38cefaee 268# Libs.private from *.pc (unreasonably they are all the same)
6a6b11be 269%{?with_opencl:Requires: OpenCL-devel >= 1.2}
f6f5022a 270%{?with_opengl:Requires: OpenGL-devel}
7003e3a3 271Requires: SDL2-devel >= 2.0.1
38cefaee
JB
272Requires: alsa-lib-devel
273Requires: bzip2-devel
9c4296c2 274Requires: celt-devel >= 0.11.0
004e5628 275%{?with_fdk_aac:Requires: fdk-aac-devel}
4b05ede1 276%{?with_flite:Requires: flite-devel >= 1.4}
3dcb8642 277Requires: fontconfig-devel
0aad4bf2 278Requires: freetype-devel
4474c07d 279%{?with_fribidi:Requires: fribidi-devel}
22745365 280%{?with_gme:Requires: game-music-emu-devel}
38cefaee 281Requires: jack-audio-connection-kit-devel
9e9d5429 282%{?with_kvazaar:Requires: kvazaar-devel >= 0.8.1}
38cefaee 283Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
284Requires: libass-devel
285Requires: libavc1394-devel
3dcb8642 286Requires: libbluray-devel
4474c07d 287%{?with_bs2b:Requires: libbs2b-devel}
28673856 288%{?with_caca:Requires: libcaca-devel}
a09e741c 289Requires: libcdio-paranoia-devel >= 0.90-2
0fdde3cc 290%{?with_chromaprint:Requires: libchromaprint-devel}
9c4296c2 291Requires: libdc1394-devel >= 2
44f5d561 292%{?with_libdrm:Requires: libdrm-devel}
bf479bc6 293Requires: libgsm-devel
1c1d1368
JB
294Requires: libiec61883-devel
295Requires: libmodplug-devel
6dfc7c2a 296%{?with_openmpt:Requires: libopenmpt-devel >= 0.2.6557}
7571bfa0 297Requires: libraw1394-devel >= 2
44f5d561 298%{?with_librsvg:Requires: librsvg-devel >= 2}
38cefaee 299Requires: librtmp-devel
4474c07d 300%{?with_smb:Requires: libsmbclient-devel}
38cefaee
JB
301Requires: libtheora-devel >= 1.0-0.beta3
302%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 303Requires: libvorbis-devel
ff838fc6 304%{?with_vpx:Requires: libvpx-devel >= 1.4.0}
fecf9f23 305%{?with_webp:Requires: libwebp-devel >= 0.4.0}
ea09f25d 306%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
44f5d561
JB
307%{?with_x265:Requires: libx265-devel >= 1.8}
308%{?with_libxml2:Requires: libxml2-devel >= 2}
0258feb8 309%{?with_mfx:Requires: mfx_dispatch-devel}
38cefaee 310Requires: opencore-amr-devel
fc1d9619 311%{?with_opencv:Requires: opencv-devel}
62da4e00 312%{?with_openh264:Requires: openh264-devel >= 1.3}
7003e3a3 313Requires: openjpeg2-devel >= 2.1
0fdde3cc 314%{?with_rubberband:Requires: rubberband-devel >= 1.8.1}
4a11c99e 315%{?with_shine:Requires: shine-devel >= 3.0.0}
7160e157 316%{?with_snappy:Requires: snappy-devel}
05408820 317%{?with_soxr:Requires: soxr-devel}
38cefaee 318Requires: speex-devel >= 1:1.2-rc1
e5c1d36e 319%{?with_tesseract:Requires: tesseract-devel}
ff838fc6 320Requires: twolame-devel >= 0.3.10
9befe454 321%{?with_vidstab:Requires: vid.stab-devel >= 0.98}
38cefaee 322Requires: vo-amrwbenc-devel
22745365 323%{?with_wavpack:Requires: wavpack-devel}
cbeed0a5 324%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
325Requires: xavs-devel
326Requires: xorg-lib-libXext-devel
327Requires: xorg-lib-libXfixes-devel
46f2a56b 328Requires: xvid-devel >= 1:1.1.0
6a6b11be 329%{?with_zmq:Requires: zeromq-devel}
1913be3c 330%{?with_zimg:Requires: zimg-devel >= 2.3.0}
33a1c0f3 331Requires: zlib-devel
8152d6a2 332Obsoletes: libpostproc-devel
af49d6ab
JB
333
334%description devel
335ffmpeg header files.
336
cdb7b42e
JR
337%description devel -l pl.UTF-8
338Pliki nagłówkowe ffmpeg.
af49d6ab
JB
339
340%package static
341Summary: ffmpeg static libraries
adcc0f76 342Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
343Group: Development/Libraries
344Requires: %{name}-devel = %{version}-%{release}
345
346%description static
347ffmpeg static libraries (libavcodec and libavformat).
348
cdb7b42e 349%description static -l pl.UTF-8
af49d6ab
JB
350Statyczne biblioteki ffmpeg (libavcodec i libavformat).
351
2a60eebe
JB
352%package ffplay
353Summary: FFplay - SDL-based media player
adcc0f76 354Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 355Group: Applications/Multimedia
54ec280e 356Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
357
358%description ffplay
359FFplay is a very simple and portable media player using the FFmpeg
360libraries and the SDL library. It is mostly used as a test bench for
361the various APIs of FFmpeg.
362
cdb7b42e
JR
363%description ffplay -l pl.UTF-8
364FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
365bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
366testowania różnych API FFmpeg.
2a60eebe 367
4b05ede1 368%package doc
143c6eec
JB
369Summary: FFmpeg documentation in HTML format
370Summary(pl.UTF-8): Dokumentacja pakietu FFmpeg w formacie HTML
4b05ede1
ER
371Group: Documentation
372%if "%{_rpmversion}" >= "5"
373BuildArch: noarch
374%endif
375
376%description doc
143c6eec 377FFmpeg documentation in HTML format.
4b05ede1
ER
378
379%description doc -l pl.UTF-8
143c6eec 380Dokumentacja pakietu FFmpeg w formacie HTML.
4b05ede1 381
9fc4ad22 382%prep
aed8e8c9 383%setup -q
7003e3a3 384%patch0 -p1
9fc4ad22 385
9d4f8977
ER
386# package the grep result for mplayer, the result formatted as ./mplayer/configure
387cat <<EOF > ffmpeg-avconfig
2b2445b7 388#! /bin/sh
16803cdb
ER
389libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
390libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
391libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
392libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
393libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
394libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
395libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
396libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
397libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
2b2445b7 398EOF
9d4f8977 399cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
400
401case "$1" in
402--decoders)
16803cdb 403 echo $libavdecoders_all
2b2445b7
ER
404 ;;
405--encoders)
16803cdb 406 echo $libavencoders_all
2b2445b7
ER
407 ;;
408--parsers)
16803cdb 409 echo $libavparsers_all
2b2445b7
ER
410 ;;
411--bsfs)
16803cdb 412 echo $libavbsfs_all
2b2445b7
ER
413 ;;
414--demuxers)
16803cdb 415 echo $libavdemuxers_all
2b2445b7
ER
416 ;;
417--muxers)
16803cdb 418 echo $libavmuxers_all
2b2445b7
ER
419 ;;
420--protocols)
16803cdb
ER
421 echo $libavprotocols_all
422 ;;
423--hwaccels)
424 echo $libavhwaccels_all
425 ;;
426--filters)
427 echo $libavfilters_all
2b2445b7
ER
428 ;;
429*)
430 cat <<USAGE
431Usage: $0 [OPTION]
432Options:
433 --decoders
434 --encoders
435 --parsers
436 --bsfs
437 --demuxers
438 --muxers
439 --protocols
16803cdb
ER
440 --hwaccels
441 --filters
2b2445b7
ER
442USAGE
443 exit 1;;
444esac
445
446exit 0
447EOF
448
9fc4ad22 449%build
05e1eb2f
JB
450# notes:
451# - it's not autoconf configure
d0a0ec26 452# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 453./configure \
b4680d0b 454 --arch=%{_target_base_arch} \
539b540f 455 --prefix=%{_prefix} \
9cf4d8a4 456 --libdir=%{_libdir} \
d81dfa95 457 --shlibdir=%{_libdir} \
2a60eebe 458 --mandir=%{_mandir} \
f6f5022a 459 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
1162803a 460 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 461 --cc="%{__cc}" \
126fb805
JB
462 --disable-debug \
463 --disable-optimizations \
6382c99d 464 --disable-stripping \
eaa9ad7b 465 %{!?with_doc:--disable-doc} \
314ef0df 466 --enable-avfilter \
0797daec 467 --enable-avresample \
0fdde3cc 468 %{?with_chromaprint:--enable-chromaprint} \
7003e3a3 469 %{!?with_cuda:--disable-cuda} \
44f5d561 470 %{?with_cudasdk:--enable-cuda-sdk} \
7003e3a3 471 %{!?with_cuvid:--disable-cuvid} \
f6f5022a 472 %{?with_decklink:--enable-decklink} \
d5aef92e 473 --enable-gnutls \
126fb805 474 --enable-gpl \
0b43f655 475 --enable-version3 \
d7a39558 476 %{?with_frei0r:--enable-frei0r} \
5f3dc7d9 477 %{?with_ladspa:--enable-ladspa} \
f2b6eec0 478 --enable-libaom \
d5aef92e 479 --enable-libass \
3dcb8642 480 --enable-libbluray \
4474c07d 481 %{?with_bs2b:--enable-libbs2b} \
2362253d 482 %{?with_caca:--enable-libcaca} \
cbdd2688 483 --enable-libcelt \
d5aef92e
JB
484 --enable-libcdio \
485 --enable-libdc1394 \
44f5d561 486 %{?with_libdrm:--enable-libdrm} \
1c1d1368 487 %{?with_flite:--enable-libflite} \
7003e3a3 488 --enable-libfontconfig \
3dcb8642 489 --enable-libfreetype \
4474c07d 490 %{?with_fribidi:--enable-libfribidi} \
22745365 491 %{?with_gme:--enable-libgme} \
f3692243 492 --enable-libgsm \
1c1d1368 493 --enable-libiec61883 \
004e5628 494 %{?with_ilbc:--enable-libilbc} \
7160e157 495 %{?with_kvazaar:--enable-libkvazaar} \
0258feb8 496 %{?with_mfx:--enable-libmfx} \
d5aef92e 497 --enable-libmodplug \
15c15700 498 --enable-libmp3lame \
cbdd2688
JB
499 --enable-libopencore-amrnb \
500 --enable-libopencore-amrwb \
192f9f57 501 %{?with_opencv:--enable-libopencv} \
0258feb8 502 %{?with_openh264:--enable-libopenh264} \
cbdd2688 503 --enable-libopenjpeg \
6dfc7c2a 504 %{?with_openmpt:--enable-libopenmpt} \
1c1d1368 505 --enable-libopus \
d5aef92e 506 %{?with_pulseaudio:--enable-libpulse} \
44f5d561 507 %{?with_librsvg:--enable-librsvg} \
cbdd2688 508 --enable-librtmp \
44f5d561 509 %{?with_libxml2:--enable-libxml2} \
0fdde3cc 510 %{?with_rubberband:--enable-librubberband} \
f56b6dce 511 %{?with_shine:--enable-libshine} \
4474c07d 512 %{?with_smb:--enable-libsmbclient} \
7160e157 513 %{?with_snappy:--enable-libsnappy} \
05408820 514 %{?with_soxr:--enable-libsoxr} \
da99dcf2 515 --enable-libspeex \
5f3dc7d9 516 %{?with_ssh:--enable-libssh} \
e5c1d36e 517 %{?with_tesseract:--enable-libtesseract} \
126fb805 518 --enable-libtheora \
1c1d1368 519 --enable-libtwolame \
d5aef92e 520 --enable-libv4l2 \
f56b6dce 521 %{?with_vidstab:--enable-libvidstab} \
5dc039cb 522 --enable-libvo-amrwbenc \
126fb805 523 --enable-libvorbis \
64f8f109 524 %{?with_vpx:--enable-libvpx} \
22745365 525 %{?with_wavpack:--enable-libwavpack} \
8b9d2787 526 %{?with_webp:--enable-libwebp} \
ea09f25d 527 %{?with_x264:--enable-libx264} \
90ab353a 528 %{?with_x265:--enable-libx265} \
5dc039cb 529 --enable-libxavs \
9e9d5429 530 --enable-libxcb \
126fb805 531 --enable-libxvid \
e5c1d36e 532 %{?with_zimg:--enable-libzimg} \
6a6b11be 533 %{?with_zmq:--enable-libzmq} \
5f3dc7d9 534 %{?with_zvbi:--enable-libzvbi} \
7003e3a3
JB
535 %{!?with_nvenc:--disable-nvenc} \
536 %{?with_omx:--enable-omx} \
d5aef92e 537 %{?with_openal:--enable-openal} \
f56b6dce 538 %{?with_opencl:--enable-opencl} \
8b9d2787 539 %{?with_opengl:--enable-opengl} \
6382c99d 540 --enable-postproc \
d7493de8 541 --enable-pthreads \
9cf4d8a4 542 --enable-shared \
6382c99d 543 --enable-swscale \
22745365 544 %{!?with_va:--disable-vaapi} \
7a286645 545%ifnarch %{ix86} %{x8664}
e1fe03f7 546 --disable-mmx \
547%endif
548%ifarch i386 i486
05e1eb2f 549 --disable-mmx \
b524cd99 550%endif
61f81a23
JR
551%ifarch x32
552 --disable-asm \
553%endif
0b43f655 554%if %{with nonfree}
48610c64 555 --enable-nonfree \
c8f42fb1 556 %{?with_fdk_aac:--enable-libfdk-aac} \
7003e3a3 557 %{?with_npp:--enable-libnpp} \
76243dbd 558%endif
75231f25 559 --enable-runtime-cpudetect
2305d791 560
1ef27ea1
JB
561%{__make} \
562 V=1
9fc4ad22 563
b8c60172
ER
564# CC_O to add -c to commandline. makefile should be patched
565%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
566
39711f7c
AM
567%{?with_tests:%{__make} check V=1}
568
9fc4ad22
AM
569%install
570rm -rf $RPM_BUILD_ROOT
38cf6de3 571install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
d2c2eb42 572 $RPM_BUILD_ROOT%{_includedir}/ffmpeg
9fc4ad22 573
a831ce58 574%{__make} install install-headers \
1ef27ea1
JB
575 DESTDIR=$RPM_BUILD_ROOT \
576 V=1
539b540f 577
a831ce58 578# install nonstandard, non-public headers manually
544421b2 579cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
80428ade 580for a in libavutil/*/{asm,bswap}.h; do
a831ce58 581 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 582done
9d4f8977 583cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
544421b2 584
b8c60172 585install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 586
2b2445b7
ER
587# install as ffmpeg-avconfig to avoid with possible programs looking for
588# ffmpeg-config and expecting --libs output from it which is not implemented
589# simple to do (by querying pkgconfig), but why?
b8c60172 590install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 591
a6755e78 592# packaged as %doc in -doc
eaa9ad7b 593%if %{with doc}
a6755e78 594%{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
eaa9ad7b 595%endif
a6755e78
JB
596
597install -d $RPM_BUILD_ROOT%{_examplesdir}
598%{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
599
9fc4ad22
AM
600%clean
601rm -rf $RPM_BUILD_ROOT
602
1ef27ea1
JB
603%post libs -p /sbin/ldconfig
604%postun libs -p /sbin/ldconfig
539b540f 605
9fc4ad22
AM
606%files
607%defattr(644,root,root,755)
479e9af6 608%doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
2a60eebe 609%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 610%attr(755,root,root) %{_bindir}/ffprobe
b7313442 611%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
612%dir %{_datadir}/ffmpeg
613%{_datadir}/ffmpeg/*.ffpreset
714dcf83 614%{_datadir}/ffmpeg/ffprobe.xsd
28673856
JB
615%if %{with doc}
616%{_mandir}/man1/ffmpeg.1*
22745365 617%{_mandir}/man1/ffmpeg-all.1*
28673856
JB
618%{_mandir}/man1/ffmpeg-bitstream-filters.1*
619%{_mandir}/man1/ffmpeg-codecs.1*
620%{_mandir}/man1/ffmpeg-devices.1*
621%{_mandir}/man1/ffmpeg-filters.1*
622%{_mandir}/man1/ffmpeg-formats.1*
623%{_mandir}/man1/ffmpeg-protocols.1*
624%{_mandir}/man1/ffmpeg-resampler.1*
625%{_mandir}/man1/ffmpeg-scaler.1*
626%{_mandir}/man1/ffmpeg-utils.1*
627%{_mandir}/man1/ffprobe.1*
22745365 628%{_mandir}/man1/ffprobe-all.1*
28673856 629%endif
54ec280e
PG
630
631%files libs
632%defattr(644,root,root,755)
f50f7d7c 633%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
d2c2eb42 634%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
d0a0ec26 635%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
d2c2eb42 636%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
314ef0df 637%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
d2c2eb42 638%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
f50f7d7c 639%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
d2c2eb42 640%attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
5663f846 641%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
d2c2eb42 642%attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
f50f7d7c 643%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
d2c2eb42 644%attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
d7493de8 645%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
d2c2eb42 646%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
660918c5 647%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
d2c2eb42 648%attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
ee032235 649%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
d2c2eb42 650%attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
314ef0df 651
539b540f
JB
652%files devel
653%defattr(644,root,root,755)
54ec280e 654%doc doc/optimization.txt
1ef27ea1 655%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 656%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 657%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 658%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 659%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 660%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 661%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 662%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 663%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 664%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 665%{_includedir}/ffmpeg
6382c99d
AM
666%{_includedir}/libavcodec
667%{_includedir}/libavdevice
314ef0df 668%{_includedir}/libavfilter
6382c99d 669%{_includedir}/libavformat
5663f846 670%{_includedir}/libavresample
6382c99d
AM
671%{_includedir}/libavutil
672%{_includedir}/libpostproc
660918c5 673%{_includedir}/libswresample
6382c99d 674%{_includedir}/libswscale
1ef27ea1
JB
675%{_pkgconfigdir}/libavcodec.pc
676%{_pkgconfigdir}/libavdevice.pc
677%{_pkgconfigdir}/libavfilter.pc
678%{_pkgconfigdir}/libavformat.pc
5663f846 679%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
680%{_pkgconfigdir}/libavutil.pc
681%{_pkgconfigdir}/libpostproc.pc
660918c5 682%{_pkgconfigdir}/libswresample.pc
1ef27ea1 683%{_pkgconfigdir}/libswscale.pc
28673856
JB
684%if %{with doc}
685%{_mandir}/man3/libavcodec.3*
686%{_mandir}/man3/libavdevice.3*
687%{_mandir}/man3/libavfilter.3*
688%{_mandir}/man3/libavformat.3*
689%{_mandir}/man3/libavutil.3*
690%{_mandir}/man3/libswresample.3*
691%{_mandir}/man3/libswscale.3*
692%endif
a6755e78 693%{_examplesdir}/%{name}-%{version}
539b540f 694
9cf4d8a4
JB
695%files static
696%defattr(644,root,root,755)
1ef27ea1
JB
697%{_libdir}/libavcodec.a
698%{_libdir}/libavdevice.a
699%{_libdir}/libavfilter.a
700%{_libdir}/libavformat.a
5663f846 701%{_libdir}/libavresample.a
1ef27ea1
JB
702%{_libdir}/libavutil.a
703%{_libdir}/libpostproc.a
660918c5 704%{_libdir}/libswresample.a
1ef27ea1 705%{_libdir}/libswscale.a
af49d6ab
JB
706
707%files ffplay
708%defattr(644,root,root,755)
709%attr(755,root,root) %{_bindir}/ffplay
22745365
JB
710%if %{with doc}
711%{_mandir}/man1/ffplay.1*
712%{_mandir}/man1/ffplay-all.1*
713%endif
af49d6ab 714
4b05ede1
ER
715%if %{with doc}
716%files doc
717%defattr(644,root,root,755)
718%doc doc/*.html
719%endif
This page took 0.322009 seconds and 4 git commands to generate.