]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
up to 4.0.2
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
44f5d561
JB
1# TODO:
2# - libvmaf [BR: libvmaf.pc, libvmaf, libvmaf.h]
3# - libndi_newtek[nonfree, BR: Processing.NDI.Lib.h]
4# - libmysofa [BR: libmysofa, mysofa.h]
5# - rkmpp[GPLv3, BR: rockchip_mpp.pc, rockchip/rk_mpi_cmd.h, libdrm]
197f4211 6#
d0745ce6 7# How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
29c7bf5c 8# 1. make-request -r --with bootstrap ffmpeg.spec
d0745ce6
JR
9# 2 bump release of opencv.spec and chromaprint.spec
10# 3. make-request -r opencv.spec chromaprint.spec
11# 4. bump release of ffmpeg.spec
12# 5. make-request -r ffmpeg.spec
192f9f57 13#
2b3b2117 14# Conditional build:
29c7bf5c 15%bcond_with bootstrap # disable features to able to build without installed ffmpeg
44f5d561 16%bcond_with nonfree # unblock non free options of package (currently: cuda_sdk, decklib, fdk_aac, libndi_newtek, npp, openssl)
4474c07d 17%bcond_without bs2b # BS2B audio filter support
1c1d1368 18%bcond_without caca # textual display using libcaca
0fdde3cc 19%bcond_without chromaprint # audio fingerprinting with chromaprint
44f5d561
JB
20%bcond_without cuda # NVIDIA CUDA code
21%bcond_with cudasdk # NVIDIA CUDA code using SDK [BR: cuda.h, non-free]
7003e3a3
JB
22%bcond_with cuvid # NVIDIA CUVID support
23%bcond_with decklink # Blackmagic DeskLink output support (requires nonfree)
24%bcond_with fdk_aac # AAC de/encoding via libfdk_aac (requires nonfree)
a584ded4
JB
25%bcond_without flite # flite voice synthesis support
26%bcond_without frei0r # frei0r video filtering
4474c07d 27%bcond_without fribidi # fribidi support
22745365 28%bcond_without gme # Game Music Emu support
cbeed0a5 29%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
7160e157 30%bcond_without kvazaar # Kvazaar HEVC encoder support
5f3dc7d9 31%bcond_without ladspa # LADSPA audio filtering
44f5d561
JB
32%bcond_with libdrm # Linux Direct Rendering Manager code
33%bcond_with librsvg # SVG rasterization via librsvg
34%bcond_with libxml2 # XML parsing using libxml2
0258feb8 35%bcond_with mfx # MFX hardware acceleration support
7003e3a3
JB
36%bcond_with npp # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
37%bcond_with nvenc # NVIDIA NVENC support
38%bcond_without omx # OpenMAX IL support
a584ded4 39%bcond_without openal # OpenAL 1.1 capture support
6513d7e3 40%bcond_without opencl # OpenCL 1.2 code
a584ded4 41%bcond_without opencv # OpenCV video filtering
0258feb8
JB
42%bcond_without opengl # OpenGL rendering support
43%bcond_with openh264 # OpenH264 H.264 encoder
6dfc7c2a 44%bcond_without openmpt # OpenMPT module decoder
a584ded4 45%bcond_without pulseaudio # PulseAudio input support
0fdde3cc 46%bcond_without rubberband # rubberband filter
f56b6dce 47%bcond_without shine # shine fixed-point MP3 encoder
7160e157 48%bcond_without snappy # Snappy compression support (needed for hap encoding)
0258feb8 49%bcond_without ssh # SFTP protocol support via libssh
4474c07d 50%bcond_with smb # SMB support via libsmbclient
05408820 51%bcond_without soxr # SoX Resampler support
e5c1d36e 52%bcond_with tesseract # OCR filter based on Tesseract
8b9d2787 53%bcond_without x264 # H.264 x264 encoder
90ab353a 54%bcond_without x265 # H.265/HEVC x265 encoder
1ef27ea1 55%bcond_without va # VAAPI (Video Acceleration API)
f56b6dce 56%bcond_without vidstab # vid.stab video stabilization support
1ef27ea1 57%bcond_without vpx # VP8, a high-quality video codec
22745365 58%bcond_without wavpack # wavpack encoding support
8b9d2787 59%bcond_without webp # WebP encoding support
e5c1d36e 60%bcond_without zimg # zscale filter based on z.lib
6a6b11be 61%bcond_without zmq # 0MQ message passing
5f3dc7d9 62%bcond_without zvbi # teletext via libzvbi
1ef27ea1 63%bcond_without doc # don't build docs
560d82ce 64%bcond_with tests # "make check" (some tests fail as of 2.5)
314ef0df 65
29c7bf5c
ER
66%if %{with bootstrap}
67%undefine with_opencv
d0745ce6 68%undefine with_chromaprint
29c7bf5c
ER
69%endif
70
7003e3a3 71%ifnarch %{ix86} %{x8664} %{arm}
a6755e78
JB
72%undefine with_x265
73%endif
74%ifarch i386 i486
75%undefine with_x265
76%endif
cbdd2688
JB
77Summary: FFmpeg - a very fast video and audio converter
78Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 79Name: ffmpeg
061a584a 80Version: 4.0.2
81ffd9b6 81Release: 1
9cf4d8a4 82# LGPL or GPL, chosen at configure time (GPL version is more featured)
1913be3c 83# (postprocessing, some filters, x264, x265, xavs, xvid, xcbgrab)
38cefaee 84# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 85License: GPL v3+ with LGPL v3+ parts
fde29260 86Group: Applications/Multimedia
ad057c0a 87Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
061a584a 88# Source0-md5: ae0bfdf809306a212b4f0e6eb8d1c75e
7003e3a3 89Patch0: %{name}-omx-libnames.patch
85f7cea1 90URL: http://www.ffmpeg.org/
1cfb9896 91%{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.6.1}
28673856 92%{?with_openal:BuildRequires: OpenAL-devel >= 1.1}
6a6b11be 93%{?with_opencl:BuildRequires: OpenCL-devel >= 1.2}
8b9d2787 94%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
7003e3a3
JB
95# libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
96%{?with_omx:BuildRequires: OpenMAX-IL-devel}
97BuildRequires: SDL2-devel >= 2.0.1
44f5d561 98BuildRequires: SDL2-devel < 2.1.0
cbdd2688 99BuildRequires: alsa-lib-devel
38cefaee 100BuildRequires: bzip2-devel
9f9ba8ac 101BuildRequires: celt-devel >= 0.11.0
004e5628 102%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 103%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 104BuildRequires: fontconfig-devel
0aad4bf2 105BuildRequires: freetype-devel
d7a39558 106%{?with_frei0r:BuildRequires: frei0r-devel}
4474c07d 107%{?with_fribidi:BuildRequires: fribidi-devel}
22745365 108%{?with_gme:BuildRequires: game-music-emu-devel}
4bee03f0
JB
109%ifarch ppc
110# require version with altivec support fixed
111BuildRequires: gcc >= 5:3.3.2-3
112%endif
fecf9f23 113BuildRequires: gmp-devel
d5aef92e 114BuildRequires: gnutls-devel
cbdd2688 115BuildRequires: jack-audio-connection-kit-devel
bd64dc4c 116%{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.8.1}
5f3dc7d9 117%{?with_ladspa:BuildRequires: ladspa-devel}
cbdd2688 118BuildRequires: lame-libs-devel >= 3.98.3
d5aef92e 119BuildRequires: libass-devel
1c1d1368 120BuildRequires: libavc1394-devel
4474c07d 121%{?with_bs2b:BuildRequires: libbs2b-devel}
3dcb8642 122BuildRequires: libbluray-devel
1c1d1368 123%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 124BuildRequires: libcdio-paranoia-devel >= 0.90-2
0fdde3cc 125%{?with_chromaprint:BuildRequires: libchromaprint-devel}
9c4296c2 126BuildRequires: libdc1394-devel >= 2
44f5d561 127%{?with_libdrm:BuildRequires: libdrm-devel}
f1669449 128BuildRequires: libgsm-devel
1c1d1368 129BuildRequires: libiec61883-devel
d5aef92e 130BuildRequires: libmodplug-devel
6dfc7c2a 131%{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.2.6557}
7571bfa0 132BuildRequires: libraw1394-devel >= 2
44f5d561 133%{?with_librsvg:BuildRequires: librsvg-devel >= 2}
cbdd2688 134BuildRequires: librtmp-devel
5f3dc7d9 135%{?with_ssh:BuildRequires: libssh-devel}
4474c07d 136%{?with_smb:BuildRequires: libsmbclient-devel}
9042663c 137BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 138BuildRequires: libtool >= 2:1.4d-3
daf9a670 139BuildRequires: libv4l-devel
7003e3a3
JB
140%if %{with va}
141BuildRequires: libva-devel >= 1.0.3
142BuildRequires: libva-drm-devel >= 1.0.3
143BuildRequires: libva-x11-devel >= 1.0.3
144%endif
9c4296c2 145BuildRequires: libvdpau-devel >= 0.2
e380e18a 146BuildRequires: libvorbis-devel
1be5865c 147%{?with_vpx:BuildRequires: libvpx-devel >= 1.3.0}
fecf9f23 148%{?with_webp:BuildRequires: libwebp-devel >= 0.4.0}
660918c5
AM
149# X264_BUILD >= 118
150%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
44f5d561
JB
151# X265_BUILD >= 68
152%{?with_x265:BuildRequires: libx265-devel >= 1.8}
560d82ce 153# libxcb xcb-shm xcb-xfixes xcb-shape
0258feb8 154BuildRequires: libxcb-devel >= 1.4
44f5d561 155%{?with_libxml2:BuildRequires: libxml2-devel >= 2}
0258feb8 156%{?with_mfx:BuildRequires: mfx_dispatch-devel}
e1fe03f7 157%ifarch %{ix86}
158%ifnarch i386 i486
76243dbd
JB
159BuildRequires: nasm
160%endif
e1fe03f7 161%endif
0258feb8 162# which package?
7003e3a3 163#%{?with_nvenc:BuildRequires: NVIDIA-NVENC-API} compat/nvenc/nvEncodeAPI.h
1c1d1368
JB
164BuildRequires: opencore-amr-devel
165%{?with_opencv:BuildRequires: opencv-devel}
62da4e00 166%{?with_openh264:BuildRequires: openh264-devel >= 1.3}
7003e3a3 167BuildRequires: openjpeg2-devel >= 2.1
1c1d1368 168BuildRequires: opus-devel
136f0f45 169BuildRequires: perl-Encode
1463656a 170BuildRequires: perl-tools-pod
ef3c0513 171BuildRequires: pkgconfig
1c1d1368 172%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 173BuildRequires: rpmbuild(macros) >= 1.470
0fdde3cc 174%{?with_rubberband:BuildRequires: rubberband-devel >= 1.8.1}
4a11c99e 175%{?with_shine:BuildRequires: shine-devel >= 3.0.0}
7160e157 176%{?with_snappy:BuildRequires: snappy-devel}
05408820 177%{?with_soxr:BuildRequires: soxr-devel}
1c1d1368 178BuildRequires: speex-devel >= 1:1.2-rc1
e5c1d36e 179%{?with_tesseract:BuildRequires: tesseract-devel}
64f8f109
ER
180%{?with_doc:BuildRequires: tetex}
181%{?with_doc:BuildRequires: texi2html}
182%{?with_doc:BuildRequires: texinfo}
1c1d1368 183BuildRequires: twolame-devel
9befe454 184%{?with_vidstab:BuildRequires: vid.stab-devel >= 0.98}
5dc039cb 185BuildRequires: vo-amrwbenc-devel
22745365 186%{?with_wavpack:BuildRequires: wavpack-devel}
cbeed0a5 187%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 188BuildRequires: xavs-devel
28673856 189BuildRequires: xorg-lib-libX11-devel
cbdd2688
JB
190BuildRequires: xorg-lib-libXext-devel
191BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 192BuildRequires: xvid-devel >= 1:1.1.0
7003e3a3 193BuildRequires: xz-devel
cbeed0a5 194BuildRequires: yasm
6a6b11be 195%{?with_zmq:BuildRequires: zeromq-devel}
d2c2eb42 196%{?with_zimg:BuildRequires: zimg-devel >= 2.7.0}
33a1c0f3 197BuildRequires: zlib-devel
e5c1d36e 198%{?with_zvbi:BuildRequires: zvbi-devel}
57ebb8ad 199%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
200# overflows maximum hash table size
201BuildConflicts: pdksh < 5.2.14-57
54ec280e 202Requires: %{name}-libs = %{version}-%{release}
92a3edff 203%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 204Requires: xvid >= 1:1.1.0
af49d6ab 205Obsoletes: libpostproc
539b540f 206BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 207
c01d7857
PS
208%define specflags -fno-strict-aliasing
209
210# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
211%define specflags_ia32 -fomit-frame-pointer
212# -mmmx is needed to enable <mmintrin.h> code.
213%define specflags_i586 -mmmx
214%define specflags_i686 -mmmx
1162803a 215%define specflags_ppc -fPIC
c01d7857 216
9fc4ad22 217%description
85f7cea1
ER
218FFmpeg is a complete solution to record, convert and stream audio and
219video. It is a command line tool to convert one video file format to
220another. It also supports grabbing and encoding in real time from a TV
221card.
9fc4ad22 222
cdb7b42e 223%description -l pl.UTF-8
cbdd2688
JB
224FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
225strumieni dźwięku i obrazu. Jest to działające z linii poleceń
226narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
227także przechwytywanie i kodowanie w czasie rzeczywistym z karty
228telewizyjnej.
9fc4ad22 229
54ec280e
PG
230%package libs
231Summary: ffmpeg libraries
adcc0f76 232Summary(pl.UTF-8): Biblioteki ffmpeg
1be5865c 233Group: Libraries
7003e3a3 234Requires: SDL2 >= 2.0.1
143c6eec
JB
235%if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
236# uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
f9cce0c9 237Requires: gnutls-libs >= 3.0.20
143c6eec 238%endif
6dfc7c2a 239%{?with_openmpt:Requires: libopenmpt >= 0.2.6557}
1be5865c 240%{?with_vpx:Requires: libvpx >= 1.3.0}
0fdde3cc 241%{?with_rubberband:Requires: rubberband-libs >= 1.8.1}
80c0841f 242%{?with_zimg:Requires: zimg >= 2.7.0}
54ec280e
PG
243
244%description libs
cbdd2688
JB
245This package contains the ffmpeg shared libraries:
246- the codec library (libavcodec). It supports most existing encoding
247 formats (MPEG, DivX, MPEG4, AC3, DV...),
248- demuxer library (libavformat). It supports most existing file
249 formats (AVI, MPEG, OGG, Matroska, ASF...),
250- video postprocessing library (libpostproc).
54ec280e 251
cdb7b42e 252%description libs -l pl.UTF-8
cbdd2688
JB
253Ten pakiet zawiera biblioteki współdzielone ffmpeg:
254- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
255 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
256- bibliotekę demuksera (libavformat); obsługuje większość istniejących
257 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
258- bibliotekę postprocessingu (libpostproc).
54ec280e 259
af49d6ab
JB
260%package devel
261Summary: ffmpeg header files
adcc0f76 262Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 263Group: Development/Libraries
54ec280e 264Requires: %{name}-libs = %{version}-%{release}
38cefaee 265# Libs.private from *.pc (unreasonably they are all the same)
6a6b11be 266%{?with_opencl:Requires: OpenCL-devel >= 1.2}
f6f5022a 267%{?with_opengl:Requires: OpenGL-devel}
7003e3a3 268Requires: SDL2-devel >= 2.0.1
38cefaee
JB
269Requires: alsa-lib-devel
270Requires: bzip2-devel
9c4296c2 271Requires: celt-devel >= 0.11.0
004e5628 272%{?with_fdk_aac:Requires: fdk-aac-devel}
4b05ede1 273%{?with_flite:Requires: flite-devel >= 1.4}
3dcb8642 274Requires: fontconfig-devel
0aad4bf2 275Requires: freetype-devel
4474c07d 276%{?with_fribidi:Requires: fribidi-devel}
22745365 277%{?with_gme:Requires: game-music-emu-devel}
38cefaee 278Requires: jack-audio-connection-kit-devel
9e9d5429 279%{?with_kvazaar:Requires: kvazaar-devel >= 0.8.1}
38cefaee 280Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
281Requires: libass-devel
282Requires: libavc1394-devel
3dcb8642 283Requires: libbluray-devel
4474c07d 284%{?with_bs2b:Requires: libbs2b-devel}
28673856 285%{?with_caca:Requires: libcaca-devel}
a09e741c 286Requires: libcdio-paranoia-devel >= 0.90-2
0fdde3cc 287%{?with_chromaprint:Requires: libchromaprint-devel}
9c4296c2 288Requires: libdc1394-devel >= 2
44f5d561 289%{?with_libdrm:Requires: libdrm-devel}
bf479bc6 290Requires: libgsm-devel
1c1d1368
JB
291Requires: libiec61883-devel
292Requires: libmodplug-devel
6dfc7c2a 293%{?with_openmpt:Requires: libopenmpt-devel >= 0.2.6557}
7571bfa0 294Requires: libraw1394-devel >= 2
44f5d561 295%{?with_librsvg:Requires: librsvg-devel >= 2}
38cefaee 296Requires: librtmp-devel
4474c07d 297%{?with_smb:Requires: libsmbclient-devel}
38cefaee
JB
298Requires: libtheora-devel >= 1.0-0.beta3
299%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 300Requires: libvorbis-devel
1be5865c 301%{?with_vpx:Requires: libvpx-devel >= 1.3.0}
fecf9f23 302%{?with_webp:Requires: libwebp-devel >= 0.4.0}
ea09f25d 303%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
44f5d561
JB
304%{?with_x265:Requires: libx265-devel >= 1.8}
305%{?with_libxml2:Requires: libxml2-devel >= 2}
0258feb8 306%{?with_mfx:Requires: mfx_dispatch-devel}
38cefaee 307Requires: opencore-amr-devel
fc1d9619 308%{?with_opencv:Requires: opencv-devel}
62da4e00 309%{?with_openh264:Requires: openh264-devel >= 1.3}
7003e3a3 310Requires: openjpeg2-devel >= 2.1
0fdde3cc 311%{?with_rubberband:Requires: rubberband-devel >= 1.8.1}
4a11c99e 312%{?with_shine:Requires: shine-devel >= 3.0.0}
7160e157 313%{?with_snappy:Requires: snappy-devel}
05408820 314%{?with_soxr:Requires: soxr-devel}
38cefaee 315Requires: speex-devel >= 1:1.2-rc1
e5c1d36e 316%{?with_tesseract:Requires: tesseract-devel}
1c1d1368 317Requires: twolame-devel
9befe454 318%{?with_vidstab:Requires: vid.stab-devel >= 0.98}
38cefaee 319Requires: vo-amrwbenc-devel
22745365 320%{?with_wavpack:Requires: wavpack-devel}
cbeed0a5 321%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
322Requires: xavs-devel
323Requires: xorg-lib-libXext-devel
324Requires: xorg-lib-libXfixes-devel
46f2a56b 325Requires: xvid-devel >= 1:1.1.0
6a6b11be 326%{?with_zmq:Requires: zeromq-devel}
1913be3c 327%{?with_zimg:Requires: zimg-devel >= 2.3.0}
33a1c0f3 328Requires: zlib-devel
8152d6a2 329Obsoletes: libpostproc-devel
af49d6ab
JB
330
331%description devel
332ffmpeg header files.
333
cdb7b42e
JR
334%description devel -l pl.UTF-8
335Pliki nagłówkowe ffmpeg.
af49d6ab
JB
336
337%package static
338Summary: ffmpeg static libraries
adcc0f76 339Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
340Group: Development/Libraries
341Requires: %{name}-devel = %{version}-%{release}
342
343%description static
344ffmpeg static libraries (libavcodec and libavformat).
345
cdb7b42e 346%description static -l pl.UTF-8
af49d6ab
JB
347Statyczne biblioteki ffmpeg (libavcodec i libavformat).
348
2a60eebe
JB
349%package ffplay
350Summary: FFplay - SDL-based media player
adcc0f76 351Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 352Group: Applications/Multimedia
54ec280e 353Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
354
355%description ffplay
356FFplay is a very simple and portable media player using the FFmpeg
357libraries and the SDL library. It is mostly used as a test bench for
358the various APIs of FFmpeg.
359
cdb7b42e
JR
360%description ffplay -l pl.UTF-8
361FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
362bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
363testowania różnych API FFmpeg.
2a60eebe 364
4b05ede1 365%package doc
143c6eec
JB
366Summary: FFmpeg documentation in HTML format
367Summary(pl.UTF-8): Dokumentacja pakietu FFmpeg w formacie HTML
4b05ede1
ER
368Group: Documentation
369%if "%{_rpmversion}" >= "5"
370BuildArch: noarch
371%endif
372
373%description doc
143c6eec 374FFmpeg documentation in HTML format.
4b05ede1
ER
375
376%description doc -l pl.UTF-8
143c6eec 377Dokumentacja pakietu FFmpeg w formacie HTML.
4b05ede1 378
9fc4ad22 379%prep
aed8e8c9 380%setup -q
7003e3a3 381%patch0 -p1
9fc4ad22 382
9d4f8977
ER
383# package the grep result for mplayer, the result formatted as ./mplayer/configure
384cat <<EOF > ffmpeg-avconfig
2b2445b7 385#! /bin/sh
16803cdb
ER
386libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
387libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
388libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
389libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
390libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
391libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
392libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
393libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
394libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
2b2445b7 395EOF
9d4f8977 396cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
397
398case "$1" in
399--decoders)
16803cdb 400 echo $libavdecoders_all
2b2445b7
ER
401 ;;
402--encoders)
16803cdb 403 echo $libavencoders_all
2b2445b7
ER
404 ;;
405--parsers)
16803cdb 406 echo $libavparsers_all
2b2445b7
ER
407 ;;
408--bsfs)
16803cdb 409 echo $libavbsfs_all
2b2445b7
ER
410 ;;
411--demuxers)
16803cdb 412 echo $libavdemuxers_all
2b2445b7
ER
413 ;;
414--muxers)
16803cdb 415 echo $libavmuxers_all
2b2445b7
ER
416 ;;
417--protocols)
16803cdb
ER
418 echo $libavprotocols_all
419 ;;
420--hwaccels)
421 echo $libavhwaccels_all
422 ;;
423--filters)
424 echo $libavfilters_all
2b2445b7
ER
425 ;;
426*)
427 cat <<USAGE
428Usage: $0 [OPTION]
429Options:
430 --decoders
431 --encoders
432 --parsers
433 --bsfs
434 --demuxers
435 --muxers
436 --protocols
16803cdb
ER
437 --hwaccels
438 --filters
2b2445b7
ER
439USAGE
440 exit 1;;
441esac
442
443exit 0
444EOF
445
9fc4ad22 446%build
05e1eb2f
JB
447# notes:
448# - it's not autoconf configure
d0a0ec26 449# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 450./configure \
b4680d0b 451 --arch=%{_target_base_arch} \
539b540f 452 --prefix=%{_prefix} \
9cf4d8a4 453 --libdir=%{_libdir} \
d81dfa95 454 --shlibdir=%{_libdir} \
2a60eebe 455 --mandir=%{_mandir} \
f6f5022a 456 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
1162803a 457 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 458 --cc="%{__cc}" \
126fb805
JB
459 --disable-debug \
460 --disable-optimizations \
6382c99d 461 --disable-stripping \
eaa9ad7b 462 %{!?with_doc:--disable-doc} \
314ef0df 463 --enable-avfilter \
0797daec 464 --enable-avresample \
0fdde3cc 465 %{?with_chromaprint:--enable-chromaprint} \
7003e3a3 466 %{!?with_cuda:--disable-cuda} \
44f5d561 467 %{?with_cudasdk:--enable-cuda-sdk} \
7003e3a3 468 %{!?with_cuvid:--disable-cuvid} \
f6f5022a 469 %{?with_decklink:--enable-decklink} \
d5aef92e 470 --enable-gnutls \
126fb805 471 --enable-gpl \
0b43f655 472 --enable-version3 \
d7a39558 473 %{?with_frei0r:--enable-frei0r} \
5f3dc7d9 474 %{?with_ladspa:--enable-ladspa} \
d5aef92e 475 --enable-libass \
3dcb8642 476 --enable-libbluray \
4474c07d 477 %{?with_bs2b:--enable-libbs2b} \
2362253d 478 %{?with_caca:--enable-libcaca} \
cbdd2688 479 --enable-libcelt \
d5aef92e
JB
480 --enable-libcdio \
481 --enable-libdc1394 \
44f5d561 482 %{?with_libdrm:--enable-libdrm} \
1c1d1368 483 %{?with_flite:--enable-libflite} \
7003e3a3 484 --enable-libfontconfig \
3dcb8642 485 --enable-libfreetype \
4474c07d 486 %{?with_fribidi:--enable-libfribidi} \
22745365 487 %{?with_gme:--enable-libgme} \
f3692243 488 --enable-libgsm \
1c1d1368 489 --enable-libiec61883 \
004e5628 490 %{?with_ilbc:--enable-libilbc} \
7160e157 491 %{?with_kvazaar:--enable-libkvazaar} \
0258feb8 492 %{?with_mfx:--enable-libmfx} \
d5aef92e 493 --enable-libmodplug \
15c15700 494 --enable-libmp3lame \
cbdd2688
JB
495 --enable-libopencore-amrnb \
496 --enable-libopencore-amrwb \
192f9f57 497 %{?with_opencv:--enable-libopencv} \
0258feb8 498 %{?with_openh264:--enable-libopenh264} \
cbdd2688 499 --enable-libopenjpeg \
6dfc7c2a 500 %{?with_openmpt:--enable-libopenmpt} \
1c1d1368 501 --enable-libopus \
d5aef92e 502 %{?with_pulseaudio:--enable-libpulse} \
44f5d561 503 %{?with_librsvg:--enable-librsvg} \
cbdd2688 504 --enable-librtmp \
44f5d561 505 %{?with_libxml2:--enable-libxml2} \
0fdde3cc 506 %{?with_rubberband:--enable-librubberband} \
f56b6dce 507 %{?with_shine:--enable-libshine} \
4474c07d 508 %{?with_smb:--enable-libsmbclient} \
7160e157 509 %{?with_snappy:--enable-libsnappy} \
05408820 510 %{?with_soxr:--enable-libsoxr} \
da99dcf2 511 --enable-libspeex \
5f3dc7d9 512 %{?with_ssh:--enable-libssh} \
e5c1d36e 513 %{?with_tesseract:--enable-libtesseract} \
126fb805 514 --enable-libtheora \
1c1d1368 515 --enable-libtwolame \
d5aef92e 516 --enable-libv4l2 \
f56b6dce 517 %{?with_vidstab:--enable-libvidstab} \
5dc039cb 518 --enable-libvo-amrwbenc \
126fb805 519 --enable-libvorbis \
64f8f109 520 %{?with_vpx:--enable-libvpx} \
22745365 521 %{?with_wavpack:--enable-libwavpack} \
8b9d2787 522 %{?with_webp:--enable-libwebp} \
ea09f25d 523 %{?with_x264:--enable-libx264} \
90ab353a 524 %{?with_x265:--enable-libx265} \
5dc039cb 525 --enable-libxavs \
9e9d5429 526 --enable-libxcb \
126fb805 527 --enable-libxvid \
e5c1d36e 528 %{?with_zimg:--enable-libzimg} \
6a6b11be 529 %{?with_zmq:--enable-libzmq} \
5f3dc7d9 530 %{?with_zvbi:--enable-libzvbi} \
7003e3a3
JB
531 %{!?with_nvenc:--disable-nvenc} \
532 %{?with_omx:--enable-omx} \
d5aef92e 533 %{?with_openal:--enable-openal} \
f56b6dce 534 %{?with_opencl:--enable-opencl} \
8b9d2787 535 %{?with_opengl:--enable-opengl} \
6382c99d 536 --enable-postproc \
d7493de8 537 --enable-pthreads \
9cf4d8a4 538 --enable-shared \
6382c99d 539 --enable-swscale \
22745365 540 %{!?with_va:--disable-vaapi} \
7a286645 541%ifnarch %{ix86} %{x8664}
e1fe03f7 542 --disable-mmx \
543%endif
544%ifarch i386 i486
05e1eb2f 545 --disable-mmx \
b524cd99 546%endif
61f81a23
JR
547%ifarch x32
548 --disable-asm \
549%endif
0b43f655 550%if %{with nonfree}
48610c64 551 --enable-nonfree \
c8f42fb1 552 %{?with_fdk_aac:--enable-libfdk-aac} \
7003e3a3 553 %{?with_npp:--enable-libnpp} \
76243dbd 554%endif
75231f25 555 --enable-runtime-cpudetect
2305d791 556
1ef27ea1
JB
557%{__make} \
558 V=1
9fc4ad22 559
b8c60172
ER
560# CC_O to add -c to commandline. makefile should be patched
561%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
562
39711f7c
AM
563%{?with_tests:%{__make} check V=1}
564
9fc4ad22
AM
565%install
566rm -rf $RPM_BUILD_ROOT
38cf6de3 567install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
d2c2eb42 568 $RPM_BUILD_ROOT%{_includedir}/ffmpeg
9fc4ad22 569
a831ce58 570%{__make} install install-headers \
1ef27ea1
JB
571 DESTDIR=$RPM_BUILD_ROOT \
572 V=1
539b540f 573
a831ce58 574# install nonstandard, non-public headers manually
544421b2 575cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
80428ade 576for a in libavutil/*/{asm,bswap}.h; do
a831ce58 577 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 578done
9d4f8977 579cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
544421b2 580
b8c60172 581install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 582
2b2445b7
ER
583# install as ffmpeg-avconfig to avoid with possible programs looking for
584# ffmpeg-config and expecting --libs output from it which is not implemented
585# simple to do (by querying pkgconfig), but why?
b8c60172 586install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 587
a6755e78 588# packaged as %doc in -doc
eaa9ad7b 589%if %{with doc}
a6755e78 590%{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
eaa9ad7b 591%endif
a6755e78
JB
592
593install -d $RPM_BUILD_ROOT%{_examplesdir}
594%{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
595
9fc4ad22
AM
596%clean
597rm -rf $RPM_BUILD_ROOT
598
1ef27ea1
JB
599%post libs -p /sbin/ldconfig
600%postun libs -p /sbin/ldconfig
539b540f 601
9fc4ad22
AM
602%files
603%defattr(644,root,root,755)
479e9af6 604%doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
2a60eebe 605%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 606%attr(755,root,root) %{_bindir}/ffprobe
b7313442 607%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
608%dir %{_datadir}/ffmpeg
609%{_datadir}/ffmpeg/*.ffpreset
714dcf83 610%{_datadir}/ffmpeg/ffprobe.xsd
28673856
JB
611%if %{with doc}
612%{_mandir}/man1/ffmpeg.1*
22745365 613%{_mandir}/man1/ffmpeg-all.1*
28673856
JB
614%{_mandir}/man1/ffmpeg-bitstream-filters.1*
615%{_mandir}/man1/ffmpeg-codecs.1*
616%{_mandir}/man1/ffmpeg-devices.1*
617%{_mandir}/man1/ffmpeg-filters.1*
618%{_mandir}/man1/ffmpeg-formats.1*
619%{_mandir}/man1/ffmpeg-protocols.1*
620%{_mandir}/man1/ffmpeg-resampler.1*
621%{_mandir}/man1/ffmpeg-scaler.1*
622%{_mandir}/man1/ffmpeg-utils.1*
623%{_mandir}/man1/ffprobe.1*
22745365 624%{_mandir}/man1/ffprobe-all.1*
28673856 625%endif
54ec280e
PG
626
627%files libs
628%defattr(644,root,root,755)
f50f7d7c 629%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
d2c2eb42 630%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
d0a0ec26 631%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
d2c2eb42 632%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
314ef0df 633%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
d2c2eb42 634%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
f50f7d7c 635%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
d2c2eb42 636%attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
5663f846 637%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
d2c2eb42 638%attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
f50f7d7c 639%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
d2c2eb42 640%attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
d7493de8 641%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
d2c2eb42 642%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
660918c5 643%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
d2c2eb42 644%attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
ee032235 645%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
d2c2eb42 646%attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
314ef0df 647
539b540f
JB
648%files devel
649%defattr(644,root,root,755)
54ec280e 650%doc doc/optimization.txt
1ef27ea1 651%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 652%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 653%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 654%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 655%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 656%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 657%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 658%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 659%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 660%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 661%{_includedir}/ffmpeg
6382c99d
AM
662%{_includedir}/libavcodec
663%{_includedir}/libavdevice
314ef0df 664%{_includedir}/libavfilter
6382c99d 665%{_includedir}/libavformat
5663f846 666%{_includedir}/libavresample
6382c99d
AM
667%{_includedir}/libavutil
668%{_includedir}/libpostproc
660918c5 669%{_includedir}/libswresample
6382c99d 670%{_includedir}/libswscale
1ef27ea1
JB
671%{_pkgconfigdir}/libavcodec.pc
672%{_pkgconfigdir}/libavdevice.pc
673%{_pkgconfigdir}/libavfilter.pc
674%{_pkgconfigdir}/libavformat.pc
5663f846 675%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
676%{_pkgconfigdir}/libavutil.pc
677%{_pkgconfigdir}/libpostproc.pc
660918c5 678%{_pkgconfigdir}/libswresample.pc
1ef27ea1 679%{_pkgconfigdir}/libswscale.pc
28673856
JB
680%if %{with doc}
681%{_mandir}/man3/libavcodec.3*
682%{_mandir}/man3/libavdevice.3*
683%{_mandir}/man3/libavfilter.3*
684%{_mandir}/man3/libavformat.3*
685%{_mandir}/man3/libavutil.3*
686%{_mandir}/man3/libswresample.3*
687%{_mandir}/man3/libswscale.3*
688%endif
a6755e78 689%{_examplesdir}/%{name}-%{version}
539b540f 690
9cf4d8a4
JB
691%files static
692%defattr(644,root,root,755)
1ef27ea1
JB
693%{_libdir}/libavcodec.a
694%{_libdir}/libavdevice.a
695%{_libdir}/libavfilter.a
696%{_libdir}/libavformat.a
5663f846 697%{_libdir}/libavresample.a
1ef27ea1
JB
698%{_libdir}/libavutil.a
699%{_libdir}/libpostproc.a
660918c5 700%{_libdir}/libswresample.a
1ef27ea1 701%{_libdir}/libswscale.a
af49d6ab
JB
702
703%files ffplay
704%defattr(644,root,root,755)
705%attr(755,root,root) %{_bindir}/ffplay
22745365
JB
706%if %{with doc}
707%{_mandir}/man1/ffplay.1*
708%{_mandir}/man1/ffplay-all.1*
709%endif
af49d6ab 710
4b05ede1
ER
711%if %{with doc}
712%files doc
713%defattr(644,root,root,755)
714%doc doc/*.html
715%endif
This page took 0.196522 seconds and 4 git commands to generate.