]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- updated to 2.4
[packages/ffcall.git] / ffcall.spec
1 Summary:        Libraries for building foreign function call interfaces
2 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
3 Name:           ffcall
4 Version:        2.0
5 Release:        1
6 Epoch:          1
7 License:        GPL v2+
8 Group:          Libraries
9 Source0:        http://ftp.gnu.org/gnu/libffcall/libffcall-%{version}.tar.gz
10 # Source0-md5:  e2e67382752287c5a7c42ac7ae79bfdc
11 Patch0:         %{name}-make-jN.patch
12 URL:            http://savannah.gnu.org/projects/libffcall
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %undefine       __cxx
16
17 %description
18 This is a collection of four libraries which can be used to build
19 foreign function call interfaces in embedded interpreters.
20
21 The four packages are:
22 - avcall - calling C functions with variable arguments
23 - vacall - C functions accepting variable argument prototypes
24 - trampoline - closures as first-class C functions
25 - callback - closures with variable arguments as first-class C
26   functions (a reentrant combination of vacall and trampoline)
27
28 This version B includes some minor configuration changes so that files
29 are installed in the proper place. Also it compiles on cygwin and
30 mingw32.
31
32 %description -l pl.UTF-8
33 To jest zestaw czterech bibliotek, których można użyć do tworzenia
34 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
35
36 Te cztery pakiety to:
37 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
38 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
39 - trampoline - domknięcia jako funkcje C pierwszej klasy
40 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
41   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
42
43 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
44 pliki instalują się we właściwych miejscach. A także kompiluje się pod
45 cygwinem i mingw32.
46
47 %package devel
48 Summary:        Development files for ffcall libraries
49 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
50 Group:          Development/Libraries
51 Requires:       %{name} = %{epoch}:%{version}-%{release}
52
53 %description devel
54 Development files for ffcall libraries: headers and static trampoline
55 and vacall libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki dla programistów używających bibliotek ffcall: nagłówki i
59 statyczne biblioteki trampoline oraz vacall.
60
61 %package static
62 Summary:        Static versions of avcall and callback libraries
63 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
66
67 %description static
68 Static versions of avcall and callback libraries.
69
70 %description static -l pl.UTF-8
71 Statyczne wersje bibliotek avcall i callback.
72
73 %prep
74 %setup -q -n libffcall-%{version}
75 %patch0 -p1
76
77 %build
78 %configure \
79         --enable-shared
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 # don't need those since we have man pages
90 %{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ChangeLog NEWS PLATFORMS README
101 %attr(755,root,root) %{_libdir}/libavcall.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libavcall.so.1
103 %attr(755,root,root) %{_libdir}/libcallback.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libcallback.so.1
105 %attr(755,root,root) %{_libdir}/libffcall.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libffcall.so.0
107 %attr(755,root,root) %{_libdir}/libtrampoline.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libtrampoline.so.1
109
110 %files devel
111 %defattr(644,root,root,755)
112 %doc */*.html
113 %attr(755,root,root) %{_libdir}/libavcall.so
114 %attr(755,root,root) %{_libdir}/libcallback.so
115 %attr(755,root,root) %{_libdir}/libffcall.so
116 %attr(755,root,root) %{_libdir}/libtrampoline.so
117 %{_libdir}/libavcall.la
118 %{_libdir}/libcallback.la
119 %{_libdir}/libffcall.la
120 %{_libdir}/libtrampoline.la
121 %{_libdir}/libvacall.a
122 %{_includedir}/avcall.h
123 %{_includedir}/callback.h
124 %{_includedir}/ffcall-*.h
125 %{_includedir}/trampoline*.h
126 %{_includedir}/vacall*.h
127 %{_mandir}/man3/avcall.3*
128 %{_mandir}/man3/callback.3*
129 %{_mandir}/man3/trampoline*.3*
130 %{_mandir}/man3/vacall.3*
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libavcall.a
135 %{_libdir}/libcallback.a
136 %{_libdir}/libffcall.a
137 %{_libdir}/libtrampoline.a
This page took 0.115398 seconds and 3 git commands to generate.