]> git.pld-linux.org Git - packages/ffcall.git/blame - ffcall.spec
- updated to 2.4
[packages/ffcall.git] / ffcall.spec
CommitLineData
cac2c25e 1Summary: Libraries for building foreign function call interfaces
8445a4fb 2Summary(pl.UTF-8): Biblioteki do tworzenia interfejsów wywołań obcych funkcji
cac2c25e 3Name: ffcall
e76edf17
JB
4Version: 2.4
5Release: 1
cac2c25e 6Epoch: 1
db689769 7License: GPL v2+
cac2c25e 8Group: Libraries
f5a3a324 9Source0: https://ftp.gnu.org/gnu/libffcall/libffcall-%{version}.tar.gz
e76edf17 10# Source0-md5: e7ef6e7cab40f6e224a89cc8dec6fc15
264bd3ff 11Patch0: %{name}-make-jN.patch
561c751d 12URL: http://savannah.gnu.org/projects/libffcall
cac2c25e
JB
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
69522ab0 15%undefine __cxx
16
cac2c25e
JB
17%description
18This is a collection of four libraries which can be used to build
19foreign function call interfaces in embedded interpreters.
20
21The four packages are:
22- avcall - calling C functions with variable arguments
23- vacall - C functions accepting variable argument prototypes
24- trampoline - closures as first-class C functions
25- callback - closures with variable arguments as first-class C
26 functions (a reentrant combination of vacall and trampoline)
27
28This version B includes some minor configuration changes so that files
29are installed in the proper place. Also it compiles on cygwin and
30mingw32.
31
304739ce
JR
32%description -l pl.UTF-8
33To jest zestaw czterech bibliotek, których można użyć do tworzenia
34interfejsów wywołań obcych procedur we wbudowanych interpreterach.
cac2c25e
JB
35
36Te cztery pakiety to:
304739ce
JR
37- avcall - wywoływanie funkcji w C ze zmiennymi argumentami
38- vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
39- trampoline - domknięcia jako funkcje C pierwszej klasy
40- callback - domknięcia ze zmiennymi argumentami jako funkcje C
41 pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
42
43Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
44pliki instalują się we właściwych miejscach. A także kompiluje się pod
cac2c25e
JB
45cygwinem i mingw32.
46
47%package devel
48Summary: Development files for ffcall libraries
8445a4fb 49Summary(pl.UTF-8): Pliki dla programistów używających bibliotek ffcall
cac2c25e 50Group: Development/Libraries
87c4ec88 51Requires: %{name} = %{epoch}:%{version}-%{release}
cac2c25e
JB
52
53%description devel
54Development files for ffcall libraries: headers and static trampoline
55and vacall libraries.
56
304739ce
JR
57%description devel -l pl.UTF-8
58Pliki dla programistów używających bibliotek ffcall: nagłówki i
cac2c25e
JB
59statyczne biblioteki trampoline oraz vacall.
60
61%package static
62Summary: Static versions of avcall and callback libraries
8445a4fb 63Summary(pl.UTF-8): Statyczne wersje bibliotek avcall i callback
cac2c25e 64Group: Development/Libraries
87c4ec88 65Requires: %{name}-devel = %{epoch}:%{version}-%{release}
cac2c25e
JB
66
67%description static
68Static versions of avcall and callback libraries.
69
304739ce 70%description static -l pl.UTF-8
cac2c25e
JB
71Statyczne wersje bibliotek avcall i callback.
72
73%prep
db689769 74%setup -q -n libffcall-%{version}
264bd3ff 75%patch0 -p1
cac2c25e
JB
76
77%build
87c4ec88 78%configure \
cac2c25e
JB
79 --enable-shared
80
264bd3ff 81%{__make}
cac2c25e
JB
82
83%install
84rm -rf $RPM_BUILD_ROOT
cac2c25e
JB
85
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
88
09f961fc
JB
89# for dependency generator and debuginfo extraction to work
90chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
91
f11a7762 92# don't need those since we have man pages
69522ab0 93%{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
f11a7762 94
cac2c25e 95%clean
2ccfaad5 96rm -rf $RPM_BUILD_ROOT
cac2c25e
JB
97
98%post -p /sbin/ldconfig
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(644,root,root,755)
d43a7efd 103%doc ChangeLog NEWS PLATFORMS README
bbb36a01 104%attr(755,root,root) %{_libdir}/libavcall.so.*.*.*
7d826570 105%attr(755,root,root) %ghost %{_libdir}/libavcall.so.1
bbb36a01 106%attr(755,root,root) %{_libdir}/libcallback.so.*.*.*
7d826570
JB
107%attr(755,root,root) %ghost %{_libdir}/libcallback.so.1
108%attr(755,root,root) %{_libdir}/libffcall.so.*.*.*
109%attr(755,root,root) %ghost %{_libdir}/libffcall.so.0
db689769 110%attr(755,root,root) %{_libdir}/libtrampoline.so.*.*.*
7d826570 111%attr(755,root,root) %ghost %{_libdir}/libtrampoline.so.1
cac2c25e
JB
112
113%files devel
114%defattr(644,root,root,755)
87c4ec88 115%doc */*.html
bbb36a01 116%attr(755,root,root) %{_libdir}/libavcall.so
117%attr(755,root,root) %{_libdir}/libcallback.so
7d826570 118%attr(755,root,root) %{_libdir}/libffcall.so
db689769 119%attr(755,root,root) %{_libdir}/libtrampoline.so
bbb36a01 120%{_libdir}/libavcall.la
121%{_libdir}/libcallback.la
7d826570 122%{_libdir}/libffcall.la
db689769 123%{_libdir}/libtrampoline.la
cac2c25e 124%{_libdir}/libvacall.a
d43a7efd
JB
125%{_includedir}/avcall.h
126%{_includedir}/callback.h
7d826570 127%{_includedir}/ffcall-*.h
d43a7efd
JB
128%{_includedir}/trampoline*.h
129%{_includedir}/vacall*.h
130%{_mandir}/man3/avcall.3*
131%{_mandir}/man3/callback.3*
132%{_mandir}/man3/trampoline*.3*
133%{_mandir}/man3/vacall.3*
cac2c25e
JB
134
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libavcall.a
138%{_libdir}/libcallback.a
7d826570 139%{_libdir}/libffcall.a
db689769 140%{_libdir}/libtrampoline.a
This page took 0.074255 seconds and 4 git commands to generate.