]> git.pld-linux.org Git - packages/fetchpop.git/commitdiff
*** empty log message *** PATCH
authorkura <kura@pld-linux.org>
Tue, 26 Jan 1999 18:46:08 +0000 (18:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fetchpop-fetch.patch -> 1.1
    fetchpop-make.patch -> 1.1
    fetchpop-pop.patch -> 1.1

fetchpop-fetch.patch [new file with mode: 0644]
fetchpop-make.patch [new file with mode: 0644]
fetchpop-pop.patch [new file with mode: 0644]

diff --git a/fetchpop-fetch.patch b/fetchpop-fetch.patch
new file mode 100644 (file)
index 0000000..2664bb5
--- /dev/null
@@ -0,0 +1,112 @@
+/*
+Fix of trivial typos that I found after releasing fetchpop1.9
+*/
+
+*** fetchpop1.9/fetchpop.c.orig        Thu Jun 27 02:44:51 1996
+--- fetchpop1.9/fetchpop.c     Thu Jun 27 04:26:46 1996
+***************
+*** 41,45 ****
+  int decryptit(char *to, char *from);
+  
+! #define VERSION "fetchpop 1.9 release"
+  #define DATE "Jun 1996"
+  
+--- 41,45 ----
+  int decryptit(char *to, char *from);
+  
+! #define VERSION "fetchpop 1.9pl1 release"
+  #define DATE "Jun 1996"
+  
+***************
+*** 154,160 ****
+        if (!flag1 && !flag2) {
+       options->remove = 2;
+-      if (!flag1)
+         ++flag1;
+-      else
+         ++flag2;
+        } else
+--- 154,158 ----
+***************
+*** 315,319 ****
+    
+    if (iserror) {
+!     fprintf(stderr,"usage: fetchpop [-v] [-k | -q] [-d] [-r] [-x | -e msgID] [-c | -a | -g msg ID] [-h] [-t limit] [-f alternative rcfile] [-l log file] [");
+  #ifdef HAVEMDA
+      fprintf(stderr," -m | ");
+--- 313,317 ----
+    
+    if (iserror) {
+!     fprintf(stderr,"usage: fetchpop [-v] [-k | -q] [-d] [-b] [-r] [-x | -e msg ID] [-c | -a | -g msg ID] [-h] [-t limit] [-f alternative rcfile] [-l log file] [");
+  #ifdef HAVEMDA
+      fprintf(stderr," -m | ");
+***************
+*** 339,343 ****
+  #endif
+  #ifdef HAVEPROCMAIL
+!     fprintf(stderr,"  -p   : use procmail for mail delivery.\n");
+  #endif
+      fprintf(stderr,"  -o   : write the fetched message to user defined mail folder.\n");
+--- 337,341 ----
+  #endif
+  #ifdef HAVEPROCMAIL
+!     fprintf(stderr,"  -p   : use procmail(%s) for mail delivery.\n",FORMAIL);
+  #endif
+      fprintf(stderr,"  -o   : write the fetched message to user defined mail folder.\n");
+***************
+*** 518,522 ****
+  #define DEC(c) ((((c) - ' ') & 077) -2)
+  
+! void encryptit(char to[], char from[])
+  {
+    
+--- 516,520 ----
+  #define DEC(c) ((((c) - ' ') & 077) -2)
+  
+! void encryptit(char *to, char *from)
+  {
+    
+***************
+*** 543,547 ****
+  }
+  
+! int decryptit(char to[], char from[])
+  {
+    int ch,n;
+--- 541,545 ----
+  }
+  
+! int decryptit(char *to, char *from)
+  {
+    int ch,n;
+*** fetchpop1.9/Makefile.orig  Thu Jun 27 02:44:38 1996
+--- fetchpop1.9/Makefile       Thu Jun 27 04:33:22 1996
+***************
+*** 27,30 ****
+--- 27,32 ----
+  #                         Useful if you want to use biff or xmailbox
+  #                         with fetchpop.
++ # -DNODETAILLOG              - don't display delivery method at the end 
++ #                              of retrieval
+  #--------------------------------------------------------------
+  # For example,
+***************
+*** 33,41 ****
+  #EXTRA_OPTION = -DHAVEMDA -DLogShowfrom 
+  #EXTRA_OPTION = -DHAVEPROCMAIL -DLogShowfrom 
+! EXTRA_OPTION = -DHAVEPROCMAIL -DHAVEMDA -DLogShowfrom -DLogOnlyNew 
+  #EXTRA_OPTION = -DHAVEPROCMAIL -DHAVEMDA -DLogShowfrom  
+  
+  LIBS=
+- 
+  # -------- No need to edit anything below here ---------------------------
+  DEFTARGET=notes
+--- 35,42 ----
+  #EXTRA_OPTION = -DHAVEMDA -DLogShowfrom 
+  #EXTRA_OPTION = -DHAVEPROCMAIL -DLogShowfrom 
+! EXTRA_OPTION = -DHAVEPROCMAIL -DHAVEMDA -DLogShowfrom -DLogOnlyNew -DNODETAILLOG 
+  #EXTRA_OPTION = -DHAVEPROCMAIL -DHAVEMDA -DLogShowfrom  
+  
+  LIBS=
+  # -------- No need to edit anything below here ---------------------------
+  DEFTARGET=notes
diff --git a/fetchpop-make.patch b/fetchpop-make.patch
new file mode 100644 (file)
index 0000000..eb819c2
--- /dev/null
@@ -0,0 +1,22 @@
+diff -uNr fetchpop1.9.orig/Makefile fetchpop1.9/Makefile
+--- fetchpop1.9.orig/Makefile  Tue Jun 25 22:21:43 1996
++++ fetchpop1.9/Makefile       Thu Apr 24 17:16:54 1997
+@@ -4,14 +4,14 @@
+ # and also edit config.h file if you need.
+ # if you don't know what to do, don't worry about it. Just type 'make'
+-BINDIR=/usr/local/bin
+-MANDIR=/usr/local/man/man1
++BINDIR=$(INSTALL_DIR)/usr/bin
++MANDIR=$(INSTALL_DIR)/usr/man/man1
+ CC=gcc
+-CFLAGS= -g 
++#CFLAGS= -g 
+ #CFLAGS= -O2 -m486 -pipe 
+-#CFLAGS= -O2 -m486 -fno-strength-reduce -Wall -pipe
++CFLAGS= -O2 -fno-strength-reduce -Wall -pipe
+ #--------------------------------------------------------------
+ # Valid flags for EXTRA_OPTION
diff --git a/fetchpop-pop.patch b/fetchpop-pop.patch
new file mode 100644 (file)
index 0000000..cf2a18f
--- /dev/null
@@ -0,0 +1,45 @@
+/*
+ Apply this patch to fetchpop1.9, such as 'patch < fetchpop1.9.patch2'
+ This is fix for some POP3 servers that send CR/LF in reply
+
+               seung-hong oh <oh@cis.ohio-state.edu> 
+*/
+
+*** fetchpop1.9/pop.c.orig     Tue Jun 25 21:28:06 1996
+--- fetchpop1.9/pop.c  Sun Jun 30 22:41:12 1996
+***************
+*** 94,103 ****
+  
+  #ifndef LogOnlyNew
+!   sprintf(buf,"There are %d new messages and total of %d messages.\n",newmsg,howmany);
+    printmsg(buf,options->logging, options->daemon, logfd, 0, options->whichdeliver == 4);
+    rpy = 0;
+  #else
+    if (!options->daemon)
+!     printf("There are %d new messages and total of %d messages.\n",newmsg,howmany);
+  #endif
+    if ((options->remove == 2) && (last > 0)) {
+--- 94,103 ----
+  
+  #ifndef LogOnlyNew
+!   sprintf(buf,"You have %d new messages and total of %d messages.\n",newmsg,howmany);
+    printmsg(buf,options->logging, options->daemon, logfd, 0, options->whichdeliver == 4);
+    rpy = 0;
+  #else
+    if (!options->daemon)
+!     printf("You have %d new messages and total of %d messages.\n",newmsg,howmany);
+  #endif
+    if ((options->remove == 2) && (last > 0)) {
+***************
+*** 153,157 ****
+    int rpy;
+    
+!   if (!readsock(sockfd, argbuf, POPBUFLEN)) {
+  #ifdef DEBUG
+      printf("argbuf is %s\n", argbuf);
+--- 153,157 ----
+    int rpy;
+    
+!   if (!sockgetline(sockfd, argbuf, POPBUFLEN)) {
+  #ifdef DEBUG
+      printf("argbuf is %s\n", argbuf);
This page took 0.084999 seconds and 4 git commands to generate.