]> git.pld-linux.org Git - packages/fence.git/blob - fence.spec
- up to 1.01.00
[packages/fence.git] / fence.spec
1 Summary:        I/O fencing system
2 Summary(pl):    System barier I/O
3 Name:           fence
4 Version:        1.01.00
5 Release:        1
6 Epoch:          1
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
10 # Source0-md5:  e98551b02ee8ed46ae0ab8fca193d751
11 URL:            http://sources.redhat.com/cluster/fence/
12 BuildRequires:  cman-devel
13 BuildRequires:  perl-base
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _sbindir        /sbin
17
18 %description
19 The Fence system does I/O fencing of cluster members. Any member may
20 join the default fence domain after which it will be fenced if it
21 fails without leaving the fence domain cleanly. The lock_dlm GFS lock
22 module will not permit GFS to be mounted until the node has joined a
23 fence domain. 
24
25 The fence daemon, fenced, is usually started by running "fence_tool
26 join". Once started, fenced joins the default fence domain and the
27 node is subject to being fenced if it fails. A collection of fence
28 agents are used by fenced to interface with hardware devices (usually
29 to shut off its path to shared storage or cycle its power source.)
30
31 %description -l pl
32 System Fence odpowiada za bariery I/O dla cz³onków klastra. Ka¿dy z
33 cz³onków mo¿e do³±czyæ do domy¶lnej domeny barier, po czym bêdzie
34 odgrodzony je¶li zawiedzie nie opuszczaj±c czysto domeny barier.
35 Modu³ blokuj±cy GFS-a lock_dlm nie pozwoli na podmontowanie GFS-a
36 dopóki wêze³ nie do³±czy do domeny barier.
37
38 Demon fence, fenced, jest zwykle uruchamiany przez fence_tool join. Po
39 uruchomieniu fenced do³±cza do domy¶lnej domeny barier, a wêze³ jest
40 przedmiotem odgrodzenia je¶li zawiedzie. fenced wykorzystuje zbiór
41 agentów fence do komunikacji z urz±dzeniami sprzêtowymi (zwykle do
42 odcinania drogi do dzielonej pamiêci lub wy³±czania i w³±czania
43 zasilania).
44
45 %prep
46 %setup -q -n cluster-%{version}
47 cd %{name}
48
49 %{__perl} -pi -e 's/-Wall/%{rpmcflags} -Wall/' make/defines.mk.input
50 %{__perl} -pi -e 's/-O2 //' fence_node/Makefile fence_tool/Makefile fenced/Makefile
51
52 %build
53 cd %{name}
54 ./configure \
55         --incdir=%{_includedir} \
56         --libdir=%{_libdir} \
57         --mandir=%{_mandir} \
58         --prefix=%{_prefix} \
59         --sbindir=%{_sbindir}
60 %{__make} \
61         CC="%{__cc}"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 cd %{name}
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_sbindir}/*
76 #%attr(754,root,root) /etc/rc.d/init.d/fenced
77 %{_mandir}/man?/*
This page took 0.138466 seconds and 3 git commands to generate.