]> git.pld-linux.org Git - packages/fence.git/blob - fence.spec
- initial pld release
[packages/fence.git] / fence.spec
1 #
2 # Conditional build:
3 Summary:        I/O fencing system
4 Name:           fence
5 %define snap    20040625
6 Version:        0.0.0.%{snap}.1
7 Release:        1
8 License:        GPL
9 Group:          Applications/System
10 Source0:        %{name}.tar.gz
11 # Source0-md5:  f3f40096cf957c6825ae76cac153d698
12 URL:            http://sources.redhat.com/cluster/
13 BuildRequires:  awk
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _sbindir        /sbin
17
18 %description
19 The Fence system does I/O fencing of cluster members. Any member may join the default fence domain after which it will be fenced if it fails without leaving the fence domain cleanly. The lock_dlm GFS lock module will not permit GFS to be mounted until the node has joined a fence domain. 
20
21 The fence daemon, fenced, is usually started by running "fence_tool join". Once started, fenced joins the default fence domain and the node is subject to being fenced if it fails. A collection of fence agents are used by fenced to interface with hardware devices (usually to shut off its path to shared storage or cycle its power source.)
22
23 %prep
24 %setup -q -n %{name}
25
26 %build
27 ./configure \
28         --incdir=%{_includedir} \
29         --kernel_src=%{_kernelsrcdir} \
30         --libdir=%{_libdir} \
31         --mandir=%{_mandir} \
32         --prefix=%{_prefix} \
33         --sbindir=%{_sbindir}
34 %{__make} \
35         CC="%{__cc}"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %attr(755,root,root) %{_sbindir}/*
49 %{_mandir}/man?/*
This page took 0.073705 seconds and 3 git commands to generate.