]> git.pld-linux.org Git - packages/femfind.git/blob - femfind.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/femfind.git] / femfind.spec
1 #
2 # TODO:
3 # - webapps
4 # - include apache configuration to config
5 # - pre/post play
6 # - logrotate file
7 # - fix ownership of the perl_vendorlib/FemFind directory
8 #
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        FemFind - crawl your network resources
11 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
12 Name:           FemFind
13 Version:        0.74
14 Release:        2
15 License:        GPL v2
16 Group:          Networking/Utilities
17 Source0:        http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
18 # Source0-md5:  57de716507fb23ddb4fed17cd77cd038
19 Patch0:         %{name}-config.patch
20 URL:            http://femfind.sourceforge.net/
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _wwwsite        /home/services/httpd/html/FemFind
25 %define         _cgisite        /home/services/httpd/cgi-bin/femfind
26
27 %description
28 FemFind is a crawler for SMB shares which can be found on Windows or
29 Unix systems running Samba. Additionally FemFind crawls FTP servers
30 and provides a web interface and a Windows client as frontends.
31
32 %description -l pl.UTF-8
33 FemFind jest programem przeszukującym zasoby sieci udostępnione
34 poprzez protokół SMB na maszynach windowsowych lub uniksowych z
35 działającą Sambą. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
36 interfejs WWW oraz klienta windowsowego jako frontend.
37
38 %package -n perl-FemFind-ConfigReader
39 Summary:        FemFind - crawl your network resources
40 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
41 Group:          Development/Languages/Perl
42
43 %description -n perl-FemFind-ConfigReader
44 FemFind::ConfigReader perl module for FemFind.
45
46 %description -n perl-FemFind-ConfigReader -l pl.UTF-8
47 Perlowy moduł FemFind::ConfigReader dla FemFinda.
48
49 %package -n perl-FemFind-Helper
50 Summary:        FemFind - crawl your network resources
51 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
52 Group:          Development/Languages/Perl
53
54 %description -n perl-FemFind-Helper
55 FemFind::Helper perl module for FemFind.
56
57 %description -n perl-FemFind-Helper -l pl.UTF-8
58 Perlowy moduł FemFind::Helper dla FemFinda.
59
60 %package -n FemFind-cgi
61 Summary:        FemFind - crawl your network resources
62 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
63 Group:          Networking/Utilities
64
65 %description -n FemFind-cgi
66 CGI scripts for FemFind frontend.
67
68 %description -n FemFind-cgi -l pl.UTF-8
69 Skrypty CGI do frontendu FemFinda.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 cd modules
77 cd ConfigReader
78 %{__perl} Makefile.PL \
79         INSTALLDIRS=vendor
80 %{__make}
81 cd ..
82 cd Helper
83 %{__perl} Makefile.PL \
84         INSTALLDIRS=vendor
85 %{__make}
86 cd ..
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
91 install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
92
93 %{__make} install \
94         -C modules/ConfigReader \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__make} install \
98         -C modules/Helper \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install femfind.conf    $RPM_BUILD_ROOT%{_sysconfdir}
102 install makedb.pl       $RPM_BUILD_ROOT%{_sbindir}
103 install crawler.pl      $RPM_BUILD_ROOT%{_bindir}
104 install german/*        $RPM_BUILD_ROOT%{_cgisite}/german
105 install cgi-bin/femfind/*       $RPM_BUILD_ROOT%{_cgisite}
106 install htdocs/femfind/*        $RPM_BUILD_ROOT%{_wwwsite}
107
108 touch $RPM_BUILD_ROOT/var/log/femfind.log
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 echo "Remember to init database running %{_sbindir}/makedb.pl"
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README
119 %dir /var/lib/femfind
120 %ghost /var/log/femfind.log
121 %config(noreplace) %{_sysconfdir}/femfind.conf
122 %attr(755,root,root) %{_sbindir}/makedb.pl
123 %attr(755,root,root) %{_bindir}/crawler.pl
124
125 %files -n perl-FemFind-ConfigReader
126 %defattr(644,root,root,755)
127 # ??? see Helper
128 %{perl_vendorlib}/FemFind/*.pm
129 %{_mandir}/man3/FemFind::ConfigReader.*
130
131 %files -n perl-FemFind-Helper
132 %defattr(644,root,root,755)
133 # ??? see ConfigReader
134 %{perl_vendorlib}/FemFind/*.pm
135 %{_mandir}/man3/FemFind::Helper.*
136
137 %files -n FemFind-cgi
138 %defattr(644,root,root,755)
139 %dir %{_cgisite}
140 %dir %{_wwwsite}
141 %dir %{_cgisite}/german
142 %attr(755,root,root) %{_cgisite}/german/*.pl
143 %{_cgisite}/german/*.html
144 %attr(755,root,root) %{_cgisite}/*.pl
145 %{_cgisite}/*.html
146 %{_cgisite}/ftp_list
147 %{_wwwsite}/*
This page took 0.090382 seconds and 3 git commands to generate.