]> git.pld-linux.org Git - packages/femfind.git/blame - femfind.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/femfind.git] / femfind.spec
CommitLineData
55665d2c 1#
1b8e4137 2# TODO:
510207e5 3# - webapps
1b8e4137
PG
4# - include apache configuration to config
5# - pre/post play
5d158baa 6# - logrotate file
55665d2c 7# - fix ownership of the perl_vendorlib/FemFind directory
8#
1b8e4137 9Summary: FemFind - crawl your network resources
c0eee7ce 10Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
11Name: FemFind
12Version: 0.74
55665d2c 13Release: 2
1b8e4137
PG
14License: GPL v2
15Group: Networking/Utilities
16Source0: http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
00f208f5 17# Source0-md5: 57de716507fb23ddb4fed17cd77cd038
5d158baa 18Patch0: %{name}-config.patch
1b8e4137 19URL: http://femfind.sourceforge.net/
55665d2c 20BuildRequires: rpm-perlprov >= 4.1-13
1b8e4137
PG
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
0df3e734
AA
23%define _wwwsite /home/services/httpd/html/FemFind
24%define _cgisite /home/services/httpd/cgi-bin/femfind
1b8e4137
PG
25
26%description
27FemFind is a crawler for SMB shares which can be found on Windows or
28Unix systems running Samba. Additionally FemFind crawls FTP servers
29and provides a web interface and a Windows client as frontends.
30
0d036695
JR
31%description -l pl.UTF-8
32FemFind jest programem przeszukującym zasoby sieci udostępnione
33poprzez protokół SMB na maszynach windowsowych lub uniksowych z
34działającą Sambą. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
1872e449 35interfejs WWW oraz klienta windowsowego jako frontend.
1b8e4137
PG
36
37%package -n perl-FemFind-ConfigReader
38Summary: FemFind - crawl your network resources
c0eee7ce 39Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
40Group: Development/Languages/Perl
41
42%description -n perl-FemFind-ConfigReader
43FemFind::ConfigReader perl module for FemFind.
44
0d036695
JR
45%description -n perl-FemFind-ConfigReader -l pl.UTF-8
46Perlowy moduł FemFind::ConfigReader dla FemFinda.
1b8e4137
PG
47
48%package -n perl-FemFind-Helper
49Summary: FemFind - crawl your network resources
c0eee7ce 50Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
51Group: Development/Languages/Perl
52
53%description -n perl-FemFind-Helper
54FemFind::Helper perl module for FemFind.
55
0d036695
JR
56%description -n perl-FemFind-Helper -l pl.UTF-8
57Perlowy moduł FemFind::Helper dla FemFinda.
1b8e4137
PG
58
59%package -n FemFind-cgi
60Summary: FemFind - crawl your network resources
c0eee7ce 61Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
62Group: Networking/Utilities
63
64%description -n FemFind-cgi
65CGI scripts for FemFind frontend.
66
0d036695 67%description -n FemFind-cgi -l pl.UTF-8
1b8e4137
PG
68Skrypty CGI do frontendu FemFinda.
69
70%prep
71%setup -q
5d158baa 72%patch0 -p1
1b8e4137
PG
73
74%build
75cd modules
76cd ConfigReader
55665d2c 77%{__perl} Makefile.PL \
78 INSTALLDIRS=vendor
79%{__make}
1b8e4137
PG
80cd ..
81cd Helper
55665d2c 82%{__perl} Makefile.PL \
83 INSTALLDIRS=vendor
84%{__make}
1b8e4137
PG
85cd ..
86
87%install
88rm -rf $RPM_BUILD_ROOT
56fb704c 89install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
5d158baa 90install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
1b8e4137 91
55665d2c 92%{__make} install \
93 -C modules/ConfigReader \
94 DESTDIR=$RPM_BUILD_ROOT
95
96%{__make} install \
97 -C modules/Helper \
98 DESTDIR=$RPM_BUILD_ROOT
1b8e4137
PG
99
100install femfind.conf $RPM_BUILD_ROOT%{_sysconfdir}
101install makedb.pl $RPM_BUILD_ROOT%{_sbindir}
102install crawler.pl $RPM_BUILD_ROOT%{_bindir}
103install german/* $RPM_BUILD_ROOT%{_cgisite}/german
104install cgi-bin/femfind/* $RPM_BUILD_ROOT%{_cgisite}
105install htdocs/femfind/* $RPM_BUILD_ROOT%{_wwwsite}
106
5d158baa
PG
107touch $RPM_BUILD_ROOT/var/log/femfind.log
108
1b8e4137
PG
109%clean
110rm -rf $RPM_BUILD_ROOT
111
5d158baa
PG
112%post
113echo "Remember to init database running %{_sbindir}/makedb.pl"
114
1b8e4137
PG
115%files
116%defattr(644,root,root,755)
117%doc README
5d158baa
PG
118%dir /var/lib/femfind
119%ghost /var/log/femfind.log
7fcd3309 120%config(noreplace) %{_sysconfdir}/femfind.conf
1b8e4137
PG
121%attr(755,root,root) %{_sbindir}/makedb.pl
122%attr(755,root,root) %{_bindir}/crawler.pl
123
124%files -n perl-FemFind-ConfigReader
125%defattr(644,root,root,755)
47a767ab 126# ??? see Helper
55665d2c 127%{perl_vendorlib}/FemFind/*.pm
128%{_mandir}/man3/FemFind::ConfigReader.*
1b8e4137
PG
129
130%files -n perl-FemFind-Helper
131%defattr(644,root,root,755)
47a767ab 132# ??? see ConfigReader
55665d2c 133%{perl_vendorlib}/FemFind/*.pm
134%{_mandir}/man3/FemFind::Helper.*
1b8e4137
PG
135
136%files -n FemFind-cgi
137%defattr(644,root,root,755)
138%dir %{_cgisite}
139%dir %{_wwwsite}
47a767ab 140%dir %{_cgisite}/german
1b8e4137 141%attr(755,root,root) %{_cgisite}/german/*.pl
47a767ab 142%{_cgisite}/german/*.html
1b8e4137 143%attr(755,root,root) %{_cgisite}/*.pl
47a767ab
JB
144%{_cgisite}/*.html
145%{_cgisite}/ftp_list
146%{_wwwsite}/*
This page took 0.098831 seconds and 4 git commands to generate.