]> git.pld-linux.org Git - packages/feh.git/commitdiff
- rel.3: official git_ed5f55e967152ff6c730 patch added. auto/th/feh-1_15_1-3
authorPaweł Gołaszewski <blues@pld-linux.org>
Thu, 1 Sep 2011 10:31:48 +0000 (10:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    feh-fix.patch -> 1.2
    feh-git_ed5f55e967152ff6c730.patch -> 1.1
    feh.spec -> 1.66

feh-fix.patch [deleted file]
feh-git_ed5f55e967152ff6c730.patch [new file with mode: 0644]
feh.spec

diff --git a/feh-fix.patch b/feh-fix.patch
deleted file mode 100644 (file)
index 7c9223b..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./src/slideshow.c.org      2011-09-01 11:24:04.424019451 +0200
-+++ ./src/slideshow.c  2011-09-01 11:23:57.240352664 +0200
-@@ -171,15 +171,7 @@ void feh_reload_image(winwidget w, int r
-       /* if the image has changed in dimensions - we gotta resize */
-       if ((feh_load_image(&tmp, FEH_FILE(w->file->data))) == 0) {
--              if (force_new) {
--                      eprintf("failed to reload image\n");
--              } else {
--                      im_weprintf(w, "Couldn't reload image. Is it still there?");
--              }
--              winwidget_rename(w, title);
--              free(title);
--              free(new_title);
--              filelist = feh_file_remove_from_list(filelist, w->file);
-+              weprintf("failed to reload image\n");
-               return;
-       }
diff --git a/feh-git_ed5f55e967152ff6c730.patch b/feh-git_ed5f55e967152ff6c730.patch
new file mode 100644 (file)
index 0000000..7a9e1fc
--- /dev/null
@@ -0,0 +1,42 @@
+--- ./src/slideshow.c.1        2011-09-01 12:18:59.303918828 +0200
++++ ./src/slideshow.c  2011-08-16 22:53:06.000000000 +0200
+@@ -149,7 +149,6 @@ void feh_reload_image(winwidget w, int r
+       if (!w->file) {
+               im_weprintf(w, "couldn't reload, this image has no file associated with it.");
+-              winwidget_render_image(w, 0, 0);
+               return;
+       }
+@@ -167,17 +166,20 @@ void feh_reload_image(winwidget w, int r
+       old_w = gib_imlib_image_get_width(w->im);
+       old_h = gib_imlib_image_get_height(w->im);
++      /* force imlib2 not to cache */
++      winwidget_free_image(w);
++
+       /* if the image has changed in dimensions - we gotta resize */
+       if ((feh_load_image(&tmp, FEH_FILE(w->file->data))) == 0) {
+               if (force_new) {
+                       eprintf("failed to reload image\n");
+               } else {
+                       im_weprintf(w, "Couldn't reload image. Is it still there?");
+-                      winwidget_render_image(w, 0, 0);
+               }
+               winwidget_rename(w, title);
+               free(title);
+               free(new_title);
++              filelist = feh_file_remove_from_list(filelist, w->file);
+               return;
+       }
+@@ -185,9 +187,6 @@ void feh_reload_image(winwidget w, int r
+                       (old_h != gib_imlib_image_get_height(tmp))))
+               resize = 1;
+-      /* force imlib2 not to cache */
+-      winwidget_free_image(w);
+-
+       w->im = tmp;
+       winwidget_reset_image(w);
index 9206b388738d479a092f6e690bc3c3c9ea29d161..9d3297ea79c6d158547c41eefd2613426d52bc3a 100644 (file)
--- a/feh.spec
+++ b/feh.spec
@@ -3,14 +3,14 @@ Summary(hu.UTF-8):    Gyors képnézegető/indexelő/montázsoló
 Summary(pl.UTF-8):     Szybki program do przeglądania/indeksowania/montowania obrazów
 Name:          feh
 Version:       1.15.1
 Summary(pl.UTF-8):     Szybki program do przeglądania/indeksowania/montowania obrazów
 Name:          feh
 Version:       1.15.1
-Release:       2.1
+Release:       3
 License:       BSD
 Group:         X11/Applications/Graphics
 Source0:       https://derf.homelinux.org/~derf/projects/feh/%{name}-%{version}.tar.bz2
 # Source0-md5: 0684ff2dad34ee328ab2b6b717281787
 URL:           http://feh.finalrewind.org/
 Patch0:                %{name}-install.patch
 License:       BSD
 Group:         X11/Applications/Graphics
 Source0:       https://derf.homelinux.org/~derf/projects/feh/%{name}-%{version}.tar.bz2
 # Source0-md5: 0684ff2dad34ee328ab2b6b717281787
 URL:           http://feh.finalrewind.org/
 Patch0:                %{name}-install.patch
-Patch1:                %{name}-fix.patch
+Patch1:                %{name}-git_ed5f55e967152ff6c730.patch
 Source1:       %{name}-bash-completion
 BuildRequires: giblib-devel >= 1.2.4
 BuildRequires: imlib2-devel >= 1.0.0
 Source1:       %{name}-bash-completion
 BuildRequires: giblib-devel >= 1.2.4
 BuildRequires: imlib2-devel >= 1.0.0
@@ -66,7 +66,7 @@ bashowe dopełnianie linii poleceń programu feh.
 %prep
 %setup -q
 %patch0 -p1
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+%patch1 -p1 -R
 %{__sed} -i "s,CFLAGS ?=.*,CFLAGS = %{rpmcflags}," config.mk
 
 %build
 %{__sed} -i "s,CFLAGS ?=.*,CFLAGS = %{rpmcflags}," config.mk
 
 %build
This page took 0.093927 seconds and 4 git commands to generate.