]> git.pld-linux.org Git - packages/fedora-packager.git/blob - fedora-packager.spec
- new custom tarball, package only fedpkg
[packages/fedora-packager.git] / fedora-packager.spec
1 Summary:        Tools for setting up a Fedora maintainer environment
2 Name:           fedora-packager
3 Version:        0.5.5.0
4 Release:        0.2
5 License:        GPL v2+
6 Group:          X11/Applications
7 URL:            https://fedorahosted.org/fedora-packager
8 #Source0:       https://fedorahosted.org/releases/f/e/fedora-packager/%{name}-%{version}.tar.bz2
9 Source0:        %{name}-%{version}.tar.bz2
10 # Source0-md5:  45b7a7561d5676f0c69a53a6991a9cac
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 #Requires:      bodhi-client
16 Requires:       curl
17 Requires:       koji
18 #Requires:      mock
19 Requires:       openssh-clients
20 Requires:       python-offtrac
21 Requires:       python-pyOpenSSL
22 Requires:       python-pycurl
23 #Requires:      redhat-rpm-config
24 Requires:       rpm-build
25 #Requires:      rpmdevtools
26 #Requires:      rpmlint
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Set of utilities useful for a Fedora packager in setting up their
32 environment.
33
34 %package -n fedpkg
35 Summary:        Fedora utility for working with dist-git
36 Group:          Applications/Databases
37 Requires:       curl
38 Requires:       git-core
39 Requires:       python-argparse
40 Requires:       python-git >= 0.2.0
41 Requires:       rpm-build
42
43 %description -n fedpkg
44 Provides the fedpkg command for working with dist-git.
45
46 %package -n bash-completion-fedpkg
47 Summary:        bash-completion for fedpkg
48 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla fedpkg
49 Group:          Applications/Shells
50 Requires:       bash-completion
51 Requires:       fedpkg = %{version}-%{release}
52
53 %description -n bash-completion-fedpkg
54 bash-completion for fedpkg.
55
56 %description -n bash-completion-fedpkg -l pl.UTF-8
57 bashowe uzupełnianie nazw dla fedpkg.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %py_postclean
72
73 mv $RPM_BUILD_ROOT/etc/bash_completion.d/fedpkg{.bash,}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %if 0
79 %files
80 %defattr(644,root,root,755)
81 %doc TODO AUTHORS ChangeLog
82 %attr(755,root,root) %{_bindir}/*
83 %attr(755,root,root) %{_sbindir}/fedora-burn-yubikey
84 %exclude %{_bindir}/fedpkg
85 # R: fedora.client.fas2
86 %{py_sitescriptdir}/fedora_cert
87 %endif
88
89 %files -n fedpkg
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_bindir}/fedpkg
92 %{_mandir}/man1/fedpkg.1*
93 %{py_sitescriptdir}/pyfedpkg
94
95 %files -n bash-completion-fedpkg
96 %defattr(644,root,root,755)
97 /etc/bash_completion.d/*
This page took 0.103524 seconds and 4 git commands to generate.