]> git.pld-linux.org Git - packages/fedora-ds.git/blame_incremental - fedora-ds.spec
- drop obsolete files
[packages/fedora-ds.git] / fedora-ds.spec
... / ...
CommitLineData
1#
2# http://directory.fedora.redhat.com/wiki/Building
3#
4Summary: Fedora Directory Server
5Summary(pl.UTF-8): Fedora Directory Server - serwer usług katalogowych
6Name: fedora-ds
7Version: 1.0.4
8Release: 0.1
9License: GPL v2
10Group: Applications
11Source0: http://directory.fedora.redhat.com/sources/%{name}-%{version}.tar.gz
12# Source0-md5: fca8c94d2bfdc3a762c0e8b09ab04b09
13URL: http://directory.fedora.redhat.com/
14BuildRequires: cyrus-sasl-devel >= 2.0
15BuildRequires: db-devel >= 4.0
16# fake, but required now
17#BuildRequires: db-utils
18BuildRequires: fedora-adminutil >= 1.0
19BuildRequires: fedora-setuputil >= 1.0
20BuildRequires: gdbm-devel >= 1.6
21#BuildRequires: java-sun
22#BuildRequires: libgssglue-devel
23BuildRequires: libicu-devel >= 2.4
24BuildRequires: libstdc++-devel
25BuildRequires: lm_sensors-devel
26BuildRequires: mozldap-devel >= 6.0
27BuildRequires: ncurses-devel
28BuildRequires: net-snmp-devel >= 5.2.1
29BuildRequires: nspr-devel >= 1:4.4.1
30BuildRequires: nss-devel >= 1:3.9.3
31BuildRequires: rpmbuild(macros) >= 1.228
32BuildRequires: which
33BuildRequires: zip
34#
35#BuildRequires: Java/XML Components
36# axis.jar, jaxrpc.jar, and saaj.jar - http://ws.apache.org/axis/index.html
37# xercesImpl.jar and xml-apis.jar - http://xml.apache.org/xerces2-j/download.cgi
38# activation.jar - http://java.sun.com/products/javabeans/glasgow/jaf.html
39# axrpc-api.jar - http://java.sun.com/webservices/downloads/webservicespack.html
40# crimson.jar - http://xml.apache.org/dist/crimson/
41#BuildRequires: apache-devel
42#BuildRequires: ant >= 1.6.1
43#BuildRequires: krb5-devel
44#BuildRequires: mozilla-components: DBM (v1.61), NSS (v3.93), SVRCORE (v4.0), LDAPSDK (v5.16), and PerLDAP (*)
45#BuildRequires: perl-Mozilla-LDAP
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49The Fedora Directory Server is a robust, scalable open-source server
50designed to manage large directories of users and resources. It is
51based on an open-systems server protocol called the Lightweight
52Directory Access Protocol (LDAP). The Fedora Directory Server is a
53world-class Directory Server implementation. Some of the more
54interesting features that are included are:
55- 4-Way Multi-Master Replication
56- Scalability: thousands of operations per second, tens of thousands
57 of concurrent users, tens of millions of entries, hundreds of
58 gigabytes of data
59- SSLv3, TLSv1, and SASL for secure authentication and transport
60- Support for most LDAPv3 features, including many common controls and
61 extensions
62- Schema update over LDAP
63- Flexible in-tree Access Control Information (ACIs), updatable over
64 LDAP
65- On-line configuration and management over LDAP
66- Graphical console for all facets of user, group, and server
67 management
68
69%description -l pl.UTF-8
70Fedora Directory Server to potężny, posiadający otwarte źródła,
71skalowalny serwer zaprojektowany do zarządzania dużymi katalogami
72użytkowników i zasobów. Jest oparty na otwartym protokole serwerowym
73LDAP (Lightweight Directory Access Protocol). Fedora Directory Server
74to światowej klasy implementacja serwera usług katalogowych. Bardziej
75interesujące cechy obejmują:
76- 4-stronną replikację multi-master
77- skalowalność: tysiące operacji na sekundą, dziesiątki tysięcy
78 jednoczesnych użytkowników, dziesiątki milionów wpisów, setki
79 gigabajtów danych
80- obsługę SSLv3, TLSv1 i SASL do bezpiecznego uwierzytelniania i
81 przesyłania danych
82- obsługę większości cech LDAPv3, w tym wielu popularnych opcji i
83 rozszerzeń
84- uaktualnianie schematu przez LDAP
85- elastyczne informacje o prawach dostępu w drzewie (ACI - Access
86 Control Information), uaktualniane przez LDAP
87- konfigurację i zarządzanie w locie przez LDAP
88- graficzną konsolę dla wszystkich aspektów zarządzania użytkownikami,
89 grupami i serwerem
90
91%prep
92%setup -q
93# dirty hack, maybe fedora-adminserver needed
94mkdir -p __admserv/admin
95touch __admserv/setup.inf
96
97%build
98%{__make} buildDirectory \
99 ARCH_DEBUG="%{rpmcflags}" \
100 ARCH_OPT="%{rpmcflags}" \
101 BUILD_DEBUG=%{?debug:full}%{!?debug:optimize} \
102 CC="%{__cc}" \
103 CXX="%{__cxx}" \
104 MAKE=%{__make} \
105 NSOS_TEST=PLD \
106 ADMINUTIL_INCPATH=%{_includedir}/adminutil-1.0 \
107 ADMINUTIL_LINK=-ladminutil \
108 ADMINSERVER_SUBCOMPS=setup.inf \
109 ADMSERV_DIR=$PWD/__admserv \
110 CURSES="-lncurses" \
111 DB_BINPATH=%{_bindir} \
112 DB_INCLUDE=%{_includedir} \
113 DBM_INCDIR=%{_includedir} \
114 DBM_LIBNAMES=gdbm \
115 GSSAPI_LIBS=-lgssapi \
116 ICU_INCDIR=%{_includedir}/unicode \
117 ICU_INCPATH=%{_includedir}/icu \
118 LDAPSDK_INCDIR=%{_includedir}/mozldap \
119 NETSNMP_INCDIR=%{_includedir}/net-snmp \
120 NETSNMP_LIBNAMES="netsnmp netsnmpagent netsnmpmibs netsnmphelpers rpm sensors" \
121 NSPR_INCDIR=%{_includedir}/nspr \
122 SASL_INCDIR=%{_includedir}/sasl \
123 SECURITY_INCDIR=%{_includedir}/nss \
124 SETUPUTIL_INCDIR=/usr/include/fedora-setuputil \
125 SETUPUTIL_BINPATH=%{_bindir} \
126 SVRCORE_INCLUDE="-I/usr/include/svrcore" \
127 MFLAGS="\
128 USE_ADMINSERVER=1 \
129 USE_CONSOLE=0 \
130 USE_DSMLGW=0 \
131 USE_ORGCHART=1 \
132 USE_DSGW=1 \
133 USE_JAVATOOLS=0 \
134 USE_SETUPUTIL=1 \
135 USE_PERL_FROM_PATH=1 \
136 DEBUG=%{?debug:full}%{!?debug:optimize} \
137 NOJAVA=1"
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145#%files
146#%defattr(644,root,root,755)
This page took 0.027339 seconds and 4 git commands to generate.