]> git.pld-linux.org Git - packages/febootstrap.git/commitdiff
- new auto/th/febootstrap-3_12-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 22 Jan 2012 18:38:35 +0000 (18:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    0001-Fix-Python-code-when-_bestPackageFromList-returns-No.patch -> 1.1
    febootstrap.spec -> 1.1

0001-Fix-Python-code-when-_bestPackageFromList-returns-No.patch [new file with mode: 0644]
febootstrap.spec [new file with mode: 0644]

diff --git a/0001-Fix-Python-code-when-_bestPackageFromList-returns-No.patch b/0001-Fix-Python-code-when-_bestPackageFromList-returns-No.patch
new file mode 100644 (file)
index 0000000..d88afd2
--- /dev/null
@@ -0,0 +1,27 @@
+From 61c565bc06a83da75b57f8568fe76f393e665d70 Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Tue, 8 Nov 2011 14:40:18 +0000
+Subject: [PATCH] Fix Python code when _bestPackageFromList returns None.
+
+Yet Another Bug caused by lack of strong typing and nullable types in
+this sad excuse for a programming language.
+---
+ src/febootstrap_yum_rpm.ml |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/febootstrap_yum_rpm.ml b/src/febootstrap_yum_rpm.ml
+index bfda11e..1def619 100644
+--- a/src/febootstrap_yum_rpm.ml
++++ b/src/febootstrap_yum_rpm.ml
+@@ -78,7 +78,7 @@ while not stable:
+             for r in pkg.requires:
+                 ps = yb.whatProvides (r[0], r[1], r[2])
+                 best = yb._bestPackageFromList (ps.returnPackages ())
+-                if best.name != pkg.name:
++                if best and best.name != pkg.name:
+                     deps[pkg].append (best)
+                     if not deps.has_key (best):
+                         deps[best] = False
+-- 
+1.7.6
+
diff --git a/febootstrap.spec b/febootstrap.spec
new file mode 100644 (file)
index 0000000..cb2bad9
--- /dev/null
@@ -0,0 +1,79 @@
+Summary:       Bootstrapping tool for creating supermin appliances
+Name:          febootstrap
+Version:       3.12
+Release:       1
+License:       GPL v2
+Group:         Applications
+Source0:       http://people.redhat.com/~rjones/febootstrap/files/%{name}-%{version}.tar.gz
+# Source0-md5: 8d0143c96c538909bf0bbc13d09604c4
+Patch0:                0001-Fix-Python-code-when-_bestPackageFromList-returns-No.patch
+URL:           http://people.redhat.com/~rjones/febootstrap/
+BuildRequires: ocaml >= 3.04-7
+BuildRequires: ocaml-findlib
+BuildRequires: e2fsprogs-devel
+BuildRequires: libcom_err-devel
+BuildRequires: zlib-devel
+BuildRequires: perl-perldoc
+BuildRequires: gawk
+Suggests:      yum >= 3.2
+Suggests:      yum-utils
+Suggests:      qemu
+Suggests:      filelight
+Requires:      %{name}-supermin-helper = %{version}-%{release}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Febootstrap is a tool for building supermin appliances.
+These are tiny appliances [similar to virtual machines], usually
+around 100KB in size, which get fully instantiated on-the-fly
+in a fraction of a second when you need to boot one of them.
+
+Currently we support Fedora and Debian.
+We hope to support many other distros in future. 
+
+%package supermin-helper
+Summary:       Runtime support for febootstrap
+Group:         Development/Tools
+Requires:      util-linux
+Requires:      cpio
+Requires:      /sbin/mke2fs
+
+%description supermin-helper
+This package contains the runtime support for febootstrap.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%configure \
+       YUM="yum" \
+       RPM="rpm" \
+       YUMDOWNLOADER="yumdownloader" \
+       APTITUDE="aptitude" \
+       APT_CACHE="apg-cache" \
+       DPKG="dpkg" \
+       PACMAN="pacman"
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(755,root,root) %{_bindir}/febootstrap
+%{_mandir}/man8/febootstrap.8*
+
+%files supermin-helper
+%defattr(644,root,root,755)
+%doc helper/README
+%attr(755,root,root) %{_bindir}/febootstrap-supermin-helper
+%{_mandir}/man8/febootstrap-supermin-helper.8*
This page took 0.062057 seconds and 4 git commands to generate.